在线检测未来函数

通达信王者归来K线主图指标公式

来源:Internet,编辑:股旁网,2022-05-12

是否创业:=IF(CODELIKE('300') OR CODELIKE('301') ,1,0);
是否科创:=IF(CODELIKE('688') OR CODELIKE('689'),1,0);
涨停价格10:=ZTPRICE(REF(CLOSE,1),0.1);
涨停价格20:=ZTPRICE(REF(CLOSE,1),0.2);
跌停价格10:=DTPRICE(REF(CLOSE,1),0.1);
跌停价格20:=DTPRICE(REF(CLOSE,1),0.2);
非上市首日:=BArslAst(DATE<>REF(DATE,1))+1;
涨停:=C=涨停价格10 OR C=涨停价格20;
STICKLINE(涨停,OPEN,CLOSE,2.95,0),COLORRED;
跌停:=C=跌停价格10 OR C=跌停价格20;
STICKLINE(跌停 AND C<>O,OPEN,CLOSE,2.95,0),COLORBLUE;
二一位:IF(C>O,(C-O)*0.5+O,(O-C)*0.5+C),NODRAW,COLORRED;
三一位:O+(C-O)*2/3,NODRAW,COLORRED;
涨停价格:=IF(是否创业 OR 是否科创,ZTPRICE(C,0.2), ZTPRICE(C,0.1));
明日涨停:涨停价格,NODRAW,COLORRED;
{板块信息}
DRAWTEXT_FIX(ISLASTBAR,0,1,0,HYBLOCK),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.1,1,0,GNBLOCK),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.05,1,0,DYBLOCK),COLORRED;
是否触及跌停:=L <= 跌停价格10;
实体是否是阴:=C<O;
STICKLINE(是否触及跌停 AND 实体是否是阴,C,L,0.01,0),COLORBLUE;
STICKLINE(是否触及跌停 AND 实体是否是阴,OPEN,CLOSE,2.95,0),COLORBLUE;
低开高走:=C>O;
假阳1:=C<REF(C,1) AND 低开高走 AND 非上市首日;
假阳2:=AMOUNT/V/100<REF(C,1) AND AMOUNT/V/100>(REF(C,1)/10) AND O<REF(C,1) AND NOT(假阳1) AND 低开高走 AND 非上市首日;
量柱:=C>REF(C,1) AND V >= REF(V,1)*2 AND V < REF(V,1)*3 AND C>O AND NOT(假阳1) AND NOT(假阳2);
STICKLINE(倍量柱,OPEN,CLOSE,2.95,0),COLOR0099FF;
高开低走:=C<O;
假阴1:=C>REF(C,1) AND 高开低走;
假阴2:=AMOUNT/V/100>REF(C,1) AND O>REF(C,1) AND NOT(假阴1) AND 高开低走;
前日涨停:=REF(CLOSE,1)>=ZTPRICE(REF(CLOSE,2),0.1);
STICKLINE(假阴1 AND 前日涨停,OPEN,CLOSE,2.95,0),COLORmaGENTA;
STICKLINE(假阴2 AND 前日涨停,OPEN,CLOSE,2.95,0),COLORMAGENTA;
{低开高走:=C>O;
假阳1:=C<REF(C,1) AND 低开高走 AND 非上市首日;
假阳2:=AMOUNT/V/100<REF(C,1) AND AMOUNT/V/100>(REF(C,1)/10) AND O<REF(C,1) AND NOT(假阳1) AND 低开高走 AND 非上市首日;
STICKLINE(假阳1,OPEN,CLOSE,2.95,0),COLOR00CCFF;
STICKLINE(假阳2,OPEN,CLOSE,2.95,0),COLOR00CCFF;}
是否板枪:=H >= 涨停价格10;
实体是否是阳:=C>O;
STICKLINE(是否板枪 AND 实体是否是阳,C,H,0.01,0),COLORRED;
STICKLINE(是否板枪 AND 实体是否是阳,OPEN,CLOSE,2.95,0),COLORRED;
{二一位画线}
FLAG:=Abs(C-O)/IF((H-L) = 0,100,H-L);
ZHANGF:=ABS(C-O)/O;
STICKLINE(ZHANGF>=0.03 && FLAG >= 0.03,二一位,二一位,-1,0),COLORLIRED;
跳空:=C>O AND O>=REF(MAX(C,O),1)+0.01 OR O>=REF(C,1)+0.01 AND C!=O;
STICKLINE(跳空, O,(C-O)*0.01+O,-1,0),COLORBLUE;

通达信王者归来K线主图指标公式

相关文章