在线检测未来函数

通达信阳信号选股指标公式

来源:Internet,编辑:股旁网,2022-05-12

VAR2T:=(100-((90*(HHV(HIGH,21)-CLOSE))/(HHV(HIGH,21)-LLV(LOW,21))));
VAR3T:=(100-ma(((100*(HHV(HIGH,6)-CLOSE))/(HHV(HIGH,6)-LLV(LOW,6))),34));
YDZF:=(C-REF(C,1))/REF(C,1)*100;
VARA:=C>REF(C,1) AND C>REF(C,2);
VARB:=C<REF(C,1) AND C<REF(C,2);
VAR1:=REF(VARB,1) AND C>=REF(C,1) AND C<=REF(C,2);
VAR2:=REF(VAR1,1) AND C<=REF(C,1) AND C>=REF(C,2);
VAR3:=REF(VAR2,1) AND C>=REF(C,1) AND C<=REF(C,2);
VAR4:=REF(VAR3,1) AND C<=REF(C,1) AND C>=REF(C,2);
VAR5:=REF(VAR4,1) AND C>=REF(C,1) AND C<=REF(C,2);
VAR6:=REF(VAR5,1) AND C<=REF(C,1) AND C>=REF(C,2);
VAR7:=REF(VAR6,1) AND C>=REF(C,1) AND C<=REF(C,2);
VAR8:=REF(VAR7,1) AND C<=REF(C,1) AND C>=REF(C,2);
VAR9:=REF(VAR8,1) AND C>=REF(C,1) AND C<=REF(C,2);
VAR10:=REF(VAR9,1) AND C<=REF(C,1) AND C>=REF(C,2);
VAR11:=REF(VAR10,1) AND C>=REF(C,1) AND C<=REF(C,2);
JIN:=VARB OR VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VAR10 OR VAR11;
阳信号:=VARA AND REF(JIN,1);
MID:=REF(HIGH+LOW,1)/2;
cr:=SUM(MAX(0,HIGH-MID),26)/SUM(MAX(0,MID-LOW),26)*100;
XG:CROSS(VAR2T,VAR3T) AND 阳信号 AND CR>REF(CR,1) AND YDZF>5 AND REF(CLOSE,1)<REF(OPEN,1) AND REF(CLOSE,1)>OPEN AND CLOSE>REF(OPEN,1) AND CLOSE/REF(CLOSE,1)>1.02;

通达信阳信号选股指标公式

相关文章