在线检测未来函数

通达信王者VOL指标公式

来源:Internet,编辑:股旁网,2022-05-13

M1:=5;
M2:=10;
非上市首日:=BArslAst(DATE<>REF(DATE,1))+1;
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
Vvol:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1) && FROMOPEN > 60,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
{maVOL1:MA(VOLUME,M1);
MAVOL2:MA(VOLUME,M2);}
跌停价格10:=DTPRICE(REF(CLOSE,1),0.1);
跌停价格20:=DTPRICE(REF(CLOSE,1),0.2);
跌停:=C=跌停价格10 OR C=跌停价格20;
STICKLINE(跌停,VOL,0,-1,0),COLORBLUE;
是否触及跌停:=L <= 跌停价格10;
实体是否是阴:=C<O;
STICKLINE(是否触及跌停 AND 实体是否是阴,VOL,0,-1,0),COLORBLUE;
量柱:=C>REF(C,1) AND V >= REF(V,1)*2 AND V < REF(V,1)*3 AND C>O;
STICKLINE(倍量柱,VOL,0,-1,0),COLOR0099FF;
TJ:=C<O;
TJ1:=C>REF(C,1) AND TJ;
TJ2:=AMOUNT/V/100>REF(C,1) AND O>REF(C,1) AND NOT(TJ1) AND TJ;
前日涨停:=REF(CLOSE,1)>=ZTPRICE(REF(CLOSE,2),0.1);
STICKLINE(TJ1 AND 前日涨停,VOL,0,-1,0),COLORMAGENTA;
STICKLINE(TJ2 AND 前日涨停,VOL,0,-1,0),COLORMAGENTA;
{低开高走:=C>O;
假阳1:=C<REF(C,1) AND 低开高走 AND 非上市首日;
假阳2:=AMOUNT/V/100<REF(C,1) AND AMOUNT/V/100>(REF(C,1)/10) AND O<REF(C,1) AND NOT(假阳1) AND 低开高走 AND 非上市首日;
STICKLINE(假阳1,VOL,0,-1,0),COLOR00CCFF;
STICKLINE(假阳2,VOL,0,-1,0),COLOR00CCFF;}
涨停价格10:=ZTPRICE(REF(CLOSE,1),0.1);
涨停价格20:=ZTPRICE(REF(CLOSE,1),0.2);
是否板枪:=H >= 涨停价格10;
实体是否是阳:=C>=O;
TJ3:=是否板枪 AND 实体是否是阳 AND PERIOD = 5;
STICKLINE(TJ3,VOL,0,-1,0),COLORRED;
{DRAWICON(TJ1,H,1);
DRAWICON(TJ2,H,5);};
SL1TJ:=V=LLV(V,100) AND BARSCOUNT(V)>10;
SL2TJ:=V<REF(V,1)/2 AND NOT(SL1TJ);
SDI:=IF(C>O,O,C);
SDING:=IF(C>O,C,O);
SL3TJ:=V<REF(V,1)/1.5 AND NOT(SL2TJ) AND NOT(SL1TJ);{ AND SDI>REF((SDING-SDI)/1.5+SDI,1);}
DRAWTEXT(SL3TJ,V*0.95,'3'),DRAWAbovE,COLORRED;
DRAWTEXT(SL2TJ,V*0.95,'2'),DRAWABOVE,COLORRED;
DRAWTEXT(SL1TJ,V*0.95,'1'),DRAWABOVE,COLORRED;

通达信王者VOL指标公式

相关文章