在线检测未来函数

通达信趋势好帮手主图指标公式

来源:Internet,编辑:股旁网,2022-05-24

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1006”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

SJTJ:=DATE<1590301;
AA:=Abs((2*CLOSE+HIGH+LOW)/4-ma(CLOSE,30))/MA(CLOSE,30);
长期趋势线:=DMA((2*CLOSE+LOW+HIGH)/4,AA);
CC:=(CLOSE/长期趋势线);
MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);
MAAA:=((MA1-长期趋势线)/长期趋势线)/3;
TMP:=MA1-MAAA*MA1;
长期趋势上升:IF(TMP>长期趋势线 ,长期趋势线,DRAWNULL),LINETHICK4,COLORRED;
HZS:=crOSS(TMP,长期趋势线);
LZS:=CROSS(长期趋势线,TMP);
DRAWICON(HZS,长期趋势线-0.1,23);
DRAWICON(LZS,长期趋势线+0.1,24);
{DRAWICON(TMP<=长期趋势线 AND NOT(LZS),长期趋势线-0.1,14)};
{DRAWICON(TMP>长期趋势线 AND NOT(HZS),长期趋势线+0.1,13)};
MAH:=(H*18+REF(H,1)*17+REF(H,2)*16+REF(H,3)*15+REF(H,4)*14+REF(H,5)*13+REF(H,6)*12+REF(H,7)*11+REF(H,8)*10+REF(H,9)*9+REF(H,10)*8+REF(H,11)*7+REF(H,12)*6+REF(H,13)*5+REF(H,14)*4+REF(H,15)*3+REF(H,16)*2+REF(H,17)*1)/171;
MAL:=(L*18+REF(L,1)*17+REF(L,2)*16+REF(L,3)*15+REF(L,4)*14+REF(L,5)*13+REF(L,6)*12+REF(L,7)*11+REF(L,8)*10+REF(L,9)*9+REF(L,10)*8+REF(L,11)*7+REF(L,12)*6+REF(L,13)*5+REF(L,14)*4+REF(L,15)*3+REF(L,16)*2+REF(L,17)*1)/171;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
DK:= SJTJ AND( CLOSE>=MAH OR (C>MA5 AND C>MA10 AND C>MA20 AND C>MA60));
KK:= SJTJ AND( MAL>CLOSE OR (C<MA5 AND C<MA10 AND C<MA20 AND C<MA60));
DK1:=BArslAst(DK);
KK1:=BARSLAST(KK);
DK2:=BARSLAST(CROSS(KK1,DK1));
KK2:=BARSLAST(CROSS(DK1,KK1));
HS:=DK2<KK2;
LS:=KK2<DK2;
W2:=OPEN-CLOSE;
HT:=IF(OPEN>CLOSE,OPEN,CLOSE);
LT:=IF(OPEN<CLOSE,OPEN,CLOSE);
趋势线:=(MAH+MAL)/2 COLORGREEN,,LINETHICK2;
中级趋势上升:IF(HS,趋势线,DRAWNULL),LINETHICK2,COLORGREEN;

通达信趋势好帮手主图指标公式

相关文章