在线检测未来函数

通达信回踩支撑位主图指标公式

来源:Internet,编辑:股旁网,2022-05-25

A1:=REF(C,7)=HHV(C,2*7+1);
B1:=FILTER(A1,7);
C1:=BacKSET(B1,7+1);
D1:FILTER(C1,7),NODRAW;{高点}
A2:=REF(L,7)=LLV(L,2*7+1);
B2:=FILTER(A2,7);
C2:=BACKSET(B2,7+1);
D2:FILTER(C2,7),NODRAW;{低点}
E1:=(REF(LLV(L,2*7),1)+REF(HHV(C,2*7),1))/2;
E2:=(H+L)/2;{高低点出现在同一k线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLAstBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BArslAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1),LINETHICK0;{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,C,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1),LINETHICK0;{过滤后高点}
R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);
S1:R1>REF(R1,1),NODRAW; {前一高}
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);
S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2);
U3:=T3>REF(T3,1); {前三低}
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2);
U4:=T4>REF(T4,1); {前四低}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2);
S3:=R3>REF(R3,1); {前三高}
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2);
S4:=R4>REF(R4,1); {前四高}
压力1:=DRAWLINE(S2,C,S1,C,1),COLORmaGENTA,LINETHICK1;
压力2:=DRAWLINE(S3,C,S2,C,1),COLORFF8000;
压力3:=DRAWLINE(S4,C,S3,C,1),COLOR0000FF;
支撑1:=DRAWLINE(U2,L,U1,L,1),COLOR8FBC8F,LINETHICK1;
支撑2:=DRAWLINE(U3,L,U2,L,1),COLOR99CC32;
支撑3:=DRAWLINE(U4,L,U3,L,1),COLOR00FF7F;
{DRAWICON(S2,H*1.01,10);
DRAWICON(S3,H*1.01,10);}
DRAWNUMBER(S2,H*1.024,C),COLORWHITE;
DRAWNUMBER(S1,H*1.024,C),COLORWHITE;
DRAWNUMBER(S3,H*1.024,C),COLORWHITE;
DRAWNUMBER(S4,H*1.024,C),COLORWHITE;
DRAWNUMBER(U1,L*0.99,L),COLORWHITE;
DRAWNUMBER(U2,L*0.99,L),COLORWHITE;
DRAWNUMBER(U3,L*0.99,L),COLORWHITE;
DRAWICON(U1,L*0.99,11);
回踩点:DRAWLINE(S1,C,REF(S1,1),REF(C,1),1)COLORRED,DOTLINE;
压力位:DRAWLINE(S2,C,REF(S2,1),REF(C,1),1)COLORMAGENTA,DOTLINE;
二高:=DRAWLINE(S3,C,REF(S3,1),REF(C,1),1)COLORLIRED,DOTLINE;
破位:DRAWLINE(U1,L,REF(U1,1),REF(L,1),1)COLORGREEN,DOTLINE;
支撑位:DRAWLINE(U2,L,REF(U2,1),REF(L,1),1)COLORLIBLUE,DOTLINE;
A点:=DRAWLINE(U3,L,REF(U3,1),REF(L,1),1)COLORLICYAN,DOTLINE;

通达信回踩支撑位主图指标公式

相关文章