在线检测未来函数

通达信顶底决策主图指标公式

来源:Internet,编辑:股旁网,2022-05-30

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1006”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

AA:=(H+L+2*C+O)/5;
VAR60:=Ema(AA,40);
VAR10:=EMA(AA,20);
{上轨:VAR60+2.3*stD(CLOSE,60),COLORGREEN,LINETHICK2;
下轨:VAR60-2.3*STD(CLOSE,60),COLORRED,LINETHICK2;
次上轨:VAR10+2.2*STD(CLOSE,10),DOTLINE,COLORFF9900;
次下轨:VAR10-2.2*STD(CLOSE,10),DOTLINE,COLORYELLOW;}
VAR2:=CLOSE*vol;
VARR:=EMA((EMA(VAR2,5)/EMA(VOL,5)+EMA(VAR2,10)/EMA(VOL,10)+EMA(VAR2,20)/EMA(VOL,20)+EMA(VAR2,40)/EMA(VOL,40))/4,15);
上轨:VARR*1.3,COLORGREEN,LINETHICK2;
下轨:VARR*0.8,COLORRED,LINETHICK2;
次上轨:VARR*1.1,DOTLINE,COLORFF9900;
次下轨:VARR*0.9,DOTLINE,COLORYELLOW;
{STICKLINE(LOW<=下轨 AND CLOSE>OPEN,CLOSE, OPEN,3,0.5),COLORMAGENTA;
STICKLINE(LOW<=下轨 AND CLOSE>OPEN,CLOSE, HIGH,0,0.5),COLORMAGENTA;
STICKLINE(LOW<=下轨 AND CLOSE>OPEN,OPEN, LOW,0,0.5),COLORMAGENTA;
STICKLINE(LOW<=下轨 AND CLOSE<=OPEN,CLOSE, OPEN,3,0),COLORMAGENTA;
STICKLINE(LOW<=下轨 AND CLOSE<=OPEN,CLOSE, LOW,0,0),COLORMAGENTA;
STICKLINE(LOW<=下轨 AND CLOSE<=OPEN,OPEN, HIGH,0,0),COLORMAGENTA;
STICKLINE(HIGH>=上轨 AND CLOSE>OPEN,CLOSE, OPEN,3,0.5),COLORFF9900;
STICKLINE(HIGH>=上轨 AND CLOSE>OPEN,CLOSE, HIGH,0,0.5),COLORFF9900;
STICKLINE(HIGH>=上轨 AND CLOSE>OPEN,OPEN, LOW,0,0.5),COLORFF9900;
STICKLINE(HIGH>=上轨 AND CLOSE<=OPEN,CLOSE, OPEN,3,0),COLORFF9900;
STICKLINE(HIGH>=上轨 AND CLOSE<=OPEN,CLOSE, LOW,0,0),COLORFF9900;
STICKLINE(HIGH>=上轨 AND CLOSE<=OPEN,OPEN, HIGH,0,0),COLORFF9900;}
DRAWTEXT(FILTER((crOSS(次上轨,CLOSE) OR (H>次上轨 AND C<次上轨) AND C<=REF(C,1)),7),HIGH*1.01,'小顶'),COLORFF9900;
DRAWTEXT(FILTER((CROSS(CLOSE,次下轨) OR (L<次下轨 AND C>次下轨) AND C>REF(C,1)),7),LOW*0.99,'小底'),COLORYELLOW;
DRAWTEXT(FILTER((CROSS(上轨,CLOSE) OR (H>上轨 AND C<上轨) AND C<=REF(C,1)),5),HIGH*1.01,'大顶'),COLORGREEN;
DRAWTEXT(FILTER((CROSS(CLOSE,下轨) OR (L<下轨 AND C>下轨) AND C>REF(C,1)),5),LOW*0.99,'大底'),COLORRED;
VAW1:=EMA(EMA(CLOSE,13),13);
VAW2:=(VAW1-REF(VAW1,1))/REF(VAW1,1)*1000;
VAW3:=DYNAINFO(11);
VAW4:=(EMA(CLOSE,8)-EMA(CLOSE,21))*50;
VAW5:=EMA(VAW4,3);
VAW6:=(C-VAW3)/VAW3<-0.03;
VAW7:=VAW2>REF(VAW2,1) AND VAW2<-0.2;
VAW8:=CROSS(VAW4,VAW5) AND VAW4<-0.3;
VAW9:=VAW6 AND VAW7 AND VAW8;
VAW10:=FILTER(VAW9,30);
DRAWTEXT(VAW10,L-0.0011,'庄进'),COLORMAGENTA;

通达信顶底决策主图指标公式

相关文章