在线检测未来函数

通达信K线叠加概念主图指标公式

来源:Internet,编辑:股旁网,2022-06-07

M1:=5;
M2:=10;
M3:=20;
M4:=60;
M5:=0;
M6:=0;
ma5:MA(CLOSE,M1);
MA10:MA(CLOSE,M2);
MA20:MA(CLOSE,M3);
MA60:MA(CLOSE,M4);
MA120:MA(CLOSE,M5);
DRAWKLINE(H,O,L,C);
DRAWTEXT_FIX(ISLAstBAR,0,0.1,0,GNBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.00,0,0,' '),COLORFF60FF;
DRAWTEXT_FIX(1,0.03,0,0,HYBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.05,0,0,' '),COLOR6F59FF;
DRAWTEXT_FIX(1,0.08,0,0,DYBLOCK),COLORWHITE;
AAA1:=STRCAT(' ',CON2STR(DYNAINFO(60),0));
AAA2:=STRCAT(' ',CON2STR(DYNAINFO(61),0));
DRAWTEXT_FIX(ISLASTBAR,0,0,0,AAA1),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,AAA2),COLORGREEN;
BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板'),0.2,IF(INBLOCK('ST板块'),0.05,0.1)));
XA_1:=IF(DATE<=1200823,1,1);
涨停:=(C>=ZTPRICE(REF(CLOSE,1),0.1) AND C=H) AND XA_1=1;
跌停:=(C<=DTPRICE(REF(CLOSE,1),0.1) AND C=L) AND XA_1=1;
涨停:=C>=ZTPRICE(REF(C,1),BK) AND C=H;
跌停:=C<=DTPRICE(REF(C,1),BK) AND C=L;
曾涨停:=(H>=ZTPRICE(REF(C,1),BK) AND C<H) OR (H>=ZTPRICE(REF(CLOSE,1),0.1) AND C<H AND XA_1=1);
曾跌停:=(L<=DTPRICE(REF(C,1),BK) AND C>L) OR (L<=DTPRICE(REF(CLOSE,1),0.1) AND C>L AND XA_1=1);
STICKLINE(旧涨停 AND PERIOD=5,O,C,4,0),COLORYELLOW;
STICKLINE(旧跌停 AND PERIOD=5,O,C,4,0),COLORGREEN;
STICKLINE(涨停 AND PERIOD=5,C,O,2.7,0),COLORYELLOW;
STICKLINE(跌停 AND PERIOD=5,C,O,2.7,0),COLORGREEN;
STICKLINE(曾涨停 AND PERIOD=5,H,L,0.1,0),COLORYELLOW;{涨停后回落}
STICKLINE(曾跌停 AND PERIOD=5,L,H,0.1,0),COLORGREEN;{跌停后回升}
DRAWTEXT(旧涨停 AND PERIOD=5,L-0.1,''),COLORYELLOW;
DRAWTEXT(旧跌停 AND PERIOD=5,H+0.2,''),COLORGREEN;
DRAWTEXT(涨停 AND PERIOD=5,L-0.1,''),COLORYELLOW;
DRAWTEXT(跌停 AND PERIOD=5,H+0.2,''),COLORGREEN;
DRAWTEXT(曾涨停 AND PERIOD=5,H+0.2,''),COLORGREEN;
DRAWTEXT(曾跌停 AND PERIOD=5,L-0.08,' '),COLORYELLOW;

通达信K线叠加概念主图指标公式

相关文章