在线检测未来函数

通达信八仙过海排序指标公式

来源:Internet,编辑:股旁网,2022-06-17

今开:100*(DYNAINFO(4)-DYNAINFO(3))/DYNAINFO(3),NODRAW;
XM_1:=IF(FINANCE(3)=4 OR (FINANCE(3)=3 AND DATE>=1200824),1.2,1.1);
XM_2:=CLOSE=HIGH AND CLOSE>REF(CLOSE,1)*XM_1-0.01;
昨几板:REF(BArslAstCOUNT(XM_2),1);
连板数:BARSLASTCOUNT(C>=REF(C,1)*1.095 AND C=H);
开盘金额:=DYNAINFO(15)/10000,NODRAW;
A2A:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100;
A1A:=REF(H,20)=HHV(H,2*20+1);
B1A:=FILTER(A1A,10);
C1A:=BacKSET(B1A,10+1);
D1A:=FILTER(C1A,10);
R11:=BACKSET(ISLASTBAR,BARSLAST(D1A)+1);
S11:=R11>REF(R11,1);
E2A:=DRAWLINE(D1A,H,S11,H,1),COLORRED,LINETHICK2;
B2A:=DYNAINFO(15)/REF(AMOUNT,1)*100>8;
D2A:=crOSS(O,REF(E2A,1)) AND REF(CLOSE,1)<REF(E2A,1);
突破压力:BETWEEN(A2A,2,8) AND B2A AND D2A ;
X1:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100;
TM:=1200823;{注册制}
ZT:=C>=IF(DATE<TM,ZTPRICE(REF(C,1),IF(CODELIKE('688'),0.2,IF(NAMEINCLUDE('S'),0.05,0.1))),ZTPRICE(REF(C,1),IF(CODELIKE('688') OR CODELIKE('300'),0.2,IF(NAMEINCLUDE('S'),0.05,0.1))));
X2:=BARSLASTCOUNT(ZT);
X3:=REF(X2,1)=1;
X4:=REF(X2,20)>=1;
A:=(CLOSE-REF(C,1))/REF(C,1)*100;
B:=REF(A-REF(A,1),1);
竞一:RANGE(X1,3,7) AND B>8 AND X3;
XA1:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100;
ZTJ:=IF(FINANCE(3)=3 OR FINANCE(3)=4,ZTPRICE(REF(C,1),0.2),ZTPRICE(REF(C,1),0.1));
ZTA:=ZTJ=C;
XA2:=BARSLASTCOUNT(ZTA);
XA3:=REF(XA2,1);
D1:=DYNAINFO(15)/10000>2850;
精一:RANGE(XA1,3,7) AND REF(XA1,1)<3 AND XA3=1 AND D1;
X_1:=(Ema(CLOSE,8)-EMA(CLOSE,55))*10;
X_2:=EMA(X_1,5);
X_3:=REF(CROSS(X_1,X_2) AND X_1>0,1);
X_4:=DYNAINFO(15)/REF(AMOUNT,1)*100;
抓妖:RANGE(X1,3,7) AND X_3 AND X_4>5;
XB1:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100;
MA1:=MA(CLOSE,5),LINETHICK2,COLORYELLOW;
AB:=DYNAINFO(15)/10000;
BB:=DYNAINFO(15)/OPEN/FINANCE(46)*100;
DB:=REF(V*10000/FINANCE(46),1);
EB:=BB/DB*100;
简单牛:BETWEEN(XB1,3,7) AND CROSS(O,REF(MA1,1)) AND EB>10;
XC_1:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100;
XC_2:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
XC_3:=REF(SMA(XC_2,3,1),1);
智能:=(DYNAINFO(15)/DYNAINFO(4)/10/REF(V,1)-1)*(O-REF(C,1))/REF(C,1)*-1000;{智勇/能量};
JD10:=REF(ATAN((EMA(CLOSE,10)/REF(EMA(CLOSE,10),1)-1)*100)*180/3.1416,1);
量比:=(DYNAINFO(15)/DYNAINFO(4))/REF(MA(V,5),1)*2.4;
一箭:BETWEEN(XC_1,3,7) AND BETWEEN(XC_3,20,70) AND JD10>20 AND 量比>13 AND 智能>31;
XD_1:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100;
XD_2:=vol/((HIGH-LOW)*2-Abs(CLOSE-OPEN))/10000;
XD_3:=REF(IF(CLOSE>OPEN,XD_2*(HIGH-LOW),IF(CLOSE<OPEN,XD_2*(HIGH-OPEN+CLOSE-LOW),VOL/2))
+IF(CLOSE>OPEN,0-XD_2*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-XD_2*(HIGH-LOW),0-VOL/2)),1);
XD_5:=DYNAINFO(15)/OPEN/(REF(SUM(VOL,5),1)/12);
高开:=BETWEEN(XD_1,3,7) AND XD_3>5 AND XD_5>57;
低开:=BETWEEN(XD_1,-6,0) AND XD_3>150 AND XD_5>4;
双箭:高开 OR 低开;
XE_1:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100;
XE_2:=REF(VOL,1)>REF(VOL,2)*1.2 AND REF(CLOSE>OPEN AND 10000*VOL/FINANCE(7)>5,1);
XE_3:=REF(ATAN((EMA(VOL,5)/REF(EMA(VOL,5),1)-1)*100)*90/3.14,1)>44.43;
擒牛:BETWEEN(XE_1,3,7) AND XE_2 AND XE_3;
八仙过海:竞一+精一+抓妖+简单牛+一箭+双箭+擒牛;
ZY1:=CLOSE/INDEXC*1000;
P1:=IF(ZY1=HHV(ZY1,3),10,0);
P2:=IF(ZY1=HHV(ZY1,5),15,0);
P3:=IF(ZY1=HHV(ZY1,10),20,0);
P4:=IF(ZY1>REF(ZY1,1),10,0);
P5:=IF(ZY1>REF(ZY1,1),5,0);
P6:=IF(REF(ZY1,1)>REF(ZY1,2),5,0);
P7:=IF(REF(ZY1,2)>REF(ZY1,3),5,0);
P8:=IF(REF(ZY1,3)>REF(ZY1,4),5,0);
P9:=IF(REF(ZY1,4)>REF(ZY1,5),5,0);
P10:=IF(REF(ZY1,5)>REF(ZY1,6),5,0);
P11:=IF(REF(ZY1,6)>REF(ZY1,7),5,0);
P12:=IF(REF(ZY1,7)>REF(ZY1,8),5,0);
P13:=IF(REF(ZY1,8)>REF(ZY1,9),5,0);
强势股评分:P1+P2+P3+P4+P5+P6+P7+P8+P9+P10+P11+P12+P13;

通达信八仙过海排序指标公式

相关文章