在线检测未来函数

通达信多空资金速升指标公式

来源:Internet,编辑:股旁网,2022-06-20

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1006”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

VAR1:=vol/((HIGH-LOW)*2-Abs(CLOSE-OPEN));
主买:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主卖:=IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2));
主力买入量:=(主买*0.5+主卖*0.1)/2;
ZL:SUM(主力买入量,60)/SUM(V,60)*100,LINETHICK2;
DT:=ZL-REF(ZL,1);
stICKLINE(DT>0,ZL,ZL+DT,1,0),COLORRED;
STICKLINE(DT<0,ZL+DT,ZL,1,0),COLORGREEN;
Ema3:EMA(ZL,3),COLORRED,LINETHICK2;
EMA6:EMA(ZL,6),COLORFF00FF;
EMA9:EMA(ZL,9),COLORYELLOW;
EMA12:EMA(ZL,15),COLORFFCC66;
EMA25:EMA(ZL,25),COLORFFFF80;
均:=(EMA3+EMA6+EMA9+EMA12+EMA25)/5,COLORMAGENTA,LINETHICK3;
量价线:EMA(均,5),,COLORMAGENTA,LINETHICK3;
Z1:EMA(量价线,3),DOTLINE,COLORRED;
Z2:EMA(量价线,5),DOTLINE,COLORRED;
Z3:EMA(量价线,7),DOTLINE,COLORRED;
Z4:EMA(量价线,9),DOTLINE,COLORRED;
Z5:EMA(量价线,11),DOTLINE,COLORRED;
Z6:EMA(量价线,13),DOTLINE,COLORRED;
Z7:EMA(量价线,20),DOTLINE,COLORYELLOW;
Z8:EMA(量价线,25),DOTLINE,COLORYELLOW;
Z9:EMA(量价线,30),DOTLINE,COLORYELLOW;
Z10:EMA(量价线,35),DOTLINE,COLORYELLOW;
Z11:EMA(量价线,40),DOTLINE,COLORGREEN;
Z12:EMA(量价线,45),DOTLINE,COLORGREEN;
Z13:EMA(量价线,50),DOTLINE,COLORGREEN;
Z14:EMA(量价线,55),DOTLINE,COLORGREEN;
Z15:EMA(量价线,60),DOTLINE,COLORGREEN;
ZDZL:=ATAN((ZL/REF(ZL,1)-1)*100)*180/3.1416;
ZD3:=ATAN((EMA3/REF(EMA3,1)-1)*100)*180/3.1416;
ZD6:=ATAN((EMA6/REF(EMA6,1)-1)*100)*180/3.1416;
ZD9:=ATAN((EMA9/REF(EMA9,1)-1)*100)*180/3.1416;
ZD12:=ATAN((EMA12/REF(EMA12,1)-1)*100)*180/3.1416;
ZD25:=ATAN((EMA25/REF(EMA25,1)-1)*100)*180/3.1416;
D:=MAX(MAX(EMA3,EMA6),MAX(MAX(EMA9,EMA12),EMA25));
X:=MIN(MIN(EMA3,EMA6),MIN(MIN(EMA9,EMA12),EMA25));
N:=(D-X)/X*100<2;
DRAWTEXT(N,ZL,'▲'),COLORRED;
J:=crOSS(ZL,EMA3) AND CROSS(ZL,EMA6) AND CROSS(ZL,EMA9) AND CROSS(ZL,EMA12) AND CROSS(ZL,EMA25);
S:=ZL>REF(ZL,1) AND EMA3>REF(EMA3,1) AND EMA9>REF(EMA9,1) AND EMA12>REF(EMA12,1) AND EMA25>REF(EMA25,1);
多:=ZL>EMA3 AND EMA3>EMA6 AND EMA6>EMA9 AND EMA9>EMA12 AND EMA12>EMA25;
小多:=ZL>EMA3 AND EMA3>EMA6 AND EMA6>EMA9 AND EMA9>EMA12 ;
DRAWICON( 小多 AND EXIST(CROSS(ZL,EMA3),3) AND DT>0 AND EXIST(N,3),ZL,30);
XJ:=CROSS(ZL,EMA3) AND CROSS(ZL,EMA6) AND CROSS(ZL,EMA9) AND CROSS(ZL,EMA12) AND REF(DT,1)<0 AND DT>0;
DRAWTEXT(XJ,ZL+0.2,'★速升'),COLORRED;

通达信多空资金速升指标公式

相关文章