在线检测未来函数

通达信大阳主图指标公式

来源:Internet,编辑:股旁网,2022-06-21

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1006”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

M1:=100;
PE:DYNAINFO(39),NODRAW;
EPSRATE:=FINANCE(43);
PEG: DYNAINFO(39)/FINANCE(43),NODRAW;
涨停价:ZTPRICE(REF(CLOSE,1),0.1),NODRAW;
明日涨停价:C*1.1,NODRAW;
DRAWTEXT_FIX(1,0.01,0.05,0,'主题投资:')COLOR0000FF;
DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNstR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.01,0.15,0,'主营业务:')COLORFF00FF;
DRAWTEXT_FIX(1,0.06,0.15,0,EXTERNSTR(0,2))COLORFF00FF;
XA_11:=0.01;
XA_12:=0.00;
XA_13:=0.04;
DRAWTEXT_FIX(ISLASTBAR,XA_11,XA_12,0,STRCAT(STRSPacE(DYBLOCK),HYBLOCK)),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,XA_11,XA_12+XA_13*2.5,0,GNBLOCK),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,XA_11,XA_12+XA_13*5,0,FGBLOCK),COLORYELLOW;
CY:=BArslAST(CURRBARSCOUNT=100);
DX:=CONST(IF(ISLASTBAR=1,LLV(L,CY),0));
GX:=CURRBARSCOUNT<=100,DX+macd*1.5;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
AA5:=ma(CLOSE,5),COLOR0000FF;
AA10:=MA(CLOSE,10),COLOR0000FF;
BB10:=((ATAN((AA5 - REF(AA5,1))) * 3.1416) * 10);
BB12:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);
M13:=MA(CLOSE,13);{WWW.GOODGUPIao.COM}
X11:=(C+L+H)/3;
BB13:=ATAN(EMA(X11,13)-REF(EMA(X11,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWBAND(IF(CURRBARSCOUNT<=100,DX+MACD*1.5,DRAWNULL),RGB(230,30,12),DX,RGB(10,200,30));
IF(CURRBARSCOUNT<100,DX+MACD*1.5,DRAWNULL),COLORYELLOW;
DRAWTEXT(FILTER(BB13>1 AND EMA(X11,13)>REF(EMA(X11,8),1),10),
EMA8,'∠35上升'),COLORYELLOW;
{支撑:MA(REF(LLV(C,30),1),2),COLORRED;}
C11:=(CLOSE+LOW+HIGH)/3;
C2:=EMA(C11,6);
C3:=EMA(C2,5);
C4:=crOSS(C2,C3);
DRAWTEXT(C4,LOW/1.01,'★买'),COLORRED;
X:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);
Y:=EMA(CLOSE,10);
LL:=REF(CLOSE,2);
MM:=((SMA(MAX((CLOSE - LL),0),6,1) / SMA(Abs((CLOSE - LL)),6,1)) * 100);
DB:=IF(((MM < REF(MM,1)) AND (MM > 79)),MM,0);
DRAWTEXT(CROSS(Y,X),(LOW *0.985),'▲加仓'),LINETHICK5,COLORRED;
VAR24:=LLV(LOW,36);
VAR25:=HHV(HIGH,30);
VAR26:=EMA((CLOSE-VAR24)/(VAR25-VAR24)*4,4)*25;
顶背离:=ISLASTBAR,IF((VAR26>90),110,100);
DRAWTEXT(VAR26>90,L*0.98,'顶背离')COLORGREEN;
{DRAWSL(DATE=1220104,CLOSE,10000,1000,0),COLORWHITE,LINETHICK3;
DRAWSL(DATE=1220104,CLOSE,0,1000,2),COLORWHITE,LINETHICK3;}
X_3:=EMA(((2*CLOSE+HIGH+LOW)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);
X_4:=EMA(X_3,5);
X_5:=REFDATE(REF(HHV(MAX(CLOSE,OPEN),96),5),DATE);
X_6:=REFDATE(REF(LLV(MIN(CLOSE,OPEN),96),5),DATE);
X_7:=(X_5+X_6)/2;
箱顶:IF(X_3>0 AND X_3-X_4<=0,X_5,X_5),DOTLINE,COLORRED,LINETHICK3;
箱腰:IF(X_3>0 AND X_3-X_4<=0,X_7,X_7),DOTLINE,COLORYELLOW,LINETHICK3;
箱低:IF(X_3>0 AND X_3-X_4<=0,X_6,X_6),DOTLINE,COLORLIGRAY,LINETHICK3;
浮平线:=EMA(CLOSE,6)-EMA(CLOSE,13),COLORFF00FF,LINETHICK2;
门头线:=REF(HHV(浮平线,20),1),COLOR009000,LINETHICK2;
门槛线:=REF(LLV(浮平线,20),1),COLOR99EEEE;
低位介入:CROSS(浮平线,门槛线),COLORRED,NODRAW;
突破介入:CROSS(浮平线,门头线),COLORYELLOW,NODRAW;
{高位逃顶:CROSS(门头线,浮平线),COLORGREEN,NODRAW;}
DRAWICON(CROSS(浮平线,门槛线),L,23),COLORRED;
DRAWICON(CROSS(浮平线,门头线),L,34),COLORRED;
{DRAWICON(CROSS(门头线,浮平线),H*1.02,8),COLORGREEN;}
A1:=MA(C,1);
A2:=MA(C,21);
A3:=(A1+A2)/2;
STICKLINE(A3>A1,H,L,0,0),COLOR00FF00;
STICKLINE(A3>A1,C,O,3.2,0),COLOR00FF00;
STICKLINE(A3>A1 AND C>O,C,O,3.2,1),COLOR00FF00;
STICKLINE(A3>A2,H,L,0,0),COLOR0000FF;
STICKLINE(A3>A2,C,O,3.2,0),COLOR0000FF;
STICKLINE(A3>A2 AND C>O,C,O,3.2,1),COLOR0000FF;
STICKLINE(低位介入,C,O,3.2,0),COLORMAGENTA;
STICKLINE(突破介入,C,O,3.2,0),COLORYELLOW;
{STICKLINE(高位逃顶,C,O,3.2,0),COLORGREEN;}
主力成本线:(EMA(C,55)),,LINETHICK2,COLORRED;
均价:=(2*C+(C+H+L+O)/4+O)/4;
JJR1:=(2*L+3*均价)/5;
JJR2:=(2*H+3*均价)/5;
JJR3:=ABS(均价-MA((JJR1+JJR2)/2,20))/MA((JJR1+JJR2)/2,20);
JJR4:=DMA(均价,JJR3);
JJR5:(1+7/100)*JJR4,COLORYELLOW,LINETHICK2;
涨停1:=C/REF(C,1)>1.093 AND C=H;
涨停2:=COUNT(REF(涨停1,1),4)=0;
打首板1:= 涨停2 AND CROSS(C,JJR5) AND CROSS(C,EMA(REF(HHV(C,10),1),3)) AND C/REF(C,1)>1.095 AND O/REF(C,1)<1.05 AND C>O AND REF(C,1)/REF(C,2)<1.05,COLORCYAN;
打首板2:= 涨停2 AND C>(LLV(REF(LOW,1),2) + ((HHV(REF(HIGH,1),2) - LLV(REF(LOW,1),2)) / 2)) AND C/REF(C,1)>1.095 AND CROSS(C,EMA(REF(HHV(C,40),1),3)) AND O/REF(C,1)<1.05 AND C>O AND REF(C,1)/REF(C,2)<1.05;
超级打首板:=打首板1 OR 打首板2;
STICKLINE(超级打首板,O,C,3.0,0),COLORMAGENTA;
ZT1:=C/REF(C,1)>1.045 AND L=H AND C=H;
DRAWICON(DYNAINFO(8)>0 AND V<REF(LLV(V,21),1 AND NOT(C=H AND C=L)) AND NOT(ZT1),LOW*0.97,16);
DRAWICON (( C=HHV(C,10) AND H=HHV(H,10) AND C>O*1.01 AND H<C*1.04 AND V>=HHV(V,10) AND V>(REF(V,1)*1.8)),L*0.95,1);
QS1:=3*SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,5,1),3,1);
压力1:=boll+2*STD(CLOSE,14);
支撑1:=BOLL-2*STD(CLOSE,14);
BILI:=压力1/支撑1 ;
{DRAWICON ((BILI>1.4 AND REF(BILI,2)<REF(BILI,1) AND BILI<REF(BILI,1) ),H*1.05,2);}
DRAWICON ((QS1>90 AND BARSCOUNT(CLOSE)>30 AND REF(QS1,2)<REF(QS1,1) AND QS1<REF(QS1,1) ),H*1.05,12);
DRAWICON ((QS1<10 AND BARSCOUNT(CLOSE)>30 AND REF(QS1,2)>REF(QS1,1) AND QS1>REF(QS1,1) AND C>REF(C,1) AND C>O ),L*0.95,11);
X_21:=REF(CLOSE,1);
X_31:=IF((CLOSE-X_21)*100/X_21>=5-0.01*100/X_21,1,0);
KVD1:=IF(CLOSE>REF(CLOSE,1),88,0);
KVD2:=IF(CLOSE/REF(CLOSE,1)>1.01 AND HIGH/CLOSE<1.010 AND KVD1>0,91,0)>1;
KVD3:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3)/4;
KVD4:=(KVD3-REF(KVD3,1))>1;
KVD5:=C/REF(C,1)<1.2;
GP:=KVD2 AND KVD4 AND KVD5;
DFV:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*100;
CBT:=(SMA(DFV,5,1)+2*STD(CLOSE,37))<50;
RVL:=X_31 AND GP AND CBT,NODRAW;
XG:=BARSSINCEN(RVL,5)=0,COLORRED,NODRAW;
STICKLINE(XG AND C>MA(C,13),OPEN,CLOSE,3.2,0),COLORMAGENTA;
STICKLINE(XG AND C>MA(C,13),HIGH,LOW,0,0),COLORMAGENTA;
DRAWTEXT(XG,LOW*0.99,'↖起爆'),COLORYELLOW;

通达信大阳主图指标公式

相关文章