在线检测未来函数

通达信龙头战法主图指标公式

来源:Internet,编辑:股旁网,2022-08-01

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1009”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

A0:=((L+H+C*2)/4);
上:Ema(A0,14)*1.1382,COLORYELLOW,LINETHICK1;
{上B:REFDATE(上,DATE),COLORYELLOW,DOTLINE;}
DRAWNUMBER(ISLAstBAR,上,上),COLORWHITE;
中:EMA(A0,14)*1.0618,COLORWHITE,LINETHICK1;
DRAWNUMBER(ISLASTBAR,中,中),COLORWHITE;
下:EMA(A0,14),COLORRED,LINETHICK1;
DRAWNUMBER(ISLASTBAR,下,下),COLORWHITE;
{A2:=EMA(A0,25)COLORLIBLUE,LINETHICK1;
A1X:=(下-REF(下,1))/REF(下,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
买:IF(A1X>=0,下,DRAWNULL),COLORRED,LINETHICK1;
卖:IF(A1X<0 AND A2X<0,下,DRAWNULL)COLORGREEN3;}
多空:EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),COLORYELLOW,LINETHICK2;
做空:=REF(多空,1),COLORGREEN,NODRAW;
A2:=EMA(多空,25)COLORLIBLUE,LINETHICK3;
A1X:=(多空-REF(多空,1))/REF(多空,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
买:IF(A1X>=0,多空,DRAWNULL),COLORMAGENTA,LINETHICK2;
卖:IF(A1X<0 AND A2X<0,多空,DRAWNULL),COLORGREEN,LINETHICK2;
{STICKLINE(做多>做空,做多,做空,3,0),COLORRED;
STICKLINE(做多<=做空,做多,做空,3,1),COLORGREEN;}
{涨停表示}
LA:=BArslAST(C>REF(C,1)*1.098);
LC:=REF(CLOSE,LA);
LO:=REF(OPEN,LA);
LAL:=REF(L,LA);
LAH:=REF(H,LA);
一涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,1);
双涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,2);
三涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,3) AND H>L;
策略1A:=EXIST((C/REF(C,2)-1)*100>20,2) AND COUNT(LC>LO,3)>=1 AND O<REF(C,1) AND C<REF(C,1) AND C>O AND C>REF(O,1) AND REF(C,1)>REF(C,2) ;
策略1B:=EXIST(双涨停,3) AND COUNT(LC>LO,4)>=1 AND O<REF(C,1) AND C<REF(C,1) AND C>O AND C>REF(O,1) AND REF(C,1)>REF(C,2) ;
{DRAWTEXT(策略1A,LOW,'↖①'),COLORYELLOW;
DRAWTEXT(策略1B,LOW,'↖①'),COLORYELLOW;}
DRAWTEXT(策略1A,LOW,'↖东方不败'),COLORYELLOW;
DRAWTEXT(策略1B,LOW,'↖东方不败'),COLORYELLOW;
策略2:=EXIST(三涨停,5) AND C>中 AND L<中*1.01618 AND C/REF(C,1)<1.05 AND HHV(H,5)/C>1.14;
{DRAWTEXT(策略2,LOW,'↖②'),COLORYELLOW;}
DRAWTEXT(策略2,LOW,'↖潜伏'),COLORYELLOW;
策略3:=EXIST(三涨停,9) AND EXIST(一涨停,9) AND C>下 AND L<下*1.01618 AND C/REF(C,1)<1.05 AND HHV(H,8)/C>1.14;
{DRAWTEXT(策略3,LOW,'↖③'),COLORYELLOW;}
DRAWTEXT(策略3,LOW,'↖潜伏'),COLORYELLOW;
角度:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*57.3;
持有:=EXIST(一涨停,5) AND 角度>75 AND C>上 AND C>REF(C,1) AND C>上 ;
突破:=角度>75 AND C>上 AND C>REF(C,1) AND C>上 {AND (H/C)<1.038};
DRAWTEXT(持有,LOW,'↖龙'),COLORYELLOW;

通达信龙头战法主图指标公式

相关文章