在线检测未来函数

通达信黄金坑选股指标公式

来源:Internet,编辑:股旁网,2022-08-04

LCF:=REF(CLOSE,1);
rsi5:=((SMA(maX((CLOSE - LCF),0),5,1) / SMA(Abs((CLOSE - LCF)),5,1)) * 100);
TR1F:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
pdi:=((DMP * 100) / TR1F);
mdi:=((DMM * 100) / TR1F);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
wr10:=((100 * (HHV(HIGH,60) - CLOSE)) / (HHV(HIGH,60) - LLV(LOW,60)));{10}
NEWvol:=(RSI5 - WR10);
金坑买入:=(AV + NEWVOL);
买入选股:=IF(crOSS(金坑买入,0),1,0),COLORRED;{NODRAW}
VAR1Z:=SMA(买入选股,8,1);{3}
VAR2Z:=SMA(VAR1Z,8,1),COLOR0000FF;{3}
VAR3Z:=SMA(VAR2Z,10,1),COLOR00FFFF;{3}
金坑:IF(CROSS(VAR2Z,VAR3Z) AND (VAR2Z<40),5,0* 10000),COLOR0000FF,LINETHICK1;{40}

通达信黄金坑选股指标公式

相关文章