在线检测未来函数

通达信支撑压力警示主图指标公式

来源:Internet,编辑:股旁网,2022-08-09

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1009”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

N:=120;
K:=BArslAst(CURRBARSCOUNT=N);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0));{高点}
DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0));{低点}
KJ:=GD-DD;{高低点差值=分区高度}
GD4:=IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL);
高区:IF(CURRBARSCOUNT<=N,GD,DRAWNULL),COLORRED,LINETHICK2;
低区:IF(CURRBARSCOUNT<=N,DD,DRAWNULL),COLOR00FF00,LINETHICK2;
平衡:=IF(CURRBARSCOUNT<=N,DD+KJ/2,DRAWNULL),COLOR00FFFF,NODRAW;
低:IF(CURRBARSCOUNT<=N/2,DD,DRAWNULL),COLORFFFF00;
高:IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL),COLOR00FFFF;
支撑:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.191,DRAWNULL);
强势: IF(CURRBARSCOUNT<=N/2,DD+KJ*0.382,DRAWNULL);
突破:IF(CURRBARSCOUNT<=N/2,DD+KJ/2,DRAWNULL);
警示:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.618,DRAWNULL);
压力:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.809,DRAWNULL);
低涨:IF(CURRBARSCOUNT<=N/2,(C/LLV(LOW,K)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;
天数:BARSLAST(L=DD),COLORCYAN,NODRAW;
顶点:IF(CURRBARSCOUNT<=N/2, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,crOSSDOT;
低点:IF(CURRBARSCOUNT<=N/2, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORmaGENTA,CROSSDOT;
STICKLINE(cci>=200 AND H>=顶点,O,C,2,0),COLORBLUE;
STICKLINE(CCI<=100 AND L<=低点,O,C,2,0),COLORYELLOW;

STICKLINE(CURRBARSCOUNT=N,GD,DD,0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT=N/2,GD,DD,0,0),COLOR408080;
STICKLINE(CURRBARSCOUNT=1,GD,DD,0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT<=N/2,支撑,支撑,2,0);
STICKLINE(CURRBARSCOUNT<=N/2,强势,强势,2,0);
STICKLINE(CURRBARSCOUNT<=N/2,突破,突破,2,0);
STICKLINE(CURRBARSCOUNT<=N/2,警示,警示,2,0);
STICKLINE(CURRBARSCOUNT<=N/2,压力,压力,2,0);
DRAWTEXT(CURRBARSCOUNT=10,压力,'压力-0.809'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=10,警示,'警示-0.618'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=10,突破,'突破-0.500'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=10,强势,'强势-0.382'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=10,支撑,'支撑-0.191'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.09,'高抛'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.3,'减仓'),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.45,'拉升'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.55,'蓄势'),COLORFFFF80;
DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/3,'逢低买入'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/10,'大胆买入'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=N/2+40,GD-KJ*0.25,'【拉升区】'),COLORRED;
DRAWTEXT(CURRBARSCOUNT=N/2+40,DD+KJ*0.25,'【持股区】'),COLORYELLOW;
第一防线:REFDATE(低,DATE),POINTDOT,COLORYELLOW,LINETHICK4;
第二防线:REFDATE(支撑,DATE),POINTDOT,COLORWHITE,LINETHICK4;
{今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLORCC3299;}
DRAWKLINE(H,O,L,C);
AHC1:=CLOSE*vol;
AHC22:=EMA((expma(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
上轨:=1.06*AHC22,COLOR40FF00,LINETHICK1;
下轨:=AHC22*0.94;
{STICKLINE(上轨>下轨,上轨,下轨,5,0),COLOR555555;}
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
启爆:=CROSS(C,上轨) OR CROSS(C,下轨) AND ZT;
DRAWTEXT(启爆,L,'');
STICKLINE(启爆,C,O,3,1);
STICKLINE(启爆,C,O,1,0);

通达信支撑压力警示主图指标公式

相关文章