在线检测未来函数

通达信擒庄乘龙指标公式

来源:Internet,编辑:股旁网,2022-08-12

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1009”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

DIF:=(CLOSE-SMA(CLOSE,13,1))/Sma(CLOSE,13,1)*(-100);
DEA:=REF(DIF,1)>13 AND REF(DIF,1)/DIF>1.23 AND CLOSE/REF(CLOSE,1)>1.03;
KOV1:=IF(DEA AND REF(CLOSE,1)<=COst(5),28,0);
KOV2:=IF(DEA AND REF(CLOSE,1)<=COST(5),18,0);
QL1:=IF(DEA AND REF(CLOSE,1)<=COST(5),1,0);
N1:=9;Q:=20;
VAR1:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
MX1:=SMA(VAR1,10,1);
RSV:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
K1:=SMA(RSV,3,1);
D1:=SMA(K1,3,1);
VAR2:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR3:=REF(VAR2,1);
VAR4:=SMA(MAX(VAR2-VAR3,0),10,1)/SMA(Abs(VAR2-VAR3),10,1)*100;
DD1:=IF(COUNT(VAR4<20,5)>=1 AND COUNT(VAR2=LLV(VAR2,5),10)>=1 AND
CLOSE>OPEN AND CLOSE>REF(OPEN,1) AND vol>1.5*MA(VOL,5),60,0);
MAV:=(2*C+H+L)/4;
VAR5:=LLV(LOW,34);
VAR6:=HHV(HIGH,34);
SK1:=EMA((MAV-VAR5)/(VAR6-VAR5)*100,13),STICK,COLOR00FFFF LINETHICK2;
SD1:=EMA(0.667*REF(SK1,1)+0.333*SK1,2);
VAR7:=SMA(MAX(CLOSE-REF(CLOSE,1),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
WTBFW:=IF(REF(VAR7,1)<20 AND (C/REF(C,1)-1)*100>9 AND C=H,85,0);
VAR11:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR12:=REF(VAR11,1);
VAR13:=SMA(MAX(VAR11-VAR12,0),10,1)/SMA(ABS(VAR11-VAR12),10,1)*100;
VAR14:=REVERSE(VAR13)+100;
DBBY:=IF(COUNT(VAR13<=14,2),30,0);
MJ1:=IF(crOSS(VAR13,DBBY) AND VOL>1.5*MA(VOL,5),60,0);
擒庄:QL1 AND DBBY;
DRAWTEXT(擒庄,0.1,' ←擒庄'),COLORYELLOW;
擒庄2:QL1 AND DD1;
DRAWTEXT(擒庄2,0.3,' ←擒庄2'),COLORFFFFFF;
A1:=((MA(C,60)-L)/MA(C,20))*200;
B1:=((MA(C,60)-L)/MA(C,60))*200;
C1:=((MA(C,30)-L)/MA(C,60))*200;
M1:=REF(CLOSE,1);
M2:=SMA(MAX(CLOSE-M1,0),7,1)/SMA(ABS(CLOSE-M1),7,1)*100;
G1:=FILTER(REF(M2,1)<20 AND M2>REF(M2,1),5);
TU:=C/MA(C,40)<0.74;
PER1:=5;
MMA:=EMA(C,PER1);
SMMA:=EMA(MMA,PER1);
IMPETMMA:=MMA - REF(MMA,1);
IMPETSMMA:=SMMA - REF(SMMA,1);
DIVMA:= ABS(MMA - SMMA);
TDJ:=(H-L)/REF(C,1)>0.05;
AVERIMPET:= (IMPETMMA+IMPETSMMA)/2;
TDF:= POW(DIVMA,1)*POW(AVERIMPET,3);
NTDF:=TDF/HHV(ABS(TDF),PER1*3);
YUL:=COUNT(TDJ,5)>1;
QD1:=TU AND TDJ AND YUL;
QD2:=CROSS(NTDF,-0.9);
BD1:=FILTER((G1 AND C1>20 OR C>REF(C,1)) AND REF(QD1,1),10);
XX1:=FILTER(REF(QD1,1) AND (QD2 OR C>REF(C,1)) AND "macd.MacD">-1.5,10);
YD1:=COUNT(XX1,13)>=1 AND BD1;
有龙1:DBBY AND DD1;
DRAWTEXT(有龙1,0.5,' ←有龙1'),COLORGREEN;
有龙2:DBBY AND YD1;
DRAWTEXT(有龙2,0.7,' ←有龙2'),COLORFFFF00;
Z_1:=VOL/CAPITAL*100<11 OR REF(VOL/CAPITAL*100,1)>6 AND VOL/CAPITAL*100/REF(VOL/CAPITAL*100,1)<1.99 OR VOL/CAPITAL<REF(HHV(VOL/CAPITAL,90),1);
Z_2:=CLOSE/REF(CLOSE,1)>1.03 AND CLOSE/HHV(HIGH,34)<1 AND NOT(CLOSE<OPEN);
Z_3:=MAX(FORCAST(COST(24)/LOW,3),SMA(COST(24)/LOW,3,1))>1.3;
ZDD:=Z_1 AND Z_2 AND Z_3 ;
VAR1G:=(((CLOSE/MA(CLOSE,40))*100)<78);
VAR2G:=(((CLOSE/MA(CLOSE,60))*100)<74);
VAR3G:=(HIGH>(LOW*1.051));
VAR4G:=(VAR3G AND (COUNT(VAR3G,5) > 1));
VARAA:=IF((VAR4G AND (VAR1G OR VAR2G)),2,0);
VARBB:=C/REF(C,25)<=1.1;
VARCC:=(SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100)<15;
CPX:=SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1);
VARV5:=SMA(CPX,2,1);
CPXCD:=CPX>REF(CPX,1) AND REF(CPX,1)<REF(CPX,2) AND CPX<23;
JPD:=VARAA AND VARBB AND VARCC AND CPXCD;
DAD:=ZDD OR JPD;
乘龙:DBBY AND DAD;
DRAWTEXT(乘龙,0.9,' ←乘龙'),COLORRED;

通达信擒庄乘龙指标公式

相关文章