在线检测未来函数

通达信追妖杀魔指标公式

来源:Internet,编辑:股旁网,2022-08-26

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1009”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

X_1:=Ema(CLOSE,12)-EMA(CLOSE,26);
X_2:=EMA(X_1,9);
X_3:=4920404/4;
X_4:=IF(DATE<X_3,1,1);
X_5:=MA(CLOSE,15) AND X_4;
X_6:=X_5+2*stD(CLOSE,15);
X_7:=IF(CLOSE>X_6 AND CLOSE>=OPEN AND X_4,5,0);
X_8:=IF(CLOSE>EMA(CLOSE,250),BArslAST(crOSS(CLOSE,EMA(CLOSE,250)))+1,0)*50000;
X_9:=(CLOSE-EMA(CLOSE,250))/EMA(CLOSE,250)*100*50000;
X_10:=HHV(X_9,X_8);
X_11:=IF(X_10=X_9 AND X_4,4.5,0);
X_12:=100*EMA(EMA(mtm,6),6)/EMA(EMA(Abs(MTM),6),6);
X_13:=100*EMA(EMA(MTM,26),26)/EMA(EMA(ABS(MTM),26),26);
X_14:=100*EMA(EMA(MTM,12),12)/EMA(EMA(ABS(MTM),12),12);
X_15:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100;
X_16:=10*WINNER(CLOSE*0.9)*8;
X_17:=10*WINNER(CLOSE*0.9)*8/50;
X_18:=X_12>X_15 AND X_13>=X_15 AND X_14>=X_15 AND X_16>=40 AND X_4;
X_19:=IF(X_12>X_15 AND X_13>=X_15 AND X_14>=X_15 AND X_16>=40,4,0);
X_20:=IF(CROSS(X_7,1),5,0);
X_21:=IF(CROSS(X_11,1),4.5,0);
X_22:=IF(CROSS(X_19,1),4,0);
X_23:=IF(CROSS(1,X_7),5,0);
X_24:=IF(CROSS(1,X_11),4.5,0);
X_25:=IF(CROSS(1,X_19),4,0);
X_26:=21;
X_27:=6;
X_28:=20;
X_29:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),X_26);
X_30:=HIGH-REF(HIGH,1);
X_31:=REF(LOW,1)-LOW;
X_32:=EMA(IF(X_30>0 AND X_30>X_31,X_30,0),X_26);
X_33:=EMA(IF(X_31>0 AND X_31>X_30,X_31,0),X_26);
X_34:=X_32*100/X_29;
X_35:=X_33*100/X_29;
X_36:=EMA((X_34-X_35)/(X_35+X_34)*100,X_27)*2;
X_37:=EMA(X_36,X_27);
X_38:=EMA(X_36,X_28);
X_39:=BARSLAST(X_38!=REF(X_38,1));
X_40:=REF(X_38,X_39+1);
X_41:=MA(CLOSE,5);
X_42:=MA(CLOSE,10);
X_43:=MA(CLOSE,20);
X_44:=MA(CLOSE,30);
X_45:=MA(CLOSE,60);
X_46:=BARSLAST(X_45!=REF(X_45,1));
X_47:=REF(X_45,X_46+1);
X_48:=vol>=REF(VOL,1)*1.9 AND CLOSE>REF(CLOSE,1);
X_49:=CROSS(CLOSE,X_43);
X_50:=CROSS(CLOSE,X_44);
X_51:=CROSS(X_41,X_42);
X_52:=X_49 AND X_50 AND X_51 AND X_48;
STICKLINE(IF(X_52,3,0),0,6.5,0.5,0),COLORRED;
DRAWTEXT(CROSS(X_52,0.01),5.5,' 追妖'),COLORRED;
X_53:=6;
X_54:=CLOSE-REF(CLOSE,1);
X_55:=100*EMA(EMA(X_54,X_53),X_53)/EMA(EMA(ABS(X_54),X_53),X_53);
X_56:=IF(LLV(X_55,2)=LLV(X_55,7) AND COUNT(X_55<0,2) AND CROSS(X_55,MA(X_55,2)),1,0);
X_57:=IF(HHV(X_55,2)=HHV(X_55,7) AND COUNT(X_55>50,2) AND CROSS(MA(X_55,2),X_55),1,0);
X_58:=COUNT(CLOSE/REF(CLOSE,1)>1.099,13)>1;
X_59:=FILTER(X_56=1,5);
X_60:=X_58 AND X_59;
X_61:=REF(BARSLAST(X_60),0)+1;
STICKLINE(IF(X_60,120,0),0,7,0.5,0),COLORRED;
DRAWTEXT(X_60,6,' 追妖'),COLORRED;
X_62:=IF(X_20 AND X_41>X_42 AND X_42>X_45 AND X_38>X_40 AND X_4,6,0);
X_63:=IF(X_24 OR X_25 AND X_45<X_47 AND X_62<6 AND X_4,4.5,0);
X_64:=COST(90);
X_65:=CLOSE;
X_66:=CROSS(X_64,X_65);
X_67:=IF(X_66>0.001,6,0);
STICKLINE(IF(X_67,3,0),0,4.5,0.5,0),COLORCYAN;
DRAWTEXT(CROSS(X_67,3),4,' 杀魔'),COLORCYAN;
(-0.2),COLORBLacK;

通达信追妖杀魔指标公式

相关文章