在线检测未来函数

通达信变色操盘主图指标公式

来源:Internet,编辑:股旁网,2022-09-01

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1009”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

M1:=5;
M2:=10;
M3:=20;
M4:=30;
M5:=60;
M6:=120;
M:=26;
P2:=100;
N:=12;
DRAWGBK(O>C,RGB(40,0,40),RGB(0,50,40),0,'01',0);
M5线绿转红持股:DRAWNULL,NODRAW,COLORRED;
M10线蓝转紫持股:DRAWNULL,NODRAW,COLORRED;
DIFF:=Ema(CLOSE,N)-EMA(CLOSE,M);
DEA:=EMA(DIFF,9);
多头:stICKLINE(DIFF>DEA,C,O,3,-1),COLORRED;
STICKLINE(DIFF>DEA,H,L,0,0),COLORWHITE;
空头:STICKLINE(DIFF<=DEA,C,O,3,0),COLORWHITE;
STICKLINE(DIFF<=DEA,H,L,0,0),COLORWHITE;
DRAWTEXT(crOSS(DIFF,DEA),L*0.95, '★买进'),COLORYELLOW;
DRAWTEXT(CROSS(DEA,DIFF),H*1.02,'☆卖出'),COLORGREEN;
DIFF1:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA1:=EMA(DIFF1,9);
多头1:STICKLINE(DIFF1>DEA1,C,O,3,0),COLORRED;
STICKLINE(DIFF>DEA1,H,L,0,0),COLORRED;
空头1:STICKLINE(DIFF1<=DEA1,C,O,3,0),COLORFFAA18;
STICKLINE(DIFF1<=DEA1,H,L,0,0),COLORFFAA18;
STICKLINE(CROSS((DIFF,DEA),DIFF1),H,L-0.15,3,0),COLORFFAA18;
STICKLINE(CROSS((DIFF,DEA),DIFF1),H,L-0.15,1.6,0),COLORGREEN;
DRAWICON(CROSS(DIFF,DEA),L*0.96,1);
DRAWICON(CROSS((DIFF,DEA),DIFF1),H+0.07,2);
STICKLINE(CROSS((DEA,DIFF),DEA1),L,H-0.15,3,0),COLORRED;
STICKLINE(CROSS((DEA,DIFF),DEA1),L,H-0.15,1.3,0),COLORYELLOW;
丁丁主力线:=EMA(C,3),COLORWHITE;
丁丁跟随主力线:=EMA(C,5),COLORYELLOW;
丁丁辅助主力线:=EMA(C,7),COLORBROWN;
短线回踩支撑:=EMA(C,10),COLORLIGREEN;
丁丁启动线:=EMA(C,20),COLORRED,LINETHICK2;
SS:=CROSS(丁丁主力线,丁丁跟随主力线) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁跟随主力线,丁丁辅助主力线) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁跟随主力线,丁短线回踩支撑) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁主力线,丁丁辅助主力线) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁主力线,丁短线回踩支撑) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁跟随主力线,丁丁辅助主力线) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁跟随主力线,丁丁启动线) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁辅助主力线,丁短线回踩支撑) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁跟随主力线,丁丁启动线) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(丁丁主力线,丁丁启动线);
DRAWTEXT(SS,L-0.15,' ↖强买'),COLORYELLOW;
DRAWICON(SS,L-0.1,34);
MA5 :MA(CLOSE,M1);
MA10:MA(CLOSE,M2);
MA20:MA(CLOSE,M3);
MA30:MA(CLOSE,M4);
MA60:MA(CLOSE,M5);
{-------黄托底买进,洋红压顶卖出。-------}
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
CO:=(C-O);
{涨跌停显示III}
STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,3.2,0),COLORRED;
STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,3.2,0),COLORGREEN;
{=========短均线>长均线\\变色========}
IF(MA5>=REF(MA5,1) AND MA5>=MA10,MA5,DRAWNULL),COLORGREEN,LINETHICK2;
IF(MA10>=REF(MA10,1) AND MA10>=MA20,MA10,DRAWNULL),COLOR990066,LINETHICK2;
IF(MA20>=REF(MA20,1) AND MA20>=MA30,MA20,DRAWNULL),COLOR3333CC,LINETHICK2;
IF(MA5<=REF(MA5,1) AND MA5<=MA10,MA5,DRAWNULL),COLORDDDDDD,LINETHICK1;
IF(MA30>=REF(MA30,1) AND MA30>=MA30 AND C>MA30,MA30,DRAWNULL),COLOR00CCFF,LINETHICK3;
DIFQ:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEAQ:=EMA(DIFQ,9);
AAAS:=(DIFQ-DEAQ)*2*60;
起爆:=CROSS(AAAS-REF(AAAS,1),15),COLORRED,LINETHICK2;
DRAWTEXT(起爆,L*0.975,'↖爆涨'),COLORYELLOW;
EMA13:=EMA(C,13),COLORWHITE;
EMA21:=EMA(C,21),COLORYELLOW;
EMA34:=EMA(C,34),COLORFF00FF;
EMA60:=MA(C,60),COLORFFCC66;
VAR2P:=(2*CLOSE+HIGH+LOW)/4;
VAR3P:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4P:=LLV(LOW,5); VAR5P:=HHV(HIGH,4);
散户:=EMA((VAR2P-VAR4P)/(VAR5P-VAR4P)*100,4)*VAR3P;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3P;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),COLORLIRED;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),COLORGREEN;

通达信变色操盘主图指标公式

相关文章