在线检测未来函数

通达信异动主图指标公式

来源:Internet,编辑:股旁网,2022-09-05

M:=3;
DRAWTEXT_FIX(ISLAstBAR,0.01,0.01,0,STRCAT('【所属行业】:',HYBLOCK)),COLORmaGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.01,0,STRCAT('【所属区域】:',DYBLOCK)),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.06,0,STRCAT('【所属概念】:',GNBLOCK)),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.11,0,STRCAT('【所属风格】:',FGBLOCK)),COLORGREEN;
CC:=COST(95);
DD:=COST(5);
筹码集中度:=(CC-DD)/(CC+DD)*100,COLORCYAN,NODRAW;
穿峰:=crOSS(CLOSE,COST(95)) AND 筹码集中度<=20;
CF:=FILTERX(穿峰,5);
HLP:=COST(95);
T:=REF(HLP,1);
STICKLINE(CF,T*1.002,T,10,0),COLORRED;
DRAWICON(CF,L,1) COLORRED;
ZTB:=IF(INBLOCK('科创板'),1.2,IF(INBLOCK('创业板') AND DATE>1200823,1.2 ,IF(INBLOCK('ST板块'),1.05,1.095)));
DTB:=IF(INBLOCK('科创板'),0.8,IF(INBLOCK('创业板') AND DATE>1200823,0.8 ,IF(INBLOCK('ST板块'),0.95,0.9)));
涨:=(REF(C,1)*ZTB-C)*100<0.49 AND C=H;{涨停板}
停:=(C-REF(C,1)*DTB)*100<0.51 AND C=L ;{跌停板};
ZTJA:=ZTPRICE(REF(C,1),0.1);
DTJ:=DTPRICE(REF(C,1),0.1);
炸:= C<H AND H=ZTJA AND L>DTJ;
天地:=C<H AND H=ZTJA AND C=DTJ;
地天:=C>O AND H=ZTJA AND C=ZTJA AND L=DTJ;
STICKLINE(C>O,H,L,0,0),COLOR7D7DFF;
STICKLINE(C>O,C,O,0,0),COLOR7D7DFF;
STICKLINE(C>O,C,O,3.1,0),COLOR1313FF;
STICKLINE(C>O,C,O,2.4,0),COLOR2424FF;
STICKLINE(C>O,C,O,2.0,0),COLOR2D2DFF;
STICKLINE(C>O,C,O,1.6,0),COLOR4444FF;
STICKLINE(C>O,C,O,1.2,0),COLOR5757FF;
STICKLINE(C>O,C,O,0.6,0),COLOR6666FF;
STICKLINE(C>O,C,O,0.1,0),COLOR7D7DFF;
STICKLINE(C<O,H,L,0,0),COLORFF9900;
STICKLINE(C<O,C,O,0,0),COLORFF5500;
STICKLINE(C<O,C,O,3.1,0),COLORFF6600;
STICKLINE(C<O,C,O,2.4,0),COLORFF7700;
STICKLINE(C<O,C,O,2.0,0),COLORFF8800;
STICKLINE(C<O,C,O,1.6,0),COLORFF9900;
STICKLINE(C<O,C,O,1.2,0),COLORFFAA00;
STICKLINE(C<O,C,O,0.6,0),COLORFFCC00;
STICKLINE(C<O,C,O,0.1,0),COLORFFFF00;
DRAWTEXT(天地,L*0.98,'天'),COLORCYAN;
DRAWTEXT(天地,L*0.95,'地'),COLORCYAN;
DRAWTEXT(天地,L*0.92,'板'),COLORCYAN;
DRAWTEXT(地天,L*0.98,'地'),COLORCYAN;
DRAWTEXT(地天,L*0.95,'包'),COLORCYAN;
DRAWTEXT(地天,L*0.92,'天'),COLORCYAN;
DRAWTEXT(炸,H,'--炸'),COLORCYAN;
STICKLINE(停,H,L,0,1), COLOR00FF00;
STICKLINE(停,C,O,3.2,0),COLOR00FF00;
STICKLINE(停,C,O,2.8,0),COLOR00AA00;
STICKLINE(停,C,O,2,0),COLOR00BB00;
STICKLINE(停,C,O,1,0),COLOR00DD00;
STICKLINE(停,C,O,0.3,0),COLOR3FFB00;
STICKLINE(涨,H,L,0,1),COLORMAGENTA;
STICKLINE(涨,C,O,3.2,0),COLORMAGENTA;
STICKLINE(涨,C,O,2.8,0),COLOR990099;
STICKLINE(涨,C,O,2.0,0),COLORBB00BB;
STICKLINE(涨,C,O,1.0,0),COLORDD00DD;
STICKLINE(涨,C,O,0.3,0),COLORMAGENTA;
{异动}
创业板:=INBLOCK('创业板') OR INBLOCK('科创板');
深圳股:=INBLOCK('深证A股');
异动A:=(C/REF(C,2)-1)*100-("399107$C"/REF("399107$C",2)-1)*100;
异动B:=(C/REF(C,3)-1)*100-("399107$C"/REF("399107$C",3)-1)*100;
异动A1:=IF(创业板,异动A>29.99,异动A>19.99);
异动B1:=IF(创业板,异动B>39.99,异动B>19.99);
异动:=IF(异动A1,1,IF(异动B1,1,0));
异动价A:=(("399107$C"/REF("399107$C",2)) + 0.2) * REF(C,2);{2天就异动}
异动价B:=(("399107$C"/REF("399107$C",3)) + 0.2) * REF(C,3);{3天才异动}
异动价:=IF(异动A1,异动价A,异动价B);
第一次异动:=IF(异动=1 AND 深圳股=1 AND EXISTR(异动=1,M,1)=0,1,0);
第二次异动:=FILTER(IF(BArslAST(第一次异动)<=3 AND 深圳股=1 AND 异动A1 AND EXISTR(第一次异动=1,M,2),1,IF( 异动B1 AND BARSLAST(第一次异动)<=3 AND EXISTR(第一次异动=1,M,3),1,0)),M);
第三次异动:=FILTER(IF(BARSLAST(第二次异动)<=3 AND 深圳股=1 AND 异动A1 AND EXISTR(第二次异动 = 1,M,2),1,IF(BARSLAST(第二次异动)<=3 AND 异动B1 AND EXISTR(第二次异动 = 1,M,3),1,0)),M);
第四次异动:=FILTER(IF(BARSLAST(第三次异动)<=3 AND 深圳股=1 AND 异动A1 AND EXISTR(第三次异动 = 1,M,2),1,IF(BARSLAST(第三次异动)<=3 AND 异动B1 AND EXISTR(第三次异动 = 1,M,3),1,0)),M);
第五次异动:=FILTER(IF(BARSLAST(第四次异动)<=3 AND 深圳股=1 AND 异动A1 AND EXISTR(第四次异动 = 1,M,2),1,IF(BARSLAST(第四次异动)<=3 AND 异动B1 AND EXISTR(第四次异动 = 1,M,3),1,0)),M);
第六次异动:=FILTER(IF(BARSLAST(第五次异动)<=3 AND 深圳股=1 AND 异动A1 AND EXISTR(第五次异动 = 1,M,2),1,IF(BARSLAST(第五次异动)<=3 AND 异动B1 AND EXISTR(第五次异动 = 1,M,3),1,0)),M);
STICKLINE(PERIOD=5 AND 深圳股=1 AND 第一次异动=1 ,异动价,异动价,-1,1),COLORGREEN;
STICKLINE(PERIOD=5 AND 深圳股=1 AND 第二次异动=1,异动价,异动价,-1,1),COLORGREEN;
STICKLINE(PERIOD=5 AND 深圳股=1 AND 第三次异动=1,异动价,异动价,-1,1),COLORGREEN;
STICKLINE(PERIOD=5 AND 深圳股=1 AND 第四次异动=1,异动价,异动价,-1,1),COLORGREEN;
STICKLINE(PERIOD=5 AND 深圳股=1 AND 第五次异动=1,异动价,异动价,-1,1),COLORGREEN;
STICKLINE(PERIOD=5 AND 深圳股=1 AND 第六次异动=1,异动价,异动价,-1,1),COLORGREEN;
DRAWTEXT(第四次异动=1,异动价,'-------触发第四次异动')COLORMAGENTA;
DRAWTEXT(第五次异动=1,异动价,'-------触发第五次异动')COLORMAGENTA;
DRAWTEXT(第六次异动=1,异动价,'-------触发第六次异动')COLORMAGENTA;
STICKLINE(CURRBARSCOUNT<=1 AND PERIOD=5 AND 深圳股=1 AND BARSLAST(异动)<=3,异动价A,异动价A,-1,1),COLORYELLOW;
YD:=第四次异动 OR 第一次异动 OR 第二次异动 OR 第三次异动 OR 第四次异动 OR 第五次异动 OR 第六次异动;
STICKLINE(YD,L*0.995,L*0.95,1.5,1),COLORMAGENTA;
STICKLINE(YD,L*0.994,L*0.975,1.2,0),COLORGREEN;
STICKLINE(YD,L*0.97,L*0.95,1.5,0),COLORMAGENTA;
DRAWNUMBER(第一次异动,L*0.97,1)COLORWHITE;
DRAWNUMBER(第二次异动,L*0.97,2)COLORWHITE;
DRAWNUMBER(第三次异动,L*0.97,3)COLORWHITE;
DRAWNUMBER(第四次异动,L*0.97,4)COLORWHITE;
DRAWNUMBER(第五次异动,L*0.97,5)COLORWHITE;
DRAWNUMBER(第六次异动,L*0.97,6)COLORWHITE;
STICKLINE(YD AND O<H,O*1.008,O,3.2,0),COLOR0055AA;
STICKLINE(YD AND O<H,O*1.008,O,2.8,0),COLOR0066BB;
STICKLINE(YD AND O<H,O*1.008,O,2,0),COLOR0077CC;
STICKLINE(YD AND O<H,O*1.008,O,1.2,0),COLOR00AAFF;
STICKLINE(YD AND O<H,O*1.008,O,0.3,0),COLOR00FFFF;

通达信异动主图指标公式

相关文章