在线检测未来函数

通达信一路筹码指标公式

来源:Internet,编辑:股旁网,2022-09-08

{指标介绍:红色柱主力获利筹码,黄色浮动筹码,绿色套牢筹码。}

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1009”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

HJ_1:=WINNER(CLOSE*0.9)*100;
HJ_2:=100-WINNER(CLOSE*1.1)*100;
HJ_3:=100-HJ_1-HJ_2;
stICKLINE(1,HJ_1,HJ_1+HJ_3,3,0),COLOR009999;
STICKLINE(1,HJ_1,HJ_1+HJ_3,2.5,0),COLOR00AAAA;
STICKLINE(1,HJ_1,HJ_1+HJ_3,2,0),COLOR00BBBB;
STICKLINE(1,HJ_1,HJ_1+HJ_3,1.5,0),COLOR00CCCC;
STICKLINE(1,HJ_1,HJ_1+HJ_3,1,0),COLOR00DDDD;
STICKLINE(1,HJ_1,HJ_1+HJ_3,0.5,0),COLOR00EEEE;
STICKLINE(1,HJ_1,HJ_1+HJ_3,0,0),COLORYELLOW;
STICKLINE(1,0,HJ_1,3,0),COLOR000077;
STICKLINE(1,0,HJ_1,2.5,0),COLOR000099;
STICKLINE(1,0,HJ_1,2,0),COLOR0000AA;
STICKLINE(1,0,HJ_1,1.5,0),COLOR0000BB;
STICKLINE(1,0,HJ_1,1,0),COLOR0000DD;
STICKLINE(1,0,HJ_1,0.5,0),COLOR0000EE;
STICKLINE(1,0,HJ_1,0,0),COLORRED;
STICKLINE(1,HJ_1+HJ_3,100,3,0),COLOR007700;
STICKLINE(1,HJ_1+HJ_3,100,2.5,0),COLOR009900;
STICKLINE(1,HJ_1+HJ_3,100,2,0),COLOR00AA00;
STICKLINE(1,HJ_1+HJ_3,100,1.5,0),COLOR00BB00;
STICKLINE(1,HJ_1+HJ_3,100,1,0),COLOR00CC00;
STICKLINE(1,HJ_1+HJ_3,100,0.5,0),COLOR00DD00;
STICKLINE(1,HJ_1+HJ_3,100,0,0),COLORGREEN;
HJ_4:=CLOSE-REF(CLOSE,1);
HJ_5:=100*Ema(EMA(HJ_4,5),3)/EMA(EMA(Abs(HJ_4),5),3);
HJ_6:=100*EMA(EMA(HJ_4,13),8)/EMA(EMA(ABS(HJ_4),13),8);
HJ_7:=HJ_5>HJ_6;
HJ_8:=IF(HJ_7,6,0);
HJ_9:=EMA(CLOSE,8)-EMA(CLOSE,13);
HJ_10:=EMA(HJ_9,5);
HJ_11:=HJ_9>HJ_10;
HJ_12:=IF(HJ_11,1,0);
HJ_13:=(EMA(CLOSE,3)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4;
HJ_14:=CLOSE>HJ_13;
HJ_15:=IF(HJ_14,5,0);
HJ_16:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
HJ_17:=SMA(HJ_16,3,1);
HJ_18:=SMA(HJ_17,3,1);
HJ_19:=HJ_17>HJ_18;
HJ_20:=IF(HJ_19,2,0);
HJ_21:=REF(CLOSE,1);
HJ_22:=SMA(MAX(CLOSE-HJ_21,0),5,1)/SMA(ABS(CLOSE-HJ_21),5,1)*100;
HJ_23:=SMA(MAX(CLOSE-HJ_21,0),13,1)/SMA(ABS(CLOSE-HJ_21),13,1)*100;
HJ_24:=HJ_22>HJ_23;
HJ_25:=IF(HJ_24,3,0);
HJ_26:=(-(HHV(HIGH,13)-CLOSE))/(HHV(HIGH,13)-LLV(LOW,13))*100;
HJ_27:=SMA(HJ_26,3,1);
HJ_28:=SMA(HJ_27,3,1);
HJ_29:=HJ_27>HJ_28;
HJ_30:=IF(HJ_29,4,0);
HJ_31:=HJ_11+HJ_19+HJ_24+HJ_29+HJ_14+HJ_7-3;
HJ_32:=HJ_31>0;
HJ_33:=HHV(HIGH,34);
HJ_34:=LLV(LOW,34);
HJ_35:=EVERY(CLOSE<OPEN,4);
HJ_36:=EVERY(CLOSE<OPEN,3);
HJ_37:=HJ_35 OR HJ_36;
HJ_38:=REF(HJ_37,1) AND HJ_33 AND HJ_34 AND OPEN<MA(CLOSE,5) AND OPEN<MA(CLOSE,10) AND CLOSE>=MA(CLOSE,5) AND CLOSE>=MA(CLOSE,10);
HJ_39:=HJ_32 AND REF(HJ_31,1)<=0 AND crOSS(CLOSE,EMA(CLOSE,5)) AND CROSS(CLOSE,EMA(CLOSE,10)) AND CROSS(CLOSE,EMA(CLOSE,20)) AND LOW>REF(LOW,1) AND macd.MacD>0;
HJ_40:=HJ_38 OR HJ_39;
HJ_41:=REF(CLOSE,1);
HJ_42:=SMA(MAX(CLOSE-HJ_41,0),5,1)/SMA(ABS(CLOSE-HJ_41),5,1)*100;
HJ_43:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),10);
HJ_44:=HIGH-REF(HIGH,1);
HJ_45:=REF(LOW,1)-LOW;
HJ_46:=SUM(IF(HJ_44>0 AND HJ_44>HJ_45,HJ_44,0),10);
HJ_47:=SUM(IF(HJ_45>0 AND HJ_45>HJ_44,HJ_45,0),10);
HJ_48:=HJ_46*100/HJ_43;
HJ_49:=HJ_47*100/HJ_43;
HJ_50:=MA(ABS(HJ_49-HJ_48)/(HJ_49+HJ_48)*100,5);
HJ_51:=HJ_42+HJ_50;
HJ_52:=(HJ_50+REF(HJ_50,5))/2+HJ_42;
HJ_53:=100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10));
HJ_54:=HJ_42-HJ_53;
HJ_55:=HJ_51+HJ_54;
HJ_56:=IF(CROSS(HJ_55,0),1,0);
HJ_57:=SMA(HJ_56,3,1);
HJ_58:=SMA(HJ_57,3,1);
HJ_59:=SMA(HJ_58,3,1);
HJ_60:=IF(CROSS(HJ_58,HJ_59) AND HJ_58<40,25,0);
HJ_61:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*50;
HJ_62:=SMA(HJ_61,3,1);
HJ_63:=SMA(HJ_62,3,1);
HJ_64:=3*HJ_62-2*HJ_63;
HJ_65:=LLV(HJ_64,2)=LLV(HJ_64,8);
HJ_66:=IF(CROSS(HJ_64,3),60,0);
HJ_67:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
HJ_68:=SMA(HJ_67,3,1);
HJ_69:=SMA(HJ_68,3,1);
HJ_70:=3*HJ_68-2*HJ_69;
HJ_71:=REVERSE(HJ_70);
HJ_72:=REF(MA(CLOSE,1),10)>REF(MA(CLOSE,60),10);
HJ_73:=IF(CROSS(HJ_70,HJ_71) AND HJ_72,45,0);
HJ_74:=HJ_60 AND REF(HJ_66,1);
HJ_75:=REF(HJ_60,1) AND HJ_66;
HJ_76:=HJ_74 OR HJ_75;
HJ_77:=ABS(((3.48*CLOSE+HIGH+LOW+OPEN)/5-EMA(CLOSE,20))/EMA(CLOSE,20));
HJ_78:=DMA((2.15*CLOSE+LOW+HIGH+OPEN)/5,HJ_77);
HJ_79:=EMA(HJ_78,200)*1.26;
HJ_80:=EMA(HJ_78,200)*1.18;
HJ_81:=MA((LOW+HIGH+CLOSE)/3,5);
HJ_82:=HHV(HJ_81,60);
HJ_83:=IF(HJ_82>REF(HJ_82,1),HJ_82,DRAWNULL);
HJ_84:=CLOSE*vol;
HJ_85:=EMA((expma(HJ_84,3)/EXPMA(VOL,3)+EXPMA(HJ_84,6)/EXPMA(VOL,6)+EXPMA(HJ_84,12)/EXPMA(VOL,12)+EXPMA(HJ_84,24)/EXPMA(VOL,24))/4,13);
HJ_86:=1.06*HJ_85;
HJ_87:=1.13*HJ_85;
HJ_88:=MIN(HJ_83,HJ_79);
HJ_89:=MIN(HJ_86,HJ_79);
HJ_90:=MIN(HJ_83,HJ_80);
HJ_91:=MIN(HJ_86,HJ_80);
HJ_92:=REF(CLOSE,1)*1.1-CLOSE<0.01 AND HIGH=CLOSE;
HJ_93:=CROSS(CLOSE,HJ_87) AND HJ_92;
HJ_94:=90;
HJ_95:=3;
HJ_96:=REF(LLV(LOW,HJ_94),HJ_95);
HJ_97:=REFDATE(HJ_96,DATE);
HJ_98:=HJ_97=LOW AND (CLOSE-LOW>OPEN-CLOSE OR OPEN-LOW>CLOSE-OPEN);
HJ_99:=HJ_93 OR HJ_98;
HJ_100:=HHV(HIGH,34);
HJ_101:=LLV(LOW,34);
HJ_102:=EVERY(CLOSE<OPEN,4);
HJ_103:=EVERY(CLOSE<OPEN,3);
HJ_104:=HJ_102 OR HJ_103;
HJ_105:=REF(HJ_104,1) AND HJ_100 AND HJ_101 AND OPEN<MA(CLOSE,5) AND OPEN<MA(CLOSE,10) AND CLOSE>=MA(CLOSE,5) AND CLOSE>=MA(CLOSE,10);
HJ_106:=EMA(CLOSE,12)-EMA(CLOSE,26);
HJ_107:=EMA(HJ_106,9);
HJ_108:=HJ_106>HJ_107;
HJ_109:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
HJ_110:=SMA(HJ_109,3,1);
HJ_111:=SMA(HJ_110,3,1);
HJ_112:=HJ_110>HJ_111;
HJ_113:=REF(CLOSE,1);
HJ_114:=SMA(MAX(CLOSE-HJ_113,0),9,1)/SMA(ABS(CLOSE-HJ_113),9,1)*100;
HJ_115:=SMA(MAX(CLOSE-HJ_113,0),26,1)/SMA(ABS(CLOSE-HJ_113),26,1)*100;
HJ_116:=HJ_114>HJ_115;
HJ_117:=SMA(HJ_109,3,1);
HJ_118:=SMA(HJ_117,3,1);
HJ_119:=HJ_117>HJ_118;
HJ_120:=(MA(CLOSE,3)+MA(CLOSE,9)+MA(CLOSE,12)+MA(CLOSE,26))/4;
HJ_121:=CLOSE>HJ_120;
HJ_122:=CLOSE-REF(CLOSE,1);
HJ_123:=100*EMA(EMA(HJ_122,9),9)/EMA(EMA(ABS(HJ_122),9),3);
HJ_124:=100*EMA(EMA(HJ_122,26),12)/EMA(EMA(ABS(HJ_122),26),12);
HJ_125:=HJ_123>HJ_124;
HJ_126:=HJ_108 AND HJ_112 AND HJ_116 AND HJ_119 AND HJ_121 AND HJ_125;
STICKLINE(HJ_126,100,108,3,0),COLORMAGENTA;
HJ_127:=EMA(EMA(CLOSE,9),9);
HJ_128:=100*WINNER(CLOSE*0.95);
HJ_129:=EMA(CLOSE,12)>EMA(CLOSE,50) AND EMA(CLOSE,20)>EMA(CLOSE,120);
HJ_130:=(HJ_127-REF(HJ_127,1))/REF(HJ_127,1)*1000;
HJ_131:=HJ_128>=50 AND COST(85)<=CLOSE AND HJ_130>0 AND HJ_130>REF(HJ_130,1);
HJ_132:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
HJ_133:=REF(EMA(HJ_132,3),1);
HJ_134:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
HJ_135:=IF(CLOSE>OPEN,HJ_134*(HIGH-LOW),IF(CLOSE<OPEN,HJ_134*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-HJ_134*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-HJ_134*(HIGH-LOW),0-VOL/2));
HJ_136:=HJ_135/20/1.15;
HJ_137:=HJ_136*0.55+REF(HJ_136,1)*0.33+REF(HJ_136,2)*0.22;
HJ_138:=EMA(HJ_137,8);
HJ_139:=EMA(HJ_137,3);
HJ_140:=HJ_139;
HJ_141:=MA(VOL,5);
HJ_142:=MA(VOL,10);
HJ_143:=HJ_141>=HJ_142;
HJ_144:=HJ_140>=0;
HJ_145:=HJ_144 AND HJ_143;
HJ_146:=MA(kdj.K#WEEK(9,3,3),5);
HJ_147:=EMA(CLOSE,12/2)-EMA(CLOSE,26/2);
HJ_148:=EMA(HJ_147,9/2);
HJ_149:=HJ_146>=REF(HJ_146,1) AND HJ_147>=HJ_148;
股:(-8),COLORRED;
HJ_150:=EMA(CLOSE,3);
HJ_151:=EMA(CLOSE,5);
HJ_152:=EMA(HJ_151,5);
HJ_153:=COUNT(CROSS(HJ_150,HJ_152),2)=1;
HJ_154:=COUNT(CROSS(HJ_151,HJ_152),2)=1;
HJ_155:=FILTER(HJ_153 AND HJ_154,2);
市:MA(HJ_1,10),COLORGREEN,LINETHICK4;
HJ_156:=CROSS(HJ_1,市) AND 市>REF(市,1);
HJ_157:=MA(HJ_1,3);
长:IF(市>HJ_157,HJ_157,市),COLORMAGENTA,LINETHICK4;
虹:118,COLORRED;
HJ_158:=CROSS(HJ_1,长) AND REF(长,1)<长 AND HJ_1<长;
HJ_159:=长=市 AND REF(长<市,1) AND HJ_1>长;
HJ_160:=HJ_158 AND HJ_156;
HJ_161:=CROSS(市,HJ_1) OR CROSS(长,HJ_1);
HJ_162:=HJ_76+HJ_105+HJ_40+HJ_99+HJ_155>=1;
HJ_163:=HJ_76+HJ_105+HJ_40+HJ_99+HJ_155>=2;
HJ_164:=HJ_76+HJ_105+HJ_40+HJ_99+HJ_155>=3;
HJ_165:=HJ_76+HJ_105+HJ_40+HJ_99+HJ_155>=4;
HJ_166:=HJ_76 AND HJ_105 AND HJ_40 AND HJ_99 AND HJ_155;
HJ_167:=HJ_126 AND HJ_145 AND HJ_149;
HJ_168:=长>2 AND CROSS(HJ_1,长*5);
DRAWICON(HJ_166 AND HJ_167,长+44,30);
DRAWICON(HJ_165 AND HJ_167,长+38,28);
DRAWICON(HJ_164 AND HJ_167,长+32,34);
DRAWICON(HJ_164 AND HJ_167,长+32,1);
DRAWICON(HJ_163 AND HJ_167,长+26,34);
DRAWICON(HJ_162 AND HJ_167,长+20,42);
DRAWICON(HJ_149,0,25);
DRAWICON(HJ_145,118,38);
DRAWICON(HJ_159 AND HJ_167,HJ_1,13);
DRAWICON(HJ_168 AND EXIST(REF(HJ_168,1),5)=0 AND HJ_167,HJ_1+18,23);
HJ_169:=长=市 AND REF(长<市,1);
HJ_170:=长<市 AND REF(长=市,1);
HJ_171:=CROSS(SUM(HJ_169,BArslAST(HJ_170)),0.5);
DRAWICON(HJ_171,长+6,11);
HJ_172:=CROSS(SUM(HJ_170,BARSLAST(HJ_169)),0.5);
DRAWICON(HJ_172,长+8,12);
HJ_173:=CROSS(SUM(HJ_160,BARSLAST(HJ_161)),0.5);
DRAWICON(HJ_173,长+8,13);
DRAWICON(HJ_161 AND 市=长 AND REF(市=长,1),长+10,14);
HJ_174:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
HJ_175:=SMA(HJ_174,3,1);
HJ_176:=SMA(HJ_175,3,1);
HJ_177:=INTPART(HJ_175);
HJ_178:=INTPART(HJ_176);
HJ_179:=HJ_177+HJ_178;
HJ_180:=HJ_179-REF(HJ_179,1);
HJ_181:=EMA(WINNER(CLOSE)*70,3);
HJ_182:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
HJ_183:=HJ_182/(HJ_181+HJ_182)*100;
HJ_184:=HJ_181/(HJ_181+HJ_182)*100;
HJ_185:=EMA(HJ_183,55);
HJ_186:=EMA(HJ_184,55);
一路筹码:IF(HJ_184<=10,HJ_184,HJ_184),NODRAW,COLORYELLOW;
STICKLINE(HJ_184>REF(HJ_184,1) AND HJ_184>20,100+HJ_184,120,2.5,0),COLORAA00BB;
STICKLINE(HJ_184>REF(HJ_184,1) AND HJ_184>20,100+HJ_184,120,1.5,0),COLORCC22BB;
STICKLINE(HJ_184>REF(HJ_184,1) AND HJ_184>20,100+HJ_184,120,0.5,0),COLOREE44BB;
STICKLINE(HJ_184<=REF(HJ_184,1) AND HJ_184>20,100+HJ_184,120,2.5,0),COLORFF7700;
STICKLINE(HJ_184<=REF(HJ_184,1) AND HJ_184>20,100+HJ_184,120,1.5,0),COLORFFAA22;
STICKLINE(HJ_184<=REF(HJ_184,1) AND HJ_184>20,100+HJ_184,120,0.5,0),COLORFFFF55;
STICKLINE(HJ_184>REF(HJ_184,1) AND HJ_184<20,100+HJ_184,120,2.5,0),COLOR131FFD;
STICKLINE(HJ_184>REF(HJ_184,1) AND HJ_184<20,100+HJ_184,120,1.5,0),COLOR5050FF;
STICKLINE(HJ_184>REF(HJ_184,1) AND HJ_184<20,100+HJ_184,120,0.5,0),COLOR7E7EFF;
STICKLINE(HJ_184<=REF(HJ_184,1) AND HJ_184<20,100+HJ_184,120,2.5,0),COLORAA0000;
STICKLINE(HJ_184<=REF(HJ_184,1) AND HJ_184<20,100+HJ_184,120,1.5,0),COLORCC0000;
STICKLINE(HJ_184<=REF(HJ_184,1) AND HJ_184<20,100+HJ_184,120,0.5,0),COLORBLUE;
STICKLINE(HJ_186>REF(HJ_186,1),100+HJ_184,100+HJ_186,2.5,0),COLOR00AAFF;
STICKLINE(HJ_186>REF(HJ_186,1),100+HJ_184,100+HJ_186,1.5,0),COLOR00CCFF;
STICKLINE(HJ_186>REF(HJ_186,1),100+HJ_184,100+HJ_186,0.5,0),COLORYELLOW;
STICKLINE(HJ_184>HJ_186 AND HJ_186>50,100+HJ_184,100+HJ_186,2.5,0),COLOR0000AA;
STICKLINE(HJ_184>HJ_186 AND HJ_186>50,100+HJ_184,100+HJ_186,1.5,0),COLOR0022CC;
STICKLINE(HJ_184>HJ_186 AND HJ_186>50,100+HJ_184,100+HJ_186,0.5,0),COLOR0055FF;
STICKLINE(HJ_184>HJ_186 AND HJ_186<50 AND HJ_184>50 AND HJ_186>REF(HJ_186,1),100+HJ_184,150,2.5,0),COLOR0000AA;
STICKLINE(HJ_184>HJ_186 AND HJ_186<50 AND HJ_184>50 AND HJ_186>REF(HJ_186,1),100+HJ_184,150,1.5,0),COLOR0022CC;
STICKLINE(HJ_184>HJ_186 AND HJ_186<50 AND HJ_184>50 AND HJ_186>REF(HJ_186,1),100+HJ_184,150,0.5,0),COLOR0055FF;
STICKLINE(HJ_184>80,100+HJ_184,100+HJ_184-(HJ_184-80)/2,2.5,0),COLOR00AA00;
STICKLINE(HJ_184>80,100+HJ_184,100+HJ_184-(HJ_184-80)/2,1.5,0),COLOR00CC00;
STICKLINE(HJ_184>80,100+HJ_184,100+HJ_184-(HJ_184-80)/2,0.5,0),COLORGREEN;

通达信一路筹码指标公式

相关文章