在线检测未来函数

通达信共性太极图主图指标公式

来源:Internet,编辑:股旁网,2022-09-20

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1009”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

满:0.72*ma(FORCAst(CLOSE,2),40),COLOR0099FF,LINETHICK2;
DRAWICON(crOSS(满,LOW),LOW*0.94,18);
吸:0.82*MA(FORCAST(CLOSE,2),40),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(吸,LOW),LOW*0.97,11);
抛:1.16*MA(FORCAST(CLOSE,2),40),COLORCYAN,LINETHICK2;
DRAWICON(CROSS(HIGH,抛),HIGH*1.01,15);
出:1.36*MA(FORCAST(CLOSE,2),40),COLORYELLOW,LINETHICK2;
DRAWICON(CROSS(HIGH,出),HIGH*1.01,8);
清:1.6*MA(FORCAST(CLOSE,2),40),COLORRED,LINETHICK2;
轴:MA(FORCAST(CLOSE,2),40),COLORWHITE,LINETHICK3;
X_1:=(抛-轴)*0.5+轴;
X_2:=(抛-X_1)*0.618+X_1;
底:0.618*MA(FORCAST(CLOSE,2),40),COLORYELLOW,LINETHICK2;
B1:轴*1.03,COLORGRAY;
B2:轴*1.06,COLORGRAY;
B3:抛*1.03,COLORGRAY;
B4:抛*1.06,COLORGRAY;
B5:出*1.03,COLORGRAY;
B6:出*1.06,COLORGRAY;
轴损:(轴+B1+B2)/3*0.95,COLORWHITE;
抛损:(抛+B3+B4)/3*0.95,COLORWHITE;
出损:(抛+B3+B4)/3*1.1,COLORWHITE;
清损:清*0.95,COLORWHITE;
D1:吸*0.95,COLORGRAY;
D2:吸*0.9,COLORGRAY;
D3:满*0.95,COLORGRAY;
D4:满*0.9,COLORGRAY;
X_3:=轴-(轴-吸)*2/3;
DRAWICON(CROSS(底,LOW),LOW*0.98,24);
AMOW:=AMOUNT/10000.0,volSTICK;
AMO1:=MA(AMOW,40);
AMO2:=MA(AMOW,135);
X_4:=AMOW;
X_5:=AMO1;
X_6:=AMO2;
X_7:=CLOSE-REF(CLOSE,20);
X_8:=SUM(Abs(CLOSE-REF(CLOSE,1)),20);
X_9:=SUM(ABS(X_7/X_8),1);
X_10:=2/(2+1);
X_11:=2/(30+1);
X_12:=X_9*(X_10-X_11)+X_11;
X_13:=X_12*X_12;
X_14:=REF(CLOSE,1)+X_13*(CLOSE-REF(CLOSE,1));
X_15:=IF(SUM(1,0)=20+1,X_14,0);
X_16:=BArslAST(X_15>0);
X_17:=REF(CLOSE,X_16);
X_18:=REF(X_17,1)+X_13*CLOSE-REF(X_17,1);
X_19:=DMA(CLOSE,X_13);
持币:DMA(CLOSE,X_13),COLORGREEN,LINETHICK2;
持股:IF(X_19>REF(X_19,1),X_19,DRAWNULL),COLORRED,LINETHICK2;
X_20:=IF(X_19>REF(X_19,1),1,0);
X_21:=IF(X_19>REF(X_19,1) AND X_4>X_5 AND X_4>X_6,1,0);
X_22:=IF(X_19>REF(X_19,1) AND X_4>X_5 AND X_5>X_6,1,0);
转势:IF(REF(X_20,1)=0 AND X_20=1,1,0),NODRAW,COLORWHITE;
DRAWICON(CLOSE>持币 AND REF(CLOSE,1)<满,1.01*HIGH,7);
强牛:IF(X_19>REF(X_19,1) AND X_4>X_5 AND X_5>X_6,1,0),NODRAW,COLORYELLOW;
火箭:IF(REF(X_22,1)=0 AND X_22,1,0),NODRAW,COLORRED;
斜率:持股/REF(持股,1),NODRAW;
STICKLINE(NOT(X_20) AND CLOSE>=OPEN,HIGH,LOW,0,1),COLORWHITE;
STICKLINE(NOT(X_20) AND CLOSE>=OPEN,OPEN,CLOSE,3,1),COLORWHITE;
STICKLINE(NOT(X_20) AND CLOSE<=OPEN,HIGH,LOW,0,0),COLORWHITE;
STICKLINE(NOT(X_20) AND CLOSE<=OPEN,OPEN,CLOSE,3,0),COLORWHITE;
STICKLINE(X_20 AND CLOSE>=OPEN,HIGH,LOW,0,0),COLOR00CCFF;
STICKLINE(X_20 AND CLOSE>=OPEN,OPEN,CLOSE,3,1),COLOR00CCFF;
STICKLINE(X_20 AND CLOSE<=OPEN,HIGH,LOW,0,0),COLOR00CCFF;
STICKLINE(X_20 AND CLOSE<=OPEN,OPEN,CLOSE,3,0),COLOR00CCFF;
STICKLINE(X_21 AND CLOSE>=OPEN,HIGH,LOW,0,0),COLORRED;
STICKLINE(X_21 AND CLOSE>=OPEN,OPEN,CLOSE,3,1),COLORRED;
STICKLINE(X_21 AND CLOSE<=OPEN,HIGH,LOW,0,0),COLORRED;
STICKLINE(X_21 AND CLOSE<=OPEN,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(X_22 AND CLOSE>=OPEN,HIGH,LOW,0,0),COLORMAGENTA;
STICKLINE(X_22 AND CLOSE>=OPEN,OPEN,CLOSE,3,1),COLORMAGENTA;
STICKLINE(X_22 AND CLOSE<=OPEN,HIGH,LOW,0,0),COLORMAGENTA;
STICKLINE(X_22 AND CLOSE<=OPEN,OPEN,CLOSE,3,0),COLORMAGENTA;
X_23:=MA(CLOSE,3)-MA(CLOSE,10);
DRAWICON(HIGH>REF(HIGH,1) AND X_23<REF(X_23,1) AND CLOSE<OPEN AND CLOSE>X_1,HIGH*1.005,2);
DRAWICON(LOW<REF(LOW,1) AND X_23>REF(X_23,1) AND CLOSE<X_3,LOW*0.995,1);

通达信共性太极图主图指标公式

相关文章