在线检测未来函数

通达信波段买卖区间指标公式

来源:Internet,编辑:股旁网,2022-09-20

{指标介绍:暗紫持仓区;暗绿空仓区;仓区仅日线参考为准!}

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1009”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

J:=ma("kdj.J#WEEK",5)/1.1;
stICKLINE(J>=REF(J,1),100,0,4,0),COLOR380038;
STICKLINE(J<=REF(J,1),-40,0,4,0),COLOR004000;
周K&J均值:=J,COLORGREEN;
LCC:=REF(C,1);
rsi:=SMA(MAX(C-LCC,0),2,1)/SMA(Abs(C-LCC),2,1)*100,COLORLIRED,LINETHICK1;
RSI均值:=SMA(SMA(RSI,2,1),2,1),COLORMAGENTA;
TYP:=(HIGH+LOW+CLOSE)/3;
cci:=(TYP-MA(TYP,28))/(0.015*AVEDEV(TYP,28))/10;
dmi:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14)*100/DMI;
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14)*100/DMI;
ADX:=EXPMEMA(ABS(DMM-DMP)/(DMM+DMP)*100,6);
ADXR:=EXPMEMA(ADX,6);
波长A:MA(50*(L- LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20)),7),POINTDOT,COLORLIBLUE,LINETHICK4;
波长B:MA(-50*(L- LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20)),7),POINTDOT,COLORLIBLUE,LINETHICK4;
IF(REF(波长A,1)<波长A AND 波长A>=0,波长A,DRAWNULL),POINTDOT,COLORRED,LINETHICK4;
IF(REF(波长B,1)>波长B AND 波长A>=0,波长B,DRAWNULL),POINTDOT,COLORRED,LINETHICK4;
DMM买点:STICKLINE(crOSS(DMP,DMM)&&CROSS(DMP,ADX)&&CROSS(DMP,ADXR)&&V>REF(V,1)&&周K&J均值>REF(周K&J均值,1),20,-20,1,0),COLORMAGENTA;
DRAWTEXT(DMM买点,-1,'DMM买点!'),COLORMAGENTA;
ADX买点:STICKLINE(CROSS(ADX,DMM)&&CROSS(ADX,ADXR)&&V>REF(V,1)&&周K&J均值>REF(周K&J均值,1),15,-15,1,0),COLORLIRED;
DRAWTEXT(ADX买点,-1,'ADX买点!'),COLORLIRED;
CBA昨振:STICKLINE(CROSS(ADXR,ADX) OR REF(CROSS(ADXR,ADX),1)&&CROSS(CCI,-10) OR REF(CROSS(CCI,-10),1)&&周K&J均值>REF(周K&J均值,1),10,-10,1,0),COLORWHITE;
CBA共振:STICKLINE(CROSS(ADXR,ADX)&&CROSS(CCI,-10)&&周K&J均值>REF(周K&J均值,1),10,-10,1,0),COLORYELLOW;
DRAWTEXT(CBA共振,15,'CBA共振!'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=53,-30,'暗紫(持仓区);暗绿(空仓区);仓区仅日线参考为准!'),COLORMAGENTA;
0,LINETHICK2;

通达信波段买卖区间指标公式

相关文章