在线检测未来函数

通达信涨停潜伏指标公式

来源:Internet,编辑:股旁网,2022-09-20

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1009”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

N:=5;
X_1:=(3*CLOSE+LOW+OPEN+HIGH)/6;
X_2:=(20*X_1+19*REF(X_1,1)+18*REF(X_1,2)+17*REF(X_1,3)+16*REF(X_1,4)+15*REF(X_1,5)+14*REF(X_1,6)+13*REF(X_1,7)+12*REF(X_1,8)+11*REF(X_1,9)+10*REF(X_1,10)+9*REF(X_1,11)+8*REF(X_1,12)+7*REF(X_1,13)+6*REF(X_1,14)+5*REF(X_1,15)+4*REF(X_1,16)+3*REF(X_1,17)+2*REF(X_1,18)+REF(X_1,20))/210;
X_3:=Ema(X_2,13);
X_4:=EMA(CLOSE,5);
X_5:=EMA(X_4,8);
X_6:=EMA(X_5,13);
X_7:=EMA(X_6,50);
X_8:=REF(CLOSE,1)<REF(X_3,1) AND CLOSE>X_3;
X_9:=CLOSE/REF(CLOSE,1)>1+0.01*N;
X_10:=X_3/X_7<1+0.01*10;
X_11:=CLOSE>MA(LOW,20)*1.1;
stICKLINE(IF(X_8 AND X_9 AND X_11,1,0),6,0,4,0),COLOR000088;
STICKLINE(IF(X_8 AND X_9 AND X_11,1,0),6,0,3,0),COLOR0000AA;
STICKLINE(IF(X_8 AND X_9 AND X_11,1,0),6,0,2,0),COLOR0000CC;
STICKLINE(IF(X_8 AND X_9 AND X_11,1,0),6,0,1.4,0),COLOR0000EE;
STICKLINE(IF(X_8 AND X_9 AND X_11,1,0),6,0,0.9,0),COLOR0000EE;
STICKLINE(IF(X_8 AND X_9 AND X_11,1,0),6,0,0.3,0),COLORLIMAGENTA;
X_12:=(HIGH+LOW+CLOSE)/3;
X_13:=AMOUNT/IF(HIGH=LOW,4,HIGH-LOW);
X_14:=X_13*(MIN(OPEN,CLOSE)-LOW);
X_15:=X_13*(X_12-MIN(CLOSE,OPEN));
X_16:=X_13*(HIGH-MAX(OPEN,CLOSE));
X_17:=X_13*(MAX(CLOSE,OPEN)-X_12);
X_18:=(X_14+X_15-(X_17+X_16))/10000;
X_19:=SUM(X_18,1);
X_20:=SUM(X_18,2);
X_21:=SUM(X_18,3);
X_22:=SUM(X_18,4);
X_23:=SUM(X_18,5);
X_24:=SUM(X_18,6);
X_25:=SUM(X_18,7);
X_26:=SUM(X_18,8);
X_27:=SUM(X_18,9);
X_28:=SUM(X_18,10);
X_29:=X_19>0;
X_30:=X_20>0;
X_31:=X_21>0;
X_32:=X_22>0;
X_33:=X_23>0;
X_34:=X_24>0;
X_35:=X_25>0;
X_36:=X_26>0;
X_37:=X_27>0;
X_38:=X_28>0;
X_39:=X_29<1 AND X_30<1 AND X_31<1 AND X_32<1 AND X_33<1 AND X_34<1 AND X_35<1 AND X_36<1 AND X_37<1 AND X_38<1;
STICKLINE(IF(X_39,1,0),4,0,4,0),COLOR00AAFF;
STICKLINE(IF(X_39,1,0),4,0,3,0),COLOR00AAFF;
STICKLINE(IF(X_39,1,0),4,0,2,0),COLOR00CCFF;
STICKLINE(IF(X_39,1,0),4,0,1.4,0),COLOR00CCFF;
STICKLINE(IF(X_39,1,0),4,0,0.9,0),COLOR00CCFF;
STICKLINE(IF(X_39,1,0),4,0,0.3,0),COLORWHITE;
STICKLINE(X_39=1,0,4,3,0),COLOR00AAFF;
STICKLINE(X_39=1,0,4,2,0),COLOR00CCFF;
STICKLINE(X_39=1,0,4,1,0),COLORYELLOW;
STICKLINE(X_39=1,0,4,0,0),COLORWHITE;

通达信涨停潜伏指标公式

相关文章