在线检测未来函数

通达信成交专家指标公式

来源:Internet,编辑:股旁网,2022-09-21

VAR0:=Ema(vol,20);{√}
VAR1:= VAR0 + 2*stD(VOL,10);
VAR2:=VAR0 - 2*STD(VOL,10);
{MID:STICKLINE( VAR0>REF( VAR0,1) , VAR0 ,REF( VAR0,1) ,8 ,0 ),COLORYELLOW;}
UPPER:STICKLINE(VAR1>REF(VAR1,1) ,VAR1 ,REF(VAR1,1) ,3.5 ,0 ),COLORRED;
LOWER:STICKLINE(VAR2>REF(VAR2,1) ,VAR2 ,REF(VAR2,1) ,3.5 , 0),COLORRED;
{STICKLINE( VAR0<REF( VAR0,1) , VAR0 ,REF( VAR0,1) ,8 ,0 ),COLORWHITE;}
STICKLINE(VAR1<REF(VAR1,1) ,VAR1 ,REF(VAR1,1) ,3.5 ,0),COLORWHITE;
STICKLINE(VAR2<REF(VAR2,1) ,VAR2 ,REF(VAR2,1) ,3.5 , 0),COLORWHITE;
VARA1:=VOL;
C1: (EMA(VARA1,2)+EMA(VARA1,5)+EMA(VARA1,8))/3,LINETHICK2, COLORYELLOW;
C2: (EMA(VARA1,3)+EMA(VARA1,6)+EMA(VARA1,9))/3,COLOR00CC33;
C3: (EMA(VARA1,4)+EMA(VARA1,7)+EMA(VARA1,10))/3,COLOR00CC33;
C4: (EMA(VARA1,5)+EMA(VARA1,8)+EMA(VARA1,11))/3,COLOR00CC33;
C5: (EMA(VARA1,6)+EMA(VARA1,9)+EMA(VARA1,12))/3,COLOR00CC33;
C6: (EMA(VARA1,7)+EMA(VARA1,10)+EMA(VARA1,13))/3,COLOR00CC33;
C7: (EMA(VARA1,8)+EMA(VARA1,11)+EMA(VARA1,14))/3,COLOR00CC33;
C8: (EMA(VARA1,9)+EMA(VARA1,12)+EMA(VARA1,15))/3,COLOR00CC33;
C9: (EMA(VARA1,10)+EMA(VARA1,13)+EMA(VARA1,16))/3,COLOR00CC33;
C10: (EMA(VARA1,11)+EMA(VARA1,14)+EMA(VARA1,17))/3,COLOR00CC33;
C11: (EMA(VARA1,12)+EMA(VARA1,15)+EMA(VARA1,18))/3,COLOR00CC33;
C12: (EMA(VARA1,13)+EMA(VARA1,16)+EMA(VARA1,19))/3,COLOR00CC33;
C13: (EMA(VARA1,14)+EMA(VARA1,17)+EMA(VARA1,20))/3,COLOR00CC33;
C14: (EMA(VARA1,15)+EMA(VARA1,18)+EMA(VARA1,21))/3,COLOR00CC33;
C15: (EMA(VARA1,16)+EMA(VARA1,19)+EMA(VARA1,22))/3,COLOR00CC33;
C16: (EMA(VARA1,17)+EMA(VARA1,20)+EMA(VARA1,23))/3,COLOR00CC33;
C17: (EMA(VARA1,18)+EMA(VARA1,21)+EMA(VARA1,24))/3,COLOR00CC33;
C18: (EMA(VARA1,19)+EMA(VARA1,22)+EMA(VARA1,25))/3,COLOR00CC33;
C19: (EMA(VARA1,20)+EMA(VARA1,23)+EMA(VARA1,26))/3,LINETHICK3, COLOR0099FF;
C20: (EMA(VARA1,21)+EMA(VARA1,24)+EMA(VARA1,27))/3,COLOR00CC33;
C21: (EMA(VARA1,22)+EMA(VARA1,25)+EMA(VARA1,28))/3,COLOR00CC33;
C22: (EMA(VARA1,23)+EMA(VARA1,26)+EMA(VARA1,29))/3,COLOR00CC33;
C23: (EMA(VARA1,24)+EMA(VARA1,27)+EMA(VARA1,30))/3,COLOR00CC33;
C24: (EMA(VARA1,25)+EMA(VARA1,28)+EMA(VARA1,31))/3,COLOR00CC33;
C25: (EMA(VARA1,26)+EMA(VARA1,29)+EMA(VARA1,32))/3,COLOR00CC33;
C26: (EMA(VARA1,27)+EMA(VARA1,30)+EMA(VARA1,33))/3,COLOR00CC33;
C27: (EMA(VARA1,28)+EMA(VARA1,31)+EMA(VARA1,34))/3,COLOR00CC33;
C28: (EMA(VARA1,29)+EMA(VARA1,32)+EMA(VARA1,35))/3,COLOR00CC33;
C29: (EMA(VARA1,30)+EMA(VARA1,33)+EMA(VARA1,36))/3,COLOR00CC33;
C30: (EMA(VARA1,31)+EMA(VARA1,34)+EMA(VARA1,37))/3,COLOR00CC33;
C31: (EMA(VARA1,32)+EMA(VARA1,35)+EMA(VARA1,38))/3,COLOR00CC33;
C32: (EMA(VARA1,33)+EMA(VARA1,36)+EMA(VARA1,39))/3,COLOR00CC33;
C33: (EMA(VARA1,34)+EMA(VARA1,37)+EMA(VARA1,40))/3,COLOR00CC33;
C34: (EMA(VARA1,35)+EMA(VARA1,38)+EMA(VARA1,41))/3,COLOR00CC33;
C35: (EMA(VARA1,36)+EMA(VARA1,39)+EMA(VARA1,42))/3,COLOR00CC33;
C36: (EMA(VARA1,37)+EMA(VARA1,40)+EMA(VARA1,43))/3,COLOR00CC33;
C37: (EMA(VARA1,38)+EMA(VARA1,41)+EMA(VARA1,44))/3,COLOR00CC33;
C38: (EMA(VARA1,39)+EMA(VARA1,42)+EMA(VARA1,45))/3,COLOR00CC33;
C39: (EMA(VARA1,40)+EMA(VARA1,43)+EMA(VARA1,46))/3,LINETHICK2, COLORBLUE;

通达信成交专家指标公式

相关文章