在线检测未来函数

通达信寻龙方向标指标公式

来源:Internet,编辑:股旁网,2022-09-27

{指标介绍:绿色持币,白色观望,红色小买,红上有黄加仓。}

X_1:=IF(PERIOD<3,35,IF(PERIOD<=5,28,IF(PERIOD<=7,21,IF(PERIOD<=8,14,IF(PERIOD<=9,7,5)))));
X_2:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_3:=maX(HIGH-LOW,MAX(HIGH-REF(CLOSE,1),REF(CLOSE,1)-LOW))/REF(CLOSE,1)*100;
X_4:=(HIGH-LOW)/REF(CLOSE,1)*100;
X_5:=vol/REF(MA(VOL,5),1);
X_6:=VOL;
X_7:=(HIGH+LOW+CLOSE)/3;
X_8:=CLOSE>X_7;
X_9:=CLOSE<X_7;
X_10:=X_2*X_6;
X_11:=Abs(IF(X_9,X_10,0));
X_12:=IF(X_8,X_10,0);
X_13:=ABS(SUM(IF(X_10<0,X_10,0),7));
X_14:=SUM(IF(X_10>0,X_10,0),7);
X_15:=ABS(X_13-X_14);
X_16:=49;
X_17:=(X_13+X_14)/2;
X_18:=stDP(MAX(X_13,X_14),X_16);
X_19:=STDP(MIN(X_13,X_14),X_16);
X_20:=WMA(X_17,X_16);
X_21:=X_20+1.618*X_18;
X_22:=X_20-1.618*X_19;
X_23:=X_14>X_13 AND X_14>=X_20;
X_24:=X_13>X_14 AND X_13>=X_20;
X_25:=X_14>X_13 AND X_14>X_21;
X_26:=X_13>X_14 AND X_13>X_21;
X_27:=X_14<X_13 AND X_14<X_22;
X_28:=X_13<X_14 AND X_13<X_22;
X_29:=X_14>=HHV(X_14,100) AND X_14>0;
X_30:=X_13>=HHV(X_13,100) AND X_13>0;
X_31:=X_14<=LLV(X_14,100);
X_32:=X_13<=LLV(X_13,100);
STICKLINE(X_23,X_14,MAX(X_20,X_13),2,0),COLORRED;
STICKLINE(X_24,X_13,MAX(X_20,X_14),2,0),COLORGREEN;
STICKLINE(X_25,X_14,MAX(X_21,X_13),2,0),COLORYELLOW;
STICKLINE(X_26,X_13,MAX(X_21,X_14),2,0),COLORWHITE;
X_33:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
X_34:=CLOSE/REF(CLOSE,1)>=1.08 AND CLOSE=HIGH AND NOT(CODELIKE(3));
STICKLINE(X_25 AND X_34 AND X_33<20,MAX(X_21,X_13),MAX(X_21,X_13)*2,2,0),COLORGREEN;

通达信寻龙方向标指标公式

相关文章