在线检测未来函数

通达信呆呆兔主图指标公式

来源:Internet,编辑:股旁网,2022-11-23

分时均价:AMOUNT/vol/100,NODRAW,COLORYELLOW;
{变色加粗bbi}
BBI:(ma(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,LINETHICK2;
IF(C>=BBI,BBI,DRAWNULL),COLORRED,LINETHICK2;
IF(C<BBI,BBI,DRAWNULL),COLORGREEN,LINETHICK2;
{近日最高最低价画线}
近日高:IF(CURRBARSCOUNT<=CONst(FINDHIGHBARS(HIGH,0,6,1)+1),CONST(FINDHIGH(HIGH,0,6,1)),DRAWNULL),COLORRED,LINETHICK1;
近日低:IF(CURRBARSCOUNT<=CONST(FINDLOWBARS(LOW,0,6,1)+1),CONST(FINDLOW(LOW,0,6,1)),DRAWNULL),COLORGREEN,LINETHICK1;
DRAWSL(ISLASTBAR,近日高,0,2000,1),COLORRED,LINETHICK1;
DRAWSL(ISLASTBAR,近日低,0,2000,1),COLORGREEN,LINETHICK1;
{涨跌停k线变色}
RQ:=IF(DATE>=1200824,1,0);
KCB:=IF(INBLOCK('科创板'),1,0);
CYB:=IF(INBLOCK('创业板') AND RQ,1,0);
{20%涨停洋红色,跌停蓝色}
STICKLINE(C/REF(C,1)>1.195 AND C=H AND (KCB OR CYB) AND PERIOD=5,O,C,3,0),COLORMAGENTA;
STICKLINE(C/REF(C,1)<0.805 AND C=L AND (KCB OR CYB) AND PERIOD=5,O,C,3,0),COLORBLUE;
{10%涨停红色,跌停绿色}
STICKLINE(C/REF(C,1)>1.095 AND C=H AND NOT(KCB OR CYB) AND PERIOD=5,O,C,3,0),COLORRED;
STICKLINE(C/REF(C,1)<0.905 AND C=L AND NOT(KCB OR CYB) AND PERIOD=5,O,C,3,0),COLORGREEN;
{自定义数据}
DRAWTEXT_FIX(1,0.00,0.00,0,'主营业务:')COLOR0000FF;
DRAWTEXT_FIX(1,0.05,0.00,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.07,0,'所属概念:')COLORFF00FF;
DRAWTEXT_FIX(1,0.05,0.07,0,EXTERNSTR(0,2))COLORFF00FF;
DRAWTEXT_FIX(1,0.00,0.14,0,'')COLOR00FF00;
DRAWTEXT_FIX(1,0.00,0.14,0,EXTERNSTR(0,3))COLOR00FF00;
DRAWTEXT_FIX(1,0.00,0.21,0,'解禁信息:')COLORYELLOW;
DRAWTEXT_FIX(1,0.05,0.21,0,EXTERNSTR(0,4))COLORYELLOW;
DRAWTEXT_FIX(1,0.00,0.28,0,'减持信息:')COLORYELLOW;
DRAWTEXT_FIX(1,0.05,0.28,0,EXTERNSTR(0,5))COLORYELLOW;
{周标记}
JZX:=WEEkdAY<>REF(WEEKDAY,1);{时间取值取周}
DRAWNUMBER(JZX,L,WEEKDAY)COLORYELLOW;

通达信呆呆兔主图指标公式

相关文章