在线检测未来函数

通达信金叉红柱指标公式

来源:Internet,编辑:股旁网,2022-11-24

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1011”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

VAR0:=(CLOSE - ma(CLOSE,5)) / MA(CLOSE,5);
LHX:(VAR0) * 100,stICK ;
STICKLINE(VAR0>0,0,LHX,2.5,0), COLORRED;
STICKLINE(VAR0>0,0,LHX,2.5,0),COLOR9933FF;
STICKLINE(VAR0>0,0,LHX,2,0), COLOR000099;
STICKLINE(VAR0>0,0,LHX,1.5,0),COLOR0000CC;
STICKLINE(VAR0>0,0,LHX,1,0), COLOR0000FF;
STICKLINE(VAR0>0,0,LHX,0,0), COLOR0033FF;
STICKLINE(VAR0<0,0,LHX,2.5,0),COLORCYAN;
STICKLINE(VAR0<0,0,LHX,2.5,0),COLOR009900;
STICKLINE(VAR0<0,0,LHX,2,0), COLOR00CC00;
STICKLINE(VAR0<0,0,LHX,1.5,0),COLOR33FF00;
STICKLINE(VAR0<0,0,LHX,1,0), COLOR33FF00;
STICKLINE(VAR0<0,0,LHX,0,0), COLOR33FF00;
VAR1:=5;
LHX1:EMA(LHX,VAR1) * VAR1 ,COLORMAGENTA;
LHX2:MA(LHX1,3),COLORGREEN ;
LHX3:MA(LHX1,5),COLORWHITE;
SVAR0:=(LLV(CLOSE,3) - HHV(CLOSE,13)) / HHV(CLOSE,13) * 100 < -13 ;
SVAR1:=crOSS(LHX1,LHX2) AND SVAR0 AND LLV(LHX1,3) - REF(LHX1,13) < -25 AND LHX3 < -8 ;
SVAR2:=SVAR1 AND (LLV(LHX2,3) > LLV(LHX2,39) OR LLV(LHX3,3) > LLV(LHX3,39)) ;
SVAR3:=(LLV(LHX2,3) > LLV(LHX2,44) OR LLV(LHX3,3) > LLV(LHX3,44)) AND CROSS(LHX1,LHX2) AND COUNT(LHX1 < -22,3) >= 1 ;
SVAR4:=(REF(LHX1,1) < REF(LHX1,2) AND LHX1 > REF(LHX1,1)) OR CROSS(LHX1,LHX2) ;
SVAR5:=(SVAR4 OR CROSS(LHX1,LHX3)) AND COUNT(LHX1 < -5,3) >= 1 AND LHX1 - REF(LHX1,1) > 1 ;
N:=9;
M1:=3;
M2:=3;
RSV:= (HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N))*100;
Lwr1:=SMA(RSV,M1,1);
LWR2:=SMA(LWR1,M2,1);
买入:FILTER(SVAR5 AND LWR1 < REF(LWR1,1),2),COLOR0000FF ;
抄底:FILTER(SVAR2,3) OR FILTER(SVAR3 AND LHX1 - REF(LHX1,1) > 1,2),COLOR0000FF ;
DRAWTEXT(买入,5,'进'),COLOR0000FF;
{VERTLINE(买入,0),COLOR0000FF;}
STICKLINE(买入,-10,20,0,0),COLORRED;
DRAWTEXT(抄底,15,'抄底'),COLOR0000FF;
{VERTLINE(抄底,0),COLOR0000FF;}
STICKLINE(抄底,-10,20,0,0),COLOR0000FF;
DRAWTEXT_FIX(C>0,0.01,0.08,0,'操作基本要领(个股参考):金叉买,死叉卖,红柱买随便卖'),COLORRED;

通达信金叉红柱指标公式

相关文章