在线检测未来函数

KDJ操盘之大魔王选股指标公式

来源:Internet,编辑:股旁网,2023-01-19

本文选股公式根据以下股票公式改编:

股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1013”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

MWA_1:=C<REF(C,4);
MWA_2:=Dma(CLOSE,vol/SUM(VOL,34));
MWA_3:=DMA(CLOSE,VOL/SUM(VOL,13));
MWA_4:=(CLOSE-MWA_2)/MWA_2*100;
MWA_5:=(CLOSE-MWA_3)/MWA_3*100;
MWA_6:=BArslAstCOUNT(MWA_1);
MWA_8:=COUNT(MWA_6=6,5)=1;
MWA_9:=MWA_5<=-17 AND MWA_4<=-25;
MWA_10:=MWA_8 AND MWA_9;
MWA_11:=MA((CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ,2);
MWA_12:=MWA_11<-20;
魔王A:=MWA_10 AND MWA_12 AND C>REF(C,1)*0.91 AND C<REF(C,1) AND INDEXC<REF(INDEXC,1) AND REF(C>REF(C,1),1);
MWB_1:=O/HHV(C,30)<0.78;
MWB_2:=C/MA(C,50)<0.78;
MWB_3:=O=LLV(O,30);
MWB_4:=C/SMA(C,13,1)-1;
MWB_5:=REF(MWB_4,1)<-0.13;
MWB_6:=REF(MWB_4,1)/MWB_4>1.1582;
MWB_7:=REF(C,1)<=COST(5);
MWB_8:=COUNT(H>L*1.05,5)>2;
魔王B:=MWB_1 AND MWB_2 AND MWB_3 AND MWB_5 AND MWB_6 AND MWB_7 AND MWB_8;
魔王C:=WINNER(C)*100<10 AND (WINNER(C*1.25)-WINNER(C))*100<20 AND C/REF(C,1)>1.0138 AND V/REF(V,1)<1;
MWD_1:=(CLOSE-SMA(CLOSE,7,1))/SMA(CLOSE,7,1)*(-100);
MWD_2:=REF(MWD_1,1)>13 AND REF(MWD_1,1)/MWD_1>1.3 AND CLOSE/REF(CLOSE,1)>1.03;
魔王D:=IF(MWD_2 AND REF(CLOSE,1)<=COST(5),1,0) AND C<MA(C,60);
MWE_1:=(C-MA(C,3))/MA(C,3)*100;
MWE_3:=INDEXC;
MWE_4:=MA(MWE_3,5);
MWE_5:=MWE_4>1.05*MWE_3;
MWE_7:=(C-REF(C,21))/REF(C,21)*10;
MWE_9:=MWE_5;
MWE_10:=MWE_7<-2.30;
MWE_11:=MWE_1<-2.7;
MWE_12:=MWE_9 AND MWE_10 AND MWE_11;
MWE_13:=crOSS(0.55,MWE_12);
MWE_14:=CROSS(MWE_13,0.5);
JS2:=BARSLAST(MWE_14=1);
MWE_15:=JS2<=5 AND C<REF(C,JS2);
MWE_16:=MWE_13 OR MWE_15;
魔王E:=BARSLASTCOUNT(REF(MWE_16,1))=1;
MWF_6:=EMA(CLOSE,12)-EMA(CLOSE,150);
MWF_7:=EMA(MWF_6,9);
MWF_8:=(MWF_6-MWF_7)*2;
MWF_9:=MWF_8<0 AND REF(MWF_8,1)<REF(MWF_8,2) AND REF(MWF_8,2)<REF(MWF_8,3) AND REF(MWF_8,3)<REF(MWF_8,4);
MWF_10:=MWF_8<0 AND REF(MWF_8,1)<REF(MWF_8,2) AND REF(MWF_8,2)<REF(MWF_8,3);
MWF_11:=MWF_8<0 AND REF(MWF_8,1)<REF(MWF_8,2);
MWF_12:=MWF_9 OR MWF_10 OR MWF_11;
MWF_13:=MWF_12;
MWF_14:=CLOSE/MA(CLOSE,20)*100<80;
MWF_15:=CLOSE/MA(CLOSE,40)*100<78;
MWF_16:=CLOSE/MA(CLOSE,60)*100<72;
MWF_17:=HIGH>LOW*1.051;
MWF_18:=MWF_17 AND COUNT(MWF_17,5)>1;
MWF_19:=(MWF_14 AND MWF_15) OR (MWF_15 AND MWF_16) OR (MWF_14 AND MWF_16);
MWF_20:=MWF_18 AND MWF_19;
MWF_21:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
MWF_23:=((REF(MWF_21,1)<REF(MWF_21,2) AND MWF_21<-20 AND MWF_21>-25) AND MWF_21>=REF(MWF_21,1)) OR (REF(CROSS(-20,MWF_21),1) AND CROSS(MWF_21,-20));
MWF_24:=MWF_23;
MWF_25:=MWE_4 AND MWF_13 AND COUNT(MWF_20,3)>=1 AND COUNT(MWF_24,5)>=1;
魔王F:=BARSLASTCOUNT(MWF_25)=1;
MWG_1:=C/MA(C,40)<0.80;
MWG_2:=EMA(C,2);
MWG_3:=EMA(MWG_2,1);
MWG_4:=MWG_2-REF(MWG_2,1);
MWG_5:=MWG_3-REF(MWG_3,1);
MWG_6:=Abs(MWG_2-MWG_3);
MWG_7:=(H-L)/REF(C,1)>0.05;
MWG_8:= (MWG_4+MWG_5)/2;
MWG_9:=POW(MWG_6,1)*POW(MWG_8,3);
MWG_10:=MWG_9/HHV(ABS(MWG_9),15);
MWG_11:=COUNT(MWG_7,5)>1;
MWG_12:=EMA(CLOSE,12)-EMA(CLOSE,26);
MWG_13:=EMA(MWG_12,9);
MWG_14:=(MWG_12-MWG_13)*2;
MWG_15:=MWG_1 AND MWG_11;
MWG_16:=CROSS(MWG_10,-0.9);
MWG_17:=FILTER(REF(MWG_15,1) AND (MWG_16 OR C>REF(C,1)) AND MWG_14>-0.58,10);
MWG_18:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
MWG_19:=MWG_18/2+22;
MWG_20:=(MWG_18+2)<MWG_19;
MWG_21:=(HIGH+LOW+CLOSE)/3;
MWG_22:=(MWG_21-MA(MWG_21,14))/(0.015*AVEDEV(MWG_21,14));
MWG_23:=MWG_20 AND COUNT(MWG_17,10)>=1 AND MWG_22>-108;
魔王G:=BARSLASTCOUNT(MWG_23)=1;
MWH_1:=DMA(CLOSE,VOL/MA(VOL,4)/4);
MWH_2:=DMA(CLOSE,VOL/MA(VOL,32)/32);
MWH_3:=(CLOSE-MWH_1)/MWH_1*100<-8;
MWH_4:=(MWH_1-MWH_2)/MWH_2*100<-21;
MWH_5:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.05;
MWH_6:=COUNT(NOT(C=O),8)>=8;
魔王H:=MWH_3 AND MWH_4 AND MWH_5 AND MWH_6;
MWI_1:=INDEXC/MA(INDEXC,58)<0.848 AND C/EMA(C,58)<0.81;
MWI_2:=BARSLAST(MWI_1)+1;
MWI_3:=BETWEEN(MWI_2,2,15) AND C<REF(C,MWI_2);
MWI_4:=COUNT(MWI_1,2) OR MWI_3;
魔王I:=FILTER(MWI_4,12);
MWJ_1:=(C-MA(C,90))/MA(C,90)*100;
MWJ_2:=(COST(11)-CLOSE)/CLOSE>0.15;
魔王J:=CROSS(MWJ_1,-26) AND MWJ_2;
MWK_1:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);
MWK_2:=REF(MWK_1,1)>13 AND REF(MWK_1,1)/MWK_1>1.23 AND CLOSE/REF(CLOSE,1)>1.03;
MWK_3:=EMA(CLOSE,24);
MWK_4:=EMA(MWK_3*80/100,5);
MWK_5:=(REF(MWK_4,1)>REF(C,1) AND C>MWK_4 AND C>REF(C,1)*1.02);
MWK_6:=C/SMA(C,13,1)-1;
MWK_7:=O/HHV(C,30)<0.78 AND C/MA(C,50)<0.78 AND O=LLV(O,30) AND REF(MWK_6,1)<-0.13 AND REF(MWK_6,1)/MWK_6>1.1582 AND REF(C,1)<=COST(5) AND COUNT(H>L*1.05,5)>2;
MWK_8:=MWK_2 AND REF(CLOSE,1)<=COST(5);
魔王K:=FILTER(MWK_5,3) OR MWK_7 OR MWK_8;
MWL_10:=5;
MWL_11:=10;
MWL_12:=0.01*EMA(AMOUNT,MWL_10)/EMA(VOL,MWL_10);
MWL_13:=(MWL_12/REF(MWL_12,1)-1)*100;
MWL_14:=MA(MWL_13,MWL_11);
XA_9:=MWL_13<(-1.1) AND MWL_14<(-1.1);
MWL_15:=CROSS(MWL_13,MWL_14);
MWL_16:=XA_9 AND MWL_15;
MWL_17:=9;
MWL_18:=CLOSE-REF(CLOSE,1);
MWL_19:=100*EMA(EMA(MWL_18,MWL_17),MWL_17)/EMA(EMA(ABS(MWL_18),MWL_17),MWL_17);
MWL_20:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
MWL_21:=REF(CLOSE,1);
MWL_22:=SMA(MAX(CLOSE-MWL_21,0),MWL_17,1)/SMA(ABS(CLOSE-MWL_21),MWL_17,1)*100;
MWL_23:=(CLOSE-REF(CLOSE,26))/REF(CLOSE,26)*10;
魔王L:=CROSS(MWL_22,20) AND MWL_19<(-45) AND MWL_20<12 AND MWL_23<(-2) AND MWL_16;
魔王:=魔王A+魔王B+魔王C+魔王D+魔王E+魔王F+魔王G+魔王H+魔王I+魔王J+魔王K+魔王L;
大魔王:魔王>=3;

KDJ操盘之大魔王选股指标公式

相关文章