在线检测未来函数

通达信百分线指标公式

来源:Internet,编辑:股旁网,2010-05-24

{公式并无好坏之分,快速判断强弱,一目了然,立即下手操作。简单快捷,应是图表分析应用的基本原则。至于是不是一定赚钱,功夫不在于公式,而是在于实战中你自己的分析判断和心理状态。
图表中自己加了四种K线形态,用来辅助分析趋势的中继、停顿和转向。具体用法,仁者见仁,智者见智。}

M1:MA(C,5);
M2:MA(C,8);
M3:MA(C,13);
MA30:=MA(C,30);
N:=60;M:=1;
高:=REF(HHV(H,N),M);
低:=REF(LLV(L,N),M);
{GUPIAOFF.COM};H33:=高-(高-低)*0.33;
H中:=高-(高-低)*0.5;
H66:=高-(高-低)*0.66;
顶点:REFDATE(高,DATE),COLORAAAA00;
%33:REFDATE(H33,DATE),COLORAAAAAA;
%50:REFDATE(H中,DATE),COLORAAAA00;
%66:REFDATE(H66,DATE),COLORAAAAAA;
低点:REFDATE(低,DATE),COLORAAAA00;
DRAWTEXT(ISLASTBAR,顶点,'顶'),COLORAAAAAA;
DRAWTEXT(ISLASTBAR,%33,'%33'),COLORAAAAAA;
DRAWTEXT(ISLASTBAR,%50,'%50'),COLORRED;
DRAWTEXT(ISLASTBAR,%66,'%66'),COLORAAAAAA;
DRAWTEXT(ISLASTBAR,低点,'低'),COLORAAAAAA;

{长脚}
长脚:=(MIN(C,O)-L)/L*100>3.5 AND (MIN(C,O)-L)/(MAX(C,O)-MIN(C,O))>1.3 AND L<=LLV(L,50);
STICKLINE(长脚,H,L,0.0,1),COLORFFFFFF;
STICKLINE(长脚,O,C,3,1),COLORFFFFFF;
十字:=(MIN(CLOSE,OPEN)-LOW)/MIN(CLOSE,OPEN)>0.015 AND (H-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)>0.015 AND MAX(CLOSE,OPEN)/MIN(CLOSE,OPEN)<1.012;
STICKLINE(十字,H,L,0,1),COLOR00FFFF;
STICKLINE(十字,C,O,3,0),COLOR00FFFF;
{GUPIAOFF.COM};哎呀:=C/MA(C,5)<0.96 AND O/REF(L,1)<0.99 AND C>REF(L,1) AND MA(C,3)/REF(MA(C,3),1)<0.98;
STICKLINE(哎呀,H,L,0,1),COLORFFFFFF,LINETHICK1;
STICKLINE(哎呀,C,O,1,0),COLORFFFFFF,LINETHICK1;
DRAWTEXT(哎呀,LOW,'哎呀'),COLORFFFFFF;
桩:=C/REF(C,1)>1.03 AND V/REF(V,1)>2 AND C=HHV(C,7);
STICKLINE(桩,C,O,3,0),COLOR0000FF,LINETHICK1;
STICKLINE(桩,C,O,2,0),COLOR00AAFF,LINETHICK1;
STICKLINE(桩,C,O,1,0),COLOR00FFFF,LINETHICK1;

 

相关文章