在线检测未来函数

通达信实用的VOL指标公式

来源:Internet,编辑:股旁网,2010-05-24

一个实用的VOL,可看出换手还是打压
显示的蓝色棒,是换手

参数: m 1 120 5

HSL:HSL*CAPITAL,LINETHICK1 COLORFF00FF ;
MAHSL:MA(HSL,M),LINETHICK1 COLORYELLOW;
VUR0:=(2*OPEN+HIGH+LOW+3*CLOSE)/7;
VUR1:=IF(CAPITAL,CAPITAL,-1)*VUR0;
VUR2:=SMA(AMOUNT,10,1)/1000;
VUR3:=MA(CLOSE*3,5);
VUR4:=VUR2*(CLOSE*3)/VUR3*1/10;
VUR5:=VUR2*(OPEN*3)/VUR3*1/10;
VUR6:=VUR2*(HIGH*3)/VUR3*1/10;
VUR7:=VUR2*(LOW*3)/VUR3*1/10;
VUR8:=(2*VUR5+VUR6+VUR7+3*VUR4)/7;
VUR9:=DMA(EMA(VUR4,2),SUM(VOL,1)*VUR8);
VUR10:=EMA(VUR9,2);
VURA:=VUR9>VUR10;
VURB:=EMA(VUR1-VUR9,1);
VURC:=REF(VURB,1);
VURD:=VURB>VURC;
VURE:=(VURB-VURC)*15;
VURF:=(VUR9-VUR10)*30000;
VURG:=(VURC-VURB)*(-1);
VURH:=IF(VURB>VURC,VURE/500,0);
VURN:=IF(VURB<VURC,VURE/500,0);
VURT:=IF(VURA AND VURD,VURF/2000000,0);
VURL:=IF(VURA AND VURB<VURC,VURE/1000,0);
0,COLOR8A8A8A;
买进量_手:VURH,COLORRED,POINTDOT;
卖出量_手:VURN,COLORGREEN,POINTDOT;
买进_强烈:VURT,COLORYELLOW,POINTDOT;
打压_减筹:VURL,COLORFF00FF,POINTDOT;
STICKLINE(VURB>VURC,0,VURE,2.5,1),COLORRED;
STICKLINE(VURB<VURC,0,VURE,2.5,0),COLORGREEN;
STICKLINE(VURA AND VURD AND CLOSE>OPEN,0,VURF*0.5,2.5,0),COLORYELLOW;
STICKLINE(VURA AND VURB<VURC,0,VURE,2.5,0),COLORMAGENTA;
HS:=FLOOR(SUM(V/CAPITAL,0));
完全换手:STICKLINE(HS>REF(HS,1),0,VURE,2,0),COLORFF0000;

 

相关文章