在线检测未来函数

通达信金牛一线牵指标公式

来源:Internet,编辑:股旁网,2010-05-24

{金牛一线牵}
N1:=7;
LC:=REF(CLOSE,1);
X:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*1000,COLORMAGENTA;
牛相:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1);
TJ1:=X=牛相;
TJ2:=X<REF(X,1);
DRAWICON(TJ1 AND TJ2,X,1);
DRAWTEXT(TJ1 AND TJ2,X,'早买')COLORRED;
VAR1R:=(HIGH+LOW+CLOSE*2)/4;
VAR2R:=EMA(VAR1R,21);
VAR3R:=STD(VAR1R,21);
VAR4R:=((VAR1R-VAR2R)/VAR3R*100+200)/4;
VAR5R:=(EMA(VAR4R,5)-25)*1.56;
AK:=EMA(VAR5R,2)*1.22;
AD1:=EMA(AK,2);
拐点:=CROSS(AD1,AK);
DRAWTEXT(拐点,X,'变盘');
VAR6R:=((C+2*L)/3-LLV(L,8))/(HHV(H,8)-LLV(L,8))*100;
VAR7R:=SMA(VAR6R,2,1);
DRAWTEXT(X>50 AND X<=80 AND CROSS(X,VAR7R),X,'追'),COLORYELLOW;
DRAWTEXT(CROSS(X,70) AND VAR7R<15,X,'大底'),COLORRED;
DRAWTEXT(CROSS(X,85) AND VAR7R<10,X,'要涨'),COLORMAGENTA;
DRAWTEXT(VAR7R<11 AND VAR7R>REF(VAR7R,1),VAR7R,'要涨'),COLORRED;
DRAWTEXT(CROSS(X,70) AND VAR7R<20,X,'大底'),COLORRED;
DRAWTEXT(ISLASTBAR,X,' 金牛判势'),COLORRED;

 

相关文章