在线检测未来函数

上下电梯(大智慧L2)(飞狐)(通达信)

来源:Internet,编辑:股旁网,2010-05-24

股价高低,买卖进出,上上下下,犹如电梯;其实,只要自己调整好了心态,坚持严守纪律,可能就简单多了!因此,各种软件自带的指标心理线PSY,给了一品更多的思考;通过观察,结合一品超级短线的实战经验,适当修改、细化、润色,以期更好地发挥指标与实战之间的辅助作用。经过几个月的观察与修改,暂时定稿;结合画面,秉承一品指标简便易解原则,名曰【上下电梯】,在此2010新年元旦佳节之际,特将【上下电梯】修改成大智慧L2、飞狐通达信三种软件版本,提供指标源码作为节日礼物,奉送给长期关心、支持一品的朋友们,作个小工具参考。
一品提醒:
1、【上下电梯】指标原理,来源于各软件自带指标心理线PSY,优化后也仅仅是对于超级短线涨跌情况的简单统计,反映市场操作多空的大致心理,并不能确认个股涨跌力度的强弱;
2、无论是个股或者大盘,都存在强者恒强、弱者恒弱的规律,因此,在市场短线多空尚未转向之前的任何提示,都是可能失败的!备钱、低买以及风险等高低提示,都仅仅是提前的预示,不可简单化地作为买卖信号加以操作!即便是【跑】的提示,也仅仅是一种参考,小心庄家强势洗盘后继续大幅拉升
3、永远记住:指标只是参考,决策还需大脑!

{上下趋势指标使用说明:(该指标基础修改于软件自带心理线PSY)
短线上下坐电梯,最爱进场上楼区;
备钱低买关注底,风险见跑下楼去.}

快:COUNT(CLOSE>REF(CLOSE,2),4)/4*100,COLOR00FF00;
慢:COUNT(CLOSE>REF(CLOSE,2),6)/6*100,COLORFFFFFF;
备钱:IF(快=0 AND 慢>20,20,0),COLORFF00FF,LAYER0;
低买:IF(快=0 AND BETWEEN(慢,1,20),50,0),COLORRED,LAYER0;
关注:IF(快=0 AND 慢=0,10,0),COLORFF8800,LAYER0;
JC:=(CROSS(快,1) AND 慢<=40) OR (CROSS(慢,20) AND 快<=50);
进场:IF(FILTER(JC,3),20,0),COLOR00FFFF,LINETHICK0;
VERTLINE(进场,2),COLOR00FFFF;
QSXS:=快>=50 AND 快>=REF(快,1) AND 慢>=REF(慢,1);
上楼:IF(QSXS,1,0),COLOR0000FF,LINETHICK0;
风险:IF(快=100 AND 慢>=80,90,100),COLORFF00FF;
FXSJ:=BARSLAST(风险=90);
快跑:IF(FXSJ=1,1,0),COLORFFFF00,POINTDOT,LINETHICK0;
QSXX:=快<=REF(快,1) AND 慢<=REF(慢,1);
下楼:IF(FXSJ>=2 AND COUNT(QSXX,FXSJ)=FXSJ,1,0),COLOR00FFFF,LINETHICK0;
{以下设置副图显示方式}
FILLRGN(快,慢,上楼,RGB(255,0,0));
FILLRGN(快,慢,下楼,RGB(255,255,0));
DRAWTEXT(CROSS(备钱,1),30,'备钱'),COLORFF00FF;
DRAWTEXT(CROSS(低买,1),60,'低买'),COLORFFFFFF;
DRAWTEXT(CROSS(关注,1),20,'关注'),COLORFFFFFF;
DRAWTEXT(CROSS(COUNT(关注,6)=6,0.8),20,'地下室'),COLOR00FF00;
DRAWTEXT(FXSJ=1,100,'跑'),COLORFFFFFF,ALIGN1;
DRAWICON(风险=90,110,12),ALIGN1,LAYER0;
====================================
{上下电梯----创幻论坛一品茶缘编写副图指标,飞狐版本}
{上下趋势指标使用说明:(该指标基础修改于软件自带心理线PSY)
短线上下坐电梯,最爱进场上楼区;
备钱低买关注底,风险见跑下楼去.}
快:COUNT(CLOSE>REF(CLOSE,2),4)/4*100,COLOR00FF00;
慢:COUNT(CLOSE>REF(CLOSE,2),6)/6*100,COLORFFFFFF;
备钱:IF(快=0 AND 慢>20,20,0),COLORFF00FF;
低买:IF(快=0 AND BETWEEN(慢,1,20),50,0),COLORRED;
关注:IF(快=0 AND 慢=0,10,0),COLORFF8800;
JC:=(CROSS(快,1) AND 慢<=40) OR (CROSS(慢,20) AND 快<=50);
进场:IF(FILTER(JC,3),20,0),COLOR00FFFF,LINETHICK0;
VERTLINE(进场),COLOR00FFFF,LINEDOT;
QSXS:=快>=50 AND 快>=REF(快,1) AND 慢>=REF(慢,1);
上楼:IF(QSXS,1,0),COLOR0000FF,LINETHICK0;
风险:IF(快=100 AND 慢>=80,90,100),COLORFF00FF;
FXSJ:=BARSLAST(风险=90);
快跑:IF(FXSJ=1,1,0),COLORFFFF00,POINTDOT,LINETHICK0;
QSXX:=快<=REF(快,1) AND 慢<=REF(慢,1);
下楼:IF(FXSJ>=2 AND COUNT(QSXX,FXSJ)=FXSJ,1,0),COLOR00FFFF,LINETHICK0;
{以下设置副图显示方式}
FILLRGN(上楼,快,慢),COLORRED;
FILLRGN(下楼,快,慢),COLORYELLOW;
DRAWTEXT(CROSS(备钱,1),30,'备钱'),COLORFF00FF;
DRAWTEXT(CROSS(低买,1),60,'低买'),COLORFFFFFF;
DRAWTEXT(CROSS(关注,1),20,'关注'),COLORFFFFFF;
DRAWTEXT(CROSS(COUNT(关注,6)=6,0.8),20,'地下室'),COLOR00FF00;
DRAWTEXT(FXSJ=1,100,'跑'),COLORFFFFFF,ALIGN1;
DRAWICON(风险=90,110,10),ALIGN1;
=======================================
{上下电梯----创幻论坛一品茶缘编写副图指标,通达信版本}
{上下趋势指标使用说明:(该指标基础修改于软件自带心理线PSY)
短线上下坐电梯,最爱进场上楼区;
备钱低买关注底,风险见跑下楼去.}
快:COUNT(CLOSE>REF(CLOSE,2),4)/4*100,COLOR00FF00;
慢:COUNT(CLOSE>REF(CLOSE,2),6)/6*100,COLORFFFFFF;
备钱:IF(快=0 AND 慢>20,20,0),COLORFF00FF;
低买:IF(快=0 AND BETWEEN(慢,1,20),50,0),COLORRED;
关注:IF(快=0 AND 慢=0,10,0),COLORFF8800;
JC:=(CROSS(快,1) AND 慢<=40) OR (CROSS(慢,20) AND 快<=50);
进场:IF(FILTER(JC,3),20,0),COLOR00FFFF,LINETHICK0;
STICKLINE(进场,0,100,0,-1),COLOR00FFFF;
QSXS:=快>=50 AND 快>=REF(快,1) AND 慢>=REF(慢,1);
上楼:IF(QSXS,1,0),COLOR0000FF,NODRAW;
风险:IF(快=100 AND 慢>=80,90,100),COLORFF00FF;
FXSJ:=BARSLAST(风险=90);
快跑:IF(FXSJ=1,1,0),COLORFFFF00,POINTDOT,NODRAW;
QSXX:=快<=REF(快,1) AND 慢<=REF(慢,1);
下楼:IF(FXSJ>=2 AND COUNT(QSXX,FXSJ)=FXSJ,1,0),COLOR00FFFF,NODRAW;
{以下设置副图显示方式}
A1:=IF(上楼,慢,快);
A2:=IF(下楼,慢,快);
DRAWBAND(快,RGB(255,0,0),A1,RGB(0,255,0));
DRAWBAND(快,RGB(255,255,255),A2,RGB(255,255,0));
DRAWTEXT(CROSS(备钱,1),30,'备钱'),COLORFF00FF;
DRAWTEXT(CROSS(低买,1),60,'低买'),COLORFFFFFF;
DRAWTEXT(CROSS(关注,1),20,'关注'),COLORFFFFFF;
DRAWTEXT(CROSS(LAST(关注,5,1),0.8),20,'地下室'),COLOR00FF00;
DRAWTEXT(FXSJ=1,100,'跑'),COLORFFFFFF;
DRAWICON(风险=90,110,13);
=====================================
{以下设置副图显示方式----通用版本替换彩色带代码}
DRAWICON(风险=90,110,1);
STICKLINE(上楼,快,慢,4,0),COLOR0000FF;
STICKLINE(下楼,快,慢,4,0),COLOR00FFFF;

 

 

 

相关文章