在线检测未来函数

多个买卖点+薛斯通道指标合集(飞狐)

来源:Internet,编辑:股旁网,2010-05-24

都是从网收集来的指标,我放在一起啦,方便看。信号较多,可靠程度自已参照历史分析吧,不同个股的准确度是不一样的,因为主力操作手法不一样的。
股市变幻不定,主力也要跟大势,大家也要跟大势操作,先分析大盘,再分析个股。
安全点操作,就是MA18变绿时操作。
有什么建议可说出控讨一下,以便修改,因为在大智慧中运行太慢,不建议在大智慧中使用。
参数较多,自已看图添加吧。共七个参数。

公式取名:世事如棋
以下源码是一个公式,不要分开,不想输参数把这个放在第一行试下:
input:N1(30,1,100),N2(3,1,100),P1(15,1,100),P2(3,1,100),Long(26,1,100),Short(12,1,100),M(9,1,100),N(5,1,10);

上百人看了,只有一个回贴的,可能大家不喜欢这类公式吧。

更改记录:
11-Feb-2010: 增加了波段趋势的买卖点提示及老砖家K线及买卖点
请同时选中"主图叠加"及"主图"。

==============================================================================
input:N1(30,1,100),N2(3,1,100),P1(15,1,100),P2(3,1,100),Long(26,1,100),Short(12,1,100),M(9,1,100),N(5,1,10);

variable:a1=0;

MA5:MA(C,5),COLORYELLOW;
MA10:=MA(CLOSE,10);
MA18:MA(CLOSE,18),colorgreen;
IF(MA10>MA18,MA10,MA18),COLORRED;

{薛斯通道}
薛斯长顶: MA(HIGH,n1)*(1+p1/100),colorwhite;
薛斯短顶: MA(HIGH,n2)*(1+p2/100),colorFFCCCC;
薛斯短底: MA(LOW,n2)*(1-p2/100),colorff00ff;
薛斯长底: MA(LOW,n1)*(1-p1/100),colorFF9933;

{机构MACD买卖}
{需要参数Long:26,20,100 Short:12,5,40 M:9,2,60}
DIFF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIFF,M);
MACD2:=2*(DIFF-DEA);
DU0:=CROSS(DIFF,0);
UD0:=CROSS(0,DIFF);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:=IF(TDU3<TUD3,REF(HHV(HIGH,2),TDU3),REF(LLV(LOW,2),TUD3));
JDU0:=REF(CLOSE,1)<=REF(UDGLINE,1) AND CLOSE>UDGLINE AND TDU0<TUD0;
JUD0:=REF(CLOSE,1)>=REF(UDGLINE,1) AND CLOSE<UDGLINE AND TUD0<TDU0;
JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
{BSLINE:=IF(BARSLAST(JDU2)<BARSLAST(JUD2),IF(REF(CROSS(0,MACD2),1),LLV(LOW,2),REF(LLV(LOW,2),BARSLAST(REF(CROSS(0,MACD2),1)))),IF(REF(CROSS(MACD2,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD2,0),1)))));}
DEFUT:=BARSLAST(CROSS(MACD2,0));
DEFDT:=BARSLAST(CROSS(0,MACD2));
DEFUL:=IF(MACD2>=0,HHV(MACD2,DEFUT+1),REF(HHV(MACD2,DEFUT+1),DEFDT+1));
DEFDL:=IF(MACD2<0,LLV(MACD2,DEFDT+1),REF(LLV(MACD2,DEFDT+1),DEFUT+1));
DEFU2L:=REF(DEFUL,DEFUT+1);
DEFD2L:=REF(DEFDL,DEFDT+1);
DRAWTEXT(LLV(MACD2,4)>0 AND MACD2<REF(MACD2,1) AND REF(MACD2,1)>REF(MACD2,2) AND REF(MACD2,2)>REF(MACD2,3),HIGH*1.04,'机构卖'),colorgreen;
DRAWTEXT(HHV(MACD2,4)<0 AND MACD2>REF(MACD2,1) AND REF(MACD2,1)<REF(MACD2,2) AND REF(MACD2,2)<REF(MACD2,3),LOW*0.98,'机构买'),color0033CC;
DRAWTEXT((JUD1 OR BARSLAST(JDU1)>BARSLAST(JUD1)) AND MACD2>=0 AND REF(MACD2,1)<REF(DEFU2L,1) AND MACD2>DEFU2L,HIGH*1.04,'关注卖'),colorFFFF33;
DRAWTEXT((JDU1 OR BARSLAST(JDU1)<BARSLAST(JUD1)) AND MACD2<0 AND REF(MACD2,1)>REF(DEFD2L,1) AND MACD2<DEFD2L,LOW*0.98,'关注买'),color66cccc;

{创幻搜牛-主图}
生命线:=WMA(WMA((3*CLOSE+LOW+OPEN+HIGH)/6,18),1);
Var1:=(OPEN+CLOSE+LOW+HIGH)/4;
分水岭:= WMA(3*Var1-2*WMA(Var1,38),18);
Var2:=IF(Var1<分水岭,Var1,分水岭);
Var3:=2*WMA(LLV(Var1,18),18)-Var1;
搜牛:=3*Var3-2*DMA(Var3,10)+0.05*9;
DRAWTEXT(CROSS(生命线,搜牛),LOW*0.84,'牛起'),colorred;
CYC5:=0.01*EMA(AMOUNT,P1)/EMA(VOL,P1);
maxcyc:=dma((c+o)/2,v/capital);
c1:=INTPART(CYC5*100*0.96)/100;
a2:=INTPART(REF(CYC5,1)*100)/100;
a3:=INTPART(REF(CYC5,1)*0.96*100)/100;
vv:=INTPART(MIN(CAPITAL*0.05,REF(MA(VOL,34),1))/100);
a40:=INTPART(maxcyc*100)/100;
a41:=INTPART(REF(MAXCYC,1)*100)/100;
a4:=a1=0 and CLOSE>a2 or (REF(VOL/100,1)<vv and CLOSE>INTPART(a2*0.98*100)/100 and VOL>MIN(CAPITAL*0.05,REF(MA(VOL,34),1)));
a5:=a1=1 and CLOSE<MIN(a3,a41);
a1:=IF(a4=1,1,IF(a5=1,0,REF(a1,1)));
DRAWTEXT(CROSS(a1,0),LOW*0.94,'B'),coloryellow;
DRAWTEXT(CROSS(1,a1),HIGH*1.06,'S'),COLORgreen;
{DRAWFLAGTEXT(a1=0 and (c1*0.98-CLOSE)/CLOSE>0.1,CLOSE,'持币');
DRAWFLAGTEXT(a1=0 and (c1*0.98-CLOSE)/CLOSE<=0.1 and REF(VOL/100,1)<vv,CLOSE,'明日收盘价超过'+str(c1)+';或收盘价超过 '+str(INTPART(c1*0.98*100)/100)+'且成交量大于'+str(vv)+'买入');
DRAWFLAGTEXT(a1=0 and (c1*0.98-CLOSE)/CLOSE<=0.1 and REF(VOL/100,1)>=vv,CLOSE,'明日收盘价超过'+str(c1)+'买入');
DRAWFLAGTEXT(a1=1 and (CLOSE-MIN(c1,a40))/MIN(c1,a40)>0.1 ,CLOSE,'持股');
DRAWFLAGTEXT(a1=1 and (CLOSE-MIN(c1,a40))/MIN(c1,a40)<=0.1 ,CLOSE,'明日收盘价跌破'+str(MIN(c1,a40))+'卖出');
}
{创幻雷达顶点}
RSV1:=(HHV(HIGH,9.8)-CLOSE)/(HHV(HIGH,9.8)-LLV(LOW,9.8))*101;
KK:=SMA(RSV1,3,1);
DD:=SMA(KK,3,1);
JJ:=3*KK-2*DD;
XW1:=IF(JJ>=100,100,IF(JJ<=0,0,JJ));
DRAWTEXT(REF(XW1,1)=0 AND XW1>0,HIGH*1.08,'见顶'),colorgreen;

{操盘铁律-采用低进和逃命和上穿买入和买入和买入时机和卖出和止损价位}
LC:=REF(CLOSE,1);
{DRAWTEXTABS(10,8,'止损价位:'+(LC*1.0035*97+0.2)/99.65),ColorAFFF00;}
滤网:=CLOSE>REF(HIGH,1) and CLOSE>OPEN;
RSI5:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
A:=SMA(R,3,1);
B:=SMA(A,3,1);
CCC:=(B/2+40)*1.1;
D:=SMA(CCC,3,1);
DRAWTEXT(CROSS(80,RSI5),HIGH*1.1,'逃命'),COLORGREEN;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DRAWTEXT(CROSS(cci,-100) and 滤网,LOW*0.92,'上穿买入'),colorwhite;
DRAWTEXT(CROSS(Cci,-150),LOW*0.96,'时机'),COLORred;
C2:=(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84));
DRAWTEXT(CROSS(C2,-70),LOW*0.88,'牛启动'),COLORGREEN;
DRAWTEXT(CROSS(100,cci) and CLOSE<REF(LOW,1),HIGH*1.14,'卖出'),colorgreen;
AA:=REF(cci,14)=HHV(cci,2*14+1);
VAR6:=4*SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1),3,1);
VAR7:=8;
DRAWTEXT(CROSS(VAR6,VAR7),LOW*0.9,'买入信号'),COLORGREEN;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19,LOW*0.86,'低进'),COLORFFFF00;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX(CLOSE - LC,0),4.1,1))/(SMA(ABS(CLOSE - LC),4.1,1)))*(100);
DRAWTEXT(CROSS(RSI,11),LOW*0.84,'底部反转'),COLORGREEN;

Var11:=(close-LLV(low,27))/(HHV(high,27)-LLV(low,27))*100;
Var12:=SMA(Var11,3,1);
Var13:=SMA(Var12,3,1);
Var14:=SMA(Var13,3,1);
箱顶:=MA(REF(HHV(close,30),1),2);
DRAWTEXT(CROSS(Var14,Var13) AND Var14>75 ,箱顶*1.12,'减★仓'),COLORf0f000;

{公称名称: 波段趋势}

BDQS1:=(CLOSE - REF(CLOSE,6));
BDQS2:=(CLOSE - REF(CLOSE,7));
BDQS3:=(CLOSE - REF(CLOSE,8));
BDQS4:=(CLOSE - REF(CLOSE,9));
BDQS5:=(CLOSE - REF(CLOSE,10));
BDQS6:=((((HHV(HIGH,N) - LLV(LOW,N)) / LLV(LOW,N)) * 100) > 8);
DX:=(((((BDQS1 + BDQS2) + BDQS3) + BDQS4) + BDQS5) / 5);
ZX:=MA(DX,5);
CX:=MA(DX,21);
{MA5:MA(CLOSE,5),colorFFFF;
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
MA120:=MA(CLOSE,120);}
BDQS1:=(((CLOSE - LLV(LOW,60)) / (HHV(HIGH,60) - LLV(LOW,60))) * 100);
BDQS2:=SMA(BDQS1,5,1);
BDQS3:=SMA(BDQS2,10,1);
BDQS4:=CROSS(BDQS3,BDQS2);
BDQS5:=((BDQS3 > 80) OR (BDQS2 > 80));
BDQS6:=(BDQS4 AND BDQS5);
BDQS7:=EMA(((AMOUNT / VOL) / 100),3);
BDQS8:=EMA(BDQS7,88);
BDQS9:=(EMA(BDQS7,88) * 0.85);
BDQSA:=(BDQS9 * 0.87);
BDQSB:=((LOW < BDQSA) AND (CLOSE > (REF(CLOSE,1) * 1.02)));
DRAWTEXT(FILTER(BDQSB,6),(LOW *0.82),'★买'),color6600FF;
DRAWTEXT(FILTER(CROSS(69,((SMA(MAX((CLOSE - REF(CLOSE,1)),0),8,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),8,1)) * 100)),10),(HIGH * 1.16),'★卖 '),colorFFFF00;
DRAWTEXT(FILTER(CROSS((0 - 5),MA((((LLV(LOW,45) - CLOSE) / (HHV(HIGH,45) - LLV(LOW,45))) * 100),5)),5),(LOW *0.82),'★买'),colorFFFF;

{}
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
LZJ1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
LZJ2:=(REF(LZJ1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
LZJ3:=(REF(LZJ2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
LZJ4:=(REF(LZJ3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
LZJ5:=(REF(LZJ4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
LZJ6:=(REF(LZJ5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
LZJ7:=(REF(LZJ6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
LZJ8:=(REF(LZJ7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
LZJ9:=(REF(LZJ8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
LZJA:=(REF(LZJ9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
LZJB:=(REF(LZJA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
LZJC:=(REF(LZJB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
LZJD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
LZJE:=(REF(LZJD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
LZJF:=(REF(LZJE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
LZJ10:=(REF(LZJF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
LZJ11:=(REF(LZJ10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
LZJ12:=(REF(LZJ11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
LZJ13:=(REF(LZJ12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
LZJ14:=(REF(LZJ13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
LZJ15:=(REF(LZJ14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
LZJ16:=(REF(LZJ15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
LZJ17:=(REF(LZJ16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
LZJ18:=(REF(LZJ17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
LZJ19:=((REF(LZJD OR LZJE OR LZJF OR LZJ10 OR LZJ11 OR LZJ12 OR LZJ13 OR LZJ14 OR LZJ15 OR LZJ16 OR LZJ17 OR LZJ18,1)) AND LZJ1);
LZJ1A:=((REF(LZJ1 OR LZJ2 OR LZJ3 OR LZJ4 OR LZJ5 OR LZJ6 OR LZJ7 OR LZJ8 OR LZJ9 OR LZJA OR LZJB OR LZJC,1)) AND LZJD);
红色持股:=IF((LZJ1 OR LZJ2 OR LZJ3 OR LZJ4 OR LZJ5 OR LZJ6 OR LZJ7 OR LZJ8 OR LZJ9 OR LZJA OR LZJB OR LZJC),1,0);
离场:=IF(红色持股,JRL,0);
{明离场价:=离场;
今离场价:REF(离场,1),COLOR0000FF,LINETHICK0; }
青色观望:=IF((LZJD OR LZJE OR LZJF OR LZJ10 OR LZJ11 OR LZJ12 OR LZJ13 OR LZJ14 OR LZJ15 OR LZJ16 OR LZJ17 OR LZJ18),1,0);
{进:=IF(青色观望,JRH,0);
明进场价:=进;}
今进场价:REF(IF(青色观望,JRH,0),1),COLOR00FF00,LINETHICK0;
{短买:=LZJ19;
品红离场:=LZJ1A; }
红进绿出:=MA((C+H+L)/3,4);
{partline(红进绿出>=ref(红进绿出,1),红进绿出),colorff0000,linethick2;
partline(红进绿出<ref(红进绿出,1),红进绿出),color00ff00,linethick2;}
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,8,0),COLOR858500;
STICKLINE(C>=O,C,O,8,0),COLOR0000E5;
STICKLINE(红色持股,CLOSE,O,6,0),COLOR000055;
STICKLINE(红色持股,CLOSE,O,5,0),COLOR000088;
STICKLINE(红色持股,CLOSE,O,4,0),COLOR0000AA;
STICKLINE(红色持股,CLOSE,O,3,0),COLOR0000CC;
STICKLINE(红色持股,CLOSE,O,2,0),COLOR0000EE;
STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000FF;
STICKLINE(青色观望,CLOSE,O,6,0),COLOR555500;
STICKLINE(青色观望,CLOSE,O,5,0),COLOR888800;
STICKLINE(青色观望,CLOSE,O,4,0),COLORAAAA00;
STICKLINE(青色观望,CLOSE,O,3,0),COLORCCCC00;
STICKLINE(青色观望,CLOSE,O,2,0),COLOREEEE00;
STICKLINE(青色观望,CLOSE,O,1,0),COLORFFFF00;
CO:=(C-O);
STICKLINE(LZJ19,O,O+CO/3,6,0),COLOR335555;
STICKLINE(LZJ19,O,O+CO/3,5,0),COLOR338888;
STICKLINE(LZJ19,O,O+CO/3,4,0),COLOR33AAAA;
STICKLINE(LZJ19,O,O+CO/3,3,0),COLOR33CCCC;
STICKLINE(LZJ19,O,O+CO/3,2,0),COLOR33EEEE;
STICKLINE(LZJ19,O,O+CO/3,1,0),COLOR33FFFF;
STICKLINE(LZJ1A,O,O+CO/3,6,0),COLOR550055;
STICKLINE(LZJ1A,O,O+CO/3,5,0),COLOR880088;
STICKLINE(LZJ1A,O,O+CO/3,4,0),COLORAA00AA;
STICKLINE(LZJ1A,O,O+CO/3,3,0),COLORCC00CC;
STICKLINE(LZJ1A,O,O+CO/3,2,0),COLOREE00EE;
STICKLINE(LZJ1A,O,O+CO/3,1,0),COLORFF00FF;
{DRAWTEXT(LZJ19,LLV(L,3),'←买'),COLOR00FFFF;
DRAWTEXT(LZJ1A,HHV(H,3),'←卖'),COLOR00FFFF;}
DRAWTEXTEX(CLOSE,1,1,10,'★K线操作:红持股,青持币,黄色买入,品红离场★\n保持良好的心态,戒骄戒躁,耐心等待 '),colorFFFF;===================================================================



 

相关文章