在线检测未来函数

大智慧精准的顶底指标公式

来源:Internet,编辑:股旁网,2010-05-24

使用方法:
该指标通过统计一段时期行情走势的高低起伏,从而寻找出股票的涨跌规律,并判断出股票的相对高低位置而研制成的提示抄底逃顶的绝佳工具。
1、绿柱表示短期探底信号
2、红柱表探底成功信号
3、粉色表底部吸筹信号
3、逃顶看顶峰线,如果趋势线接近顶峰线95出现变色, 说明局部顶已到应注意逢高减磅。
4、在高位出现变色的同时,趋势线下穿操盘线时卖出是最好的卖出时机!
5、对于箱体运作的股票可根据趋势线的低位与操盘线金叉买入。。通过死叉卖出
操作要点:出现红柱探底成功信号时,一定要观察趋势线的走向及位置,个股没有真正的顶和底,因为他们可以连续创新高新底,所谓顶底,都只是一个周期内相对应的位置。

DRAWTEXTABS(30,0,'个股顶底');
短趋势:MA(3*SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,5,1)-2*SMA(SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,5,1),3,1),3),coloryellow,LINETHICK2;
Var2:=(2*CLOSE+HIGH+LOW+OPEN)/5;
Var3:=LLV(LOW,34);
Var4:=HHV(HIGH,34);
长趋势:MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5),colorred,LINETHICK2;
判断底:=SQRT(SQRT(FLOOR(SQRT(MA(1/WINNER(CLOSE)*100,4)/10000))))*5;
Var5:=CROSS(短趋势,长趋势)AND 长趋势<25;
STICKLINE(短趋势<10 AND 判断底>0,0,30,6,0),colorgreen;
STICKLINE(Var5,0,50,8,0),colorred;
看底:8,coloryellow;
顶峰:100,colorgreen;
趋势:=3*SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1),3,1);
操盘线:=SMA(趋势,3,1);
DRAWLINE( 趋势>=90,顶峰,趋势<90,顶峰 ,0 ),colorred;
STICKLINE(CROSS(看底,趋势),0 ,30 ,6 ,0 ),colorgreen;
a:=短趋势<10 AND 判断底>0;
a1:=Var5;
a2:=CROSS(看底,趋势);
a3:=CROSS(趋势,看底 );
a4:=a+a1+a2+a3;
Var6:=EMA(HHV(HIGH,500),21);
Var7:=EMA(HHV(HIGH,250),21);
Var8:=EMA(HHV(HIGH,90),21);
Var9:=EMA(LLV(LOW,500),21);
VarA:=EMA(LLV(LOW,250),21);
VarB:=EMA(LLV(LOW,90),21);
VarC:=EMA((Var9*0.96+VarA*0.96+VarB*0.96+Var6*0.558+Var7*0.558+Var8*0.558)/6,21);
VarD:=EMA((Var9*1.25+VarA*1.23+VarB*1.2+Var6*0.55+Var7*0.55+Var8*0.65)/6,21);
VarE:=EMA((Var9*1.3+VarA*1.3+VarB*1.3+Var6*0.68+Var7*0.68+Var8*0.68)/6,21);
VarF:=EMA((VarC*3+VarD*2+VarE)/6*1.738,21);
Var10:=REF(LOW,1);
Var11:=SMA(ABS(LOW-Var10),3,1)/SMA(MAX(LOW-Var10,0),3,1)*100;
Var12:=EMA(IF(CLOSE*1.35<=VarF,Var11*10,Var11/10),3);
Var13:=LLV(LOW,30);
Var14:=HHV(Var12,30);
Var15:=IF(MA(CLOSE,58),1,0);
Var16:=EMA(IF(LOW<=Var13,(Var12+Var14*2)/2,0),3)/618*Var15;
Var17:=IF(Var16>50,50,Var16)/3.82*6;
STICKLINE(Var17>0,0,var17/2,6,0),colorf00ff0 ;

 

相关文章