在线检测未来函数

通达信合并趋势顶底公式

来源:Internet,编辑:股旁网,2010-06-01

趋势顶底指标合并了另外两个指标。
一个是“超跌”指标(绿柱体,注意此指标只表示超跌。);
另一个是“趋势”指标(最下面的红绿点,红点持股,绿点持币);

VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=VAR11-CLOSE;
VAR13:=REF(CLOSE,1);
VAR14:=SMA(MAX(CLOSE-VAR13,0),7,1)/SMA(ABS(CLOSE-VAR13),7,1)*100;
VAR15:=SMA(MAX(CLOSE-VAR13,0),13,1)/SMA(ABS(CLOSE-VAR13),13,1)*100;
VAR16:=BARSCOUNT(CLOSE);
VAR17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1A:=(SMA(VAR19,4,1)-50)*2;
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=IF(VAR17<=25 AND VAR18<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR12>=-0.25 AND VAR14<22 AND VAR15<28 AND VAR16>50,100,0),LINETHICK3,COLORYELLOW ;
极限反击:= VAR20;
STICKLINE (极限反击>0,1,89,1.3,0),COLORGREEN;
STICKLINE (极限反击>0,3,87,0.00001,0),COLORBLACK;
W:80,COLOR996699;
S:20,COLORGREEN;
Y:10,COLORCC6633,LINETHICK2;
T:90,COLOR9966FF,LINETHICK2;
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2;
长期线:A+100,COLOR9900FF;
短期线:B+100,COLOR888888;
中期线:D+100,COLORYELLOW,LINETHICK2;
见顶:(REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线) ;
顶区:(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5
AND 短期线<中期线 AND 短期线<长期线+4,COLORRED;
顶部:FILTER(顶区,4);
底区:(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1)))
OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1),COLORYELLOW ;
STICKLINE(顶部,99,103,4,1 ),COLORRED,LINETHICK2;
STICKLINE( 底区,-4,0,4,0 ),COLORGREEN;
低位金叉:=长期线<15 AND REF(长期线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,长期线) AND 短期线>中期线
AND (REF(短期线,1)<5 OR REF(短期线,2)<5 ) AND (中期线>=长期线 OR REF( 短期线,1)<1 );
STICKLINE( 低位金叉,0,5,4,0 ),COLORRED;
DRAWICON (CROSS(长期线,中期线) ,0,2);
DRAWICON(CROSS(中期线,长期线),0,1);
STICKLINE( 见顶,99.5,102.5,3,0 ),COLORGREEN;
STICKLINE( 见顶,100.5,101.5,1.5,0 ),COLORRED;
VAR111:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR222:=EMA(VAR111,30);
VAR333:=EMA(VAR222,30);
VAR444:=3*VAR222-2*VAR333;
势:=EMA(VAR444,5),COLORBLUE,LINETHICK3;
持币:IF(势<REF(势,1),-5,DRAWNULL),CIRCLEDOT,COLORGREEN;
持股:IF(势>REF(势,1),-5,DRAWNULL),CIRCLEDOT,COLOR000099;

通达信合并趋势顶底公式
通达信合并趋势顶底公式
通达信合并趋势顶底公式

 

相关文章