在线检测未来函数

通达信抄底逃顶多空分界指标公式

来源:Internet,编辑:股旁网,2010-06-07

空方防守价:=EMA(HIGH,4);
多方防守价:=EMA(LOW,5);
B1:=IF(CROSS(CLOSE,空方防守价),1,IF(CROSS(多方防守价,CLOSE),-1,0));
B2:=REF(B1,BARSLAST(B1));
B3:=IF(B2=1,多方防守价,IF(B2=-1,空方防守价,0));
分界点:B3,NODRAW,COLORFF00FF;
MA1:=B3;
C1:=(ABS(CLOSE-MA1))/CLOSE;
J:=(HHV(C1,160)+LLV(C1,160))/1.7;
CC:=IF(C1<=J-J/2,1,IF(C1<=J-J/3 AND C1>J-J/2,2,IF(C1<=J+J/3 AND C1>J-J/3,3,IF(C1<=2*J AND C1>J+J/3,4,IF(C1>2*J,5,0)))));
STICKLINE(CLOSE>MA1,0,CC,3,0),COLORFFFFFF;
STICKLINE(CLOSE>MA1,0,CC,2,0),COLOR0000FF;
STICKLINE(CLOSE>MA1 AND CC>3,3,CC,3,0),COLORFFFF00;
STICKLINE(CLOSE<MA1,0,-CC,3,0),COLORFFFFFF;
STICKLINE(CLOSE<MA1,0,-CC,2,0),COLORFF3333;
STICKLINE(CLOSE<MA1 AND CC>3,-3,-CC,3,0),COLORFF00FF;
DRAWTEXT(CLOSE>=MA1 AND ISLASTBAR=1,1,'←多↑'),COLOR0000FF;
DRAWTEXT(CLOSE<MA1 AND ISLASTBAR=1,-1,'←空↓'),COLOR00FF00;
{PARTLINE(1,0);}
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR8:=LLV(LOW,34);
VARB:=HHV(HIGH,34);
BB:=EMA((VAR6-VAR8)/(VARB-VAR8)*100,9);
趋势:EMA(0.667*REF(BB,1)+0.333*BB,2),NODRAW,COLORFFFF00;
Q:=(2*CLOSE+HIGH+LOW)/4;
A1:=LLV(LOW,24);
A2:=HHV(HIGH,24);
A:=EMA((Q-A1)/(A2-A1)*100,13);
B:=EMA(0.667*REF(A,1)+0.333*A,3);
力道:A-B,NODRAW,COLOR00FFFF;

通达信抄底逃顶多空分界指标公式

 

相关文章