在线检测未来函数

通达信MACD四线趋势指标公式

来源:Internet,编辑:股旁网,2010-06-08

DIFF:EMA(CLOSE,30)-EMA(CLOSE,60);
DEA:EMA(DIFF,15);
MACD:=3*(DIFF-DEA);
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,1,0),COLORYELLOW;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0),COLORRED;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0),COLORFFC8FF;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0),COLORFFCC66;
DIF:EMA(CLOSE,9)-EMA(CLOSE,18),LINETHICK2;
DEA1:EMA(DIF,7),LINETHICK2;
下穿:=COUNT(DEA<=0,5)=1 AND DEA<=0;
上穿:=COUNT(DEA>=0,5)=1 AND DEA>=0;
DRAWTEXT(下穿,LOW*0.1,'↓'),COLORYELLOW;
DRAWTEXT(上穿,LOW*0.1,'↑'),COLOR0000FF;
日线空头:IF(DEA<0,1,0);

通达信MACD四线趋势指标公式

 

相关文章