在线检测未来函数

通达信华丽DMI指标公式

来源:Internet,编辑:股旁网,2010-07-07

说明:
1美化后的DMI指标副图分别由PDI,MDI和ADX,ADXR两组彩带组成。
2其中粉红、黄彩带表示股价走势的趋向。
3通常情况下,当 粉红彩带上升到关注线(50)以上变成黄带,表示股价将变盘。
4由PDI, MDI组成的彩带变红是买入信号,变绿时是卖出信号。
5具体情况参考有关DMI指标操作资料进行操盘。

{参数: N 2 90 14 M 2 60 6}

TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/TR;
MDI: DMM*100/TR;
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
{股旁网-股票公式网站 www.gupang.com}
ADXR:EXPMEMA(ADX,M),COLOR00FF00,LINETHICK2;
DRAWBAND(PDI,RGB(240,0,0),MDI,RGB(0,120,0));
DRAWBAND(ADX,RGB(220,0,130),ADXR,RGB(240,240,0));
关注线:50,COLORF0F000,POINTDOT;

通达信华丽DMI指标公式

 

相关文章