在线检测未来函数

大智慧精确涨停指标公式

来源:Internet,编辑:股旁网,2010-07-08

input:WS(0,0,9);{//WS是N的尾数,WS=0,尾数,0~9之间整数,可调节参数}
RSV:=(C-LLV(L,15))/(HHV(H,15)-LLV(L,15))*100;
K:=(SMA(RSV,10,1));
D:=(SMA(K,5,1));
KK:=INTPART(SMA(RSV,10,1));
DD:=INTPART((SMA(K,5,1)));
N:KK+DD,LINETHICK1,COLORGREEN;
A:KK-DD,LINETHICK1,COLORWHITE;
A1:REF(KK-DD,1),LINETHICK1,COLORCYAN;
A2:=REF(KK-DD,2);
STICKLINE(N<25,-25,-15,10,0),align0,linethick3,COLORYELLOW;
{表格竖线}
x:=DISPSTATUS=2=BARPOS;
k:=(DISPSTATUS=3)-(DISPSTATUS=2)/110;
x1:=(DISPSTATUS=2)+INTPART(12*k)=BARPOS;
x2:=(DISPSTATUS=2)+INTPART(28*k)=BARPOS;
x3:=(DISPSTATUS=2)+INTPART(46*k)=BARPOS;
x4:=(DISPSTATUS=2)+INTPART(62*k)=BARPOS;
x5:=(DISPSTATUS=2)+INTPART(80*k)=BARPOS;
x6:=(DISPSTATUS=2)+INTPART(103*k)=BARPOS;
VERTLINE(x or x1 or x2 or x3 or x4 or x5 or x6,1 ),colorgray;
{表格横线}
DRAWLINE(x,-20,x6,-20,0),colorgray;
DRAWLINE(x,14,x6,14,0),colorgray;
DRAWLINE(x,49,x6,49,0),colorgray;
DRAWLINE(x,83,x6,83,0),colorgray;
DRAWLINE(x,120,x6,120,0),colorgray;
{卖点}
卖:=7*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*30,4,1)
-3*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*30,4,1),3,1)
-sma(SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*30,4,1),3,1),2,1);
{-----------------【图解模板】---------------------}
尾数:MOD(n,10),LINETHICK1,COLORWHITE;
N的尾数:IF(尾数=WS,0,1),LINETHICK1,COLORWHITE;
{信号}
STICKLINE(尾数=WS,38,-20,5,0),COLORGRAY;
drawicon(N<15,-20,1),ALIGN0;
{drawicon(A1=0,-20,10),ALIGN0;
drawicon((A>8 and A1>=0 and A2<0),-20,6),ALIGN0;
drawicon(A>8 and A1<-8,-20,4),ALIGN0;
{填表} {我的电脑上表格没有显示,先这么用吧,楼主注释 }
xx1:=ref(N,3); xx2:=ref(N,2); xx3:=ref(N,1); xx4:=N;
DRAWTEXT(x,108,' (N值) '),COLORGREEN;{//------------------}
DRAWTEXT(x1,108,' 前三天 = '+NUMTOSTR(xx1)),COLORGREEN;
DRAWTEXT(x2,108,' 前二天 = '+NUMTOSTR(xx2)),COLORGREEN;
DRAWTEXT(x3,108,' 前一天 = '+NUMTOSTR(xx3)),COLORGREEN;
DRAWTEXT(x4,108,' 当 天 = '+NUMTOSTR(xx4)),COLORGREEN;
{股旁网-股票公式网站 www.gupang.com}
DRAWTEXT(x5,108,' N值小于25时,要格外注意'),COLORGREEN;
yy1:=ref(A1,3); yy2:=ref(A1,2); yy3:=ref(A1,1); yy4:=A1;
DRAWTEXT(x,71,' (A1值) '),COLORCYAN;{//------------------}
DRAWTEXT(x1,71,' 前三天 = '+NUMTOSTR(yy1)),COLORCYAN;
DRAWTEXT(x2,71,' 前二天 = '+NUMTOSTR(yy2)),COLORCYAN;
DRAWTEXT(x3,71,' 前一天 = '+NUMTOSTR(yy3)),COLORCYAN;
DRAWTEXT(x4,71,' 前一天 = '+NUMTOSTR(yy4)),COLORCYAN;
DRAWTEXT(x5,71,' A1=0 时,很容易大涨'),COLORCYAN;
ZZ1:=ref(kk,3); ZZ2:=ref(kk,2); ZZ3:=ref(kk,1); ZZ4:=kk;
DRAWTEXT(x,38,' (KK值) '),ColorE9A6E9;{//-----------------}
DRAWTEXT(x1,38,' 前三天 = '+NUMTOSTR(ZZ1)),ColorE9A6E9;
DRAWTEXT(x2,38,' 前二天 = '+NUMTOSTR(ZZ2)),ColorE9A6E9;
DRAWTEXT(x3,38,' 前一天 = '+NUMTOSTR(ZZ3)),ColorE9A6E9;
DRAWTEXT(x4,38,' 当 天 = '+NUMTOSTR(ZZ4)),ColorE9A6E9;
DRAWTEXT(x5,38,' KK值一天比一天大为正转'),ColorE9A6E9;
WW1:=ref(DD,3); WW2:=ref(DD,2); WW3:=ref(DD,1); WW4:=DD;
DRAWTEXT(x,2,' (DD值) '),COLORYELLOW;{//------------------}
DRAWTEXT(x1,2,' 前三天 = '+NUMTOSTR(WW1)),COLORYELLOW;
DRAWTEXT(x2,2,' 前二天 = '+NUMTOSTR(WW2)),COLORYELLOW;
DRAWTEXT(x3,2,' 前一天 = '+NUMTOSTR(WW3)),COLORYELLOW;
DRAWTEXT(x4,2,' 当 天 = '+NUMTOSTR(WW4)),COLORYELLOW;
DRAWTEXT(x5,2,' DD值一天比一天大为正转'),COLORYELLOW;
DRAWTEXT(x6,120,' \n \n \n \n \n \n 大盘走牛时,\n N的尾数相同,\n 不小心 \n 就会让你 \n 骑上一匹黑马'),COLORWHITE;
DRAWTEXT(cross(78.89,卖),120,' ★ \n▽'),ALIGN0,ColorFF9000;

大智慧精确涨停指标公式

 

相关文章