在线检测未来函数

通达信同登彼岸指标公式

来源:Internet,编辑:股旁网,2010-07-21

本文指标含有选股公式如下:

http://www.gupang.com/202003/50782.html

{参数:
N 2 100 9
M1 2 100 3
M2 2 100 3
}
大盘涨股:INDEXADV,NODRAW,COLOR0000FF;
大盘跌股:INDEXDEC,NODRAW,COLOR00FF00;
个股成交量:VOL,NODRAW;
个股虚拟量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
RSV1:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K1:=SMA(RSV1,M1,1);
D1:=SMA(K1,M2,1);
MAJ1:=3*K1-2*D1;
RSV2:=(INDEXC-LLV(INDEXL,N))/(HHV(INDEXH,N)-LLV(INDEXL,N))*100;
K2:=SMA(RSV2,M1,1);
D2:=SMA(K2,M2,1);
MAJ2:=3*K2-2*D2;
TM:=(MAJ1-MAJ2);
LB:=VOL*1200/(FROMOPEN*REF(SUM(VOL,5),1));
STICKLINE(MAJ1>REF(MAJ1,1) AND TM>=0 ,0,TM,3,0),COLOR0000CC;
STICKLINE(MAJ1>REF(MAJ1,1) AND TM<=0 ,0,TM,3,2),COLOR0000CC;
STICKLINE(MAJ1<REF(MAJ1,1) AND TM>=0 ,0,TM,3,0),COLORFF0000;
STICKLINE(MAJ1<REF(MAJ1,1) AND TM<=0 ,0,TM,3,2),COLORFF0000;
TJ1:=(MAJ1>REF(MAJ1,1) AND TM<=0) AND COUNT((MAJ1-REF(MAJ1,1))/REF(MAJ1,1)*100<=1,3)<=2 AND MAJ2>=REF(MAJ2,1);
STICKLINE(CROSS(TJ1,0.5) AND LB>=REF(LB,1),0,TM,2,0),COLORFFFFFF;
TJ2:=MAJ1>REF(MAJ1,1) AND MAJ2>REF(MAJ2,1) AND TM>=REF(TM,1) AND REF(TM,1)<REF(TM,2) ;
{股旁网-股票公式网站 www.gupang.com}
STICKLINE((CROSS(TJ2,0.5) OR CROSS(MAJ1,MAJ2)) AND LB>=REF(LB,1) AND MAJ1<=80,0,TM,2,0),COLOR00FFFF;
TJ3:=EXIST(CROSS(MAJ1,0),2) AND MAJ2>REF(MAJ2,1);
DRAWICON(TJ3,0,1);
TJ4:=MAJ1<REF(MAJ1,1) AND MAJ1>=80 AND COUNT(MAJ1>REF(MAJ1,1),3)<=2;
STICKLINE(CROSS(TJ4,0.5) ,0,TM,2,0),COLOR00FF00;
大盘J线:MAJ2,LINETHICK2,COLORFFFFFF;
个股J线:MAJ1,LINETHICK2,COLOR00FFFF;

通达信同登彼岸指标公式

 

相关文章