在线检测未来函数

大智慧KDJ+MACD顶底信号指标公式

来源:Internet,编辑:股旁网,2010-07-22

UPPERL:= MA(HIGH,30)*(1+15/100);
UPPERS:= MA(HIGH,3)*(1+3/100);
LOWERS:= MA(LOW,3)*(1-3/100);
LOWERL:= MA(LOW,30)*(1-15/100);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),colorwhite;
D:SMA(K,3,1),coloryellow;
J:3*K-2*D,colorff00ff;
{KDJ抄底信号}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
KDJ抄底:REF(J,1)<0 AND J>0 and 50{,LINETHICK3},COLORRED;
{MACD抄底信号}
DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
MACD抄底:cross( MACD>REF(MACD,1) AND MACD<0,0.5) and count(MACD<REF(MACD,1),6)>=5;
KDJ买入信号: IF((KDJ抄底),80,0),stick3d,linethick2,COLORRED;
MACD买入信号: IF((MACD抄底),80,0),{stick3d,}linethick2,COLORYELLOW;
{顶底信号}
股价趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),linethick0;
买入警戒: IF(股价趋势<=10,45,0),stick,linethick3,COLORWHITE;
顶部警戒: 90, colorred;
卖出信号: IF(CROSS(股价趋势,顶部警戒),100,0),stick3d,linethick3,colorgreen;
底部:if(LOWERS<LOWERL,25,0),stick,linethick3,COLORFF0BFF;{底粉红柱}
aa:=if(UPPERS>UPPERL,60,100);{底粉红柱}
顶部:if(aa=60,100,0),stick,linethick3,color00ff00;{顶绿柱}
if(aa=60,90,0),stick,linethick3,color000000;{顶绿柱}
100,color00ff00;
50;
0,colorffff00;
rsv1:=100*(close-llv(low,27))/(hhv(high,27)-llv(low,27));
k1:=ref(ma(rsv1,3),1)+(rsv1-ref(ma(rsv1,3),1))/3;
d1:=ref(ma(k1,3),1)+(k1-ref(ma(k1,3),1))/3;
J1:=3*K1-2*D1;
AA1:=EMA(J1,5);
AA2:=REF(AA1,1);
J27:AA1,colorred,linethick0;
{股旁网-股票公式网站 www.gupang.com}
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
k2:=ref(ma(rsv2,3),1)+(rsv2-ref(ma(rsv2,3),1))/3;
d2:=ref(ma(k2,3),1)+(k2-ref(ma(k2,3),1))/3;
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
J9:BB1,linethick0;
DD:=AA1>AA2 AND BB1>BB2;
注意买入:DD AND NOT(REF(DD,1)) AND (AA1<50 OR BB1<50) ,LINETHICK0,PRECIS0,colorred;
DRAWICON(注意买入,35,1),ALIGN0;
注意卖出:REF(DD,1)=1 AND NOT(DD),LINETHICK0,PRECIS0,colorgreen;
DRAWtext(注意卖出,105,'S'),ALIGN1,COLORGREEN,LINETHICK6;
DRAWICON(注意卖出,115,2),ALIGN1;{哭脸};

大智慧KDJ+MACD顶底信号指标公式

 

相关文章