在线检测未来函数

大智慧无敌量能指标公式

来源:Internet,编辑:股旁网,2010-07-31

input:n1(8),n2(3),n3(24);
VAR1:=VOL/((HIGH-LOW)*2-(ABS(CLOSE-OPEN)));
成交:=VOL;
买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*(HIGH-OPEN+CLOSE-LOW),VOL/2));
卖盘:=IF(CLOSE>OPEN,-VAR1*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,-VAR1*(HIGH-LOW),-VOL/2));
买卖差:=买盘+卖盘;
A:=买卖差/2;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
量能趋势:EMA(X,N1),LINETHICK2,color66FFFF;
{股旁网-股票公式网站 www.gupang.com}
PARTLINE(MA(量能趋势,N2)>量能趋势,量能趋势),LINETHICK2;
PARTLINE(MA(量能趋势,N2)<量能趋势,量能趋势),LINETHICK2;
量能涨速:SLOPE(X,N3)/X;
J:="KDJ.J";
K:="KDJ.K";
DIFF:="MACD.DIFF";
DEA:="MACD.DEA";
KDJ金叉:=J<45 AND CROSS(J,K);
MACD金叉:=CROSS(DIFF,DEA);
低位:=J<16 AND DEA<-0.45;
金叉:=MACD金叉>0 OR KDJ金叉>0;
买入:(低位>0 OR 金叉>0) AND 量能趋势>REF(量能趋势,4);
DRAWICON(FILTER(买入,24),量能趋势,1);

大智慧无敌量能指标公式

 

相关文章