在线检测未来函数

大智慧自用vol指标公式

来源:Internet,编辑:股旁网,2010-08-11

input:N(3,1,100),N1(7,1,100),P(1,1,100),N3(6,1,100);
xClose:=EMA((Open+High+Low+Close)/4,n) ;
xOpen:=EMA((Ref(Open,1) + Ref(xClose,1))/2,n);
Tempg:=Max(High, xOpen);
xHigh:=EMA(Max(Tempg, xClose),n);
Temp:=Min(Low,XOpen);
xLow:=EMA(Min(Temp, xClose),n);
o1:=If(xOpen<xclose, xopen, xclose);
c1:=If(xOpen<xclose, xclose, xopen);
stickline(xOpen>=xClose,xHigh,xLow,1,1),colorred;
stickline(xOpen>=xClose,c1,o1,6,1),colorred;
stickline(xOpen<xClose,xHigh,xLow,1,1),colorgreen;
stickline(xOpen<xClose,c1,o1,6,1),colorgreen;
x1:=Ref(C,1);
x2:=WMA(Max(C-x1,0),N)/WMA(abs(C-x1),N1)*100;
x3:=((3*WMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5)-
2*WMA(WMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5),3)-50)+50);
x4:=(x2+x3)/2;
x5:=WMA(C+(x4/50-1)*(MA(C,30)/20)*p,3);
{股旁网-股票公式网站 www.gupang.com}
yellow:x5,coloryellow,linethick2;
n2c:=2*n3;
n3c:=2*n2c;
Var1:=Ref(Close,1);
Var3:=WMA(Max(Close-Var1,0),n3)/WMA(abs(Close-Var1),n3)*100;
Var4:=WMA(Max(Close-Var1,0),n2c)/WMA(abs(Close-Var1),n2c)*100;
Var5:=WMA(Max(Close-Var1,0),n3c)/WMA(abs(Close-Var1),n3c)*100;
Var6:=If(Cross(Var3,Var5),Low,Ref(Low,BarsSince(Cross(Var3,Var5))));
Var7:=If(Cross(Var5,Var3),High,Ref(High,BarsSince(Cross(Var5,Var3))));
Var8:=If(Close>=MA(Close,20),80,50);
Var9:=If(Close>=MA(Close,20),50,20);
VarA:=If(Var3<Var8 AND Ref(Var3,1)>=Var8,HHV(Ref(High,1),BARSLAST(Var3>=Var8 AND Ref(Var3,1)<Var8)-1),
Ref(HHV(Ref(High,1),BARSLAST(Var3>=Var8 AND Ref(Var3,1)<Var8)+1), BARSLAST(Var3<Var8 AND Ref(Var3,1))));
VarB:=If(High>VarA,Low,Ref(Low,BARSLAST(High>VarA)));
VarC:=If(High>VarA,Var3,Ref(Var3,BARSLAST(High>VarA)));
VarD:=If(High>VarB AND Var3<VarC AND Var3<Var5,High,Ref(High,BARSLAST(High>VarB AND Var3<VarC AND Var3<Var5)));
VarE:=If(Var3>Var9 AND Ref(Var3,1)<=Var9,LLV(Ref(Low,1),BARSLAST(Var3<=Var9 AND Ref(Var3,1)>Var9)+1),
Ref(LLV(Ref(Low,1),BARSLAST(Var3<=Var9 AND Ref(Var3,1)>Var9)+1),BARSLAST(Var3>Var9 AND Ref(Var3,1))));
VarF:=If(Low<VarE,High,Ref(High,BARSLAST(Low<VarE)));
Var10:=If(Low<VarE,Var3,Ref(Var3,BARSLAST(Low<VarE)));
Var11:=If(Low<VarF AND Var3>Var10 AND Var3>Var5,Low,Ref(Low,BARSLAST(Low<VarF AND Var3>Var10 AND Var3>Var5)));
PRES: Var11,COLORGRAY;
SUP: VarD,colorB958E2;
drawtext(Cross(x5,pres ),xlow,'●'),colorblue,align0;
drawtext(Cross(sup,x5 ),xhigh,'●'),COLORMAGENTA,align0;
drawtext(Cross(x5,pres ),xlow,'8'),colorwhite,align0;
drawtext(Cross(sup,x5 ),xhigh,'8'),COLORwhite,align0;

大智慧自用vol指标公式

 

相关文章