在线检测未来函数

通达信实战很强的MACD指标公式

来源:Internet,编辑:股旁网,2010-08-16

{参数:
SHORT:1/500/12
LONG:1/500/26
M:1/500/9
}
DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG),LINETHICK0;
DEA : EMA(DIFF,M),LINETHICK0;
DRAWBAND(DIFF,RGB(155,50,50),DEA,RGB(0,100,50));
力:2*(DIFF-DEA),NODRAW;
MACD : 2*(DIFF-DEA), COLORSTICK,LINETHICK2;
DD:=C=HHV(C,180);
EE:=DEA< REF(DEA,1) AND REF(DEA< REF(DEA,1),1)=1;
CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;
DRAWICON(CC AND EE,0.1,11);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:=IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),1.2,DRAWNULL),COLORRED,LINETHICK4,CROSSDOT;
势:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED LINETHICK2;
DRAWICON(DD AND EE AND DEA< HHV(DEA,180),0.1,2);
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),COLORWHITE;
压:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN LINETHICK2;
FF:=C=LLV(C,180);
GG:= DEA> REF(DEA,1) AND REF(DEA> REF(DEA,1),1)=1;
LL:=C< REF(C,1) AND REF(C< REF(C,1),1)=1;
DRAWICON(LL AND GG,-0.1,16);
DRAWICON(FF AND GG AND DEA> LLV(DEA,180),-0.3,9);
MM:=IF(MACD< 0,MACD,0);
JJ:=MM> REF(MM,1);
ZZ:=REF(JJ,1)=1;
介入区:(JJ AND ZZ)*DEA,POINTDOT,COLORFFFFFF;{MACD蓝柱缩短---指今日比昨天短}
STICKLINE(介入区=DEA,DEA,DIFF,0,0),COLORFFFFFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0,0),COLORFF00FF;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,0,0)COLOR00FF00;
STICKLINE(MACD>REF(MACD,1)AND MACD,0,MACD,0,0),COLORYELLOW;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,0,0),COLORRED;
持:IF(DIFF>=DEA,DIFF,DRAWNULL),COLORRED;
观:IF(DEA>=DIFF,DEA,DRAWNULL),COLORFF9900;
股:IF(DIFF>=DEA,DEA,DRAWNULL),COLOR00FFFF;
望:IF(DEA>=DIFF,DIFF,DRAWNULL),COLOR00FF00;
AA:=BARSLAST(REF(CROSS(DIFF,DEA),1));
BB:=REF(CLOSE,AA+1)>CLOSE AND DIFF>REF(DIFF,AA+1) AND CROSS(DIFF,DEA);
进:DRAWLINE(AA=0,DEA,BB,DEA,0),COLOR0000FF;
STICKLINE(BB,0,0.1,0,1),COLORFFFFFF;
{股旁网-股票公式网站 www.gupang.com}
火:=BARSLAST(EMA(CLOSE,5)<REF(EMA(CLOSE,5),1)),COLORRED;
山:=COUNT(EMA(CLOSE,5)>REF(EMA(CLOSE,5),1),5),COLORGREEN;
DRAWTEXT(REF(火,3)>0 AND REF(火,2)>0 AND REF(火,1)>0 AND 火=0 AND REF(火,1)>山,DIFF,'●'),COLORRED;
DRAWTEXT(REF(火,3)>0 AND REF(火,2)>0 AND REF(火,1)>0 AND 火=0 AND REF(火,1)>山,DIFF,'¤'),COLORYELLOW;
STICKLINE(REF(山,1)=0 AND 山>0,0,0.1{-1},5,2),COLORRED;
DRAWTEXT(REF("KDJ.J",1)<0 AND "KDJ.J">0,DIFF,'短'),COLORRED ;

通达信实战很强的MACD指标公式

 

相关文章