在线检测未来函数

通达信MACD资金趋势指标公式

来源:Internet,编辑:股旁网,2010-08-21

使用说明:可做日线波段,也可以30分钟或60分钟做短线,尾盘买入,第二天或第三天可以获利出局,最好结合KDJ金叉买入仅供参考,更多用法请自行参悟.

A:=VOL*C; B:=SUM(A,1)/SUM(VOL,1);
B1:=EMA(B,17); 资金:=(B-B1)*100/B; DIFF:EMA(资金,12)-EMA(资金,26);
DEA: EMA(DIFF,9); M: 2*(DIFF-DEA), COLORSTICK;
{红色立柱}
STICKLINE(M>=REF(M,1)AND M>0,0,M,2.2,0),COLOR000088;
STICKLINE(M>=REF(M,1)AND M>0,0,M,1.5,0),COLOR0000AA;
STICKLINE(M>=REF(M,1)AND M>0,0,M,0.5,0),COLOR0000CC;
STICKLINE(M>=REF(M,1)AND M>0,0,M,0.1,0),COLOR0000EE;
{金黄色立柱}
STICKLINE(M<REF(M,1)AND M>0,0,M,2.2,0),COLOR338888;
STICKLINE(M<REF(M,1)AND M>0,0,M,1.3,0),COLOR33AAAA;
STICKLINE(M<REF(M,1)AND M>0,0,M,0.9,0),COLOR33CCCC;
STICKLINE(M<REF(M,1)AND M>0,0,M,0.1,0),COLOR33EEEE;
{粉红立柱}
STICKLINE(M>REF(M,1)AND M<0,0,M,2.2,0),COLORCC00CC;
STICKLINE(M>REF(M,1)AND M<0,0,M,1.1,0),COLOREE00EE;
STICKLINE(M>REF(M,1)AND M<0,0,M,0.1,0)COLORFF00FF;
{绿色立柱}
STICKLINE(M<=REF(M,1)AND M<0,0,M,2.2,0),COLOR009900;
STICKLINE(M<=REF(M,1)AND M<0,0,M,1.5,0),COLOR00BB00;
STICKLINE(M<=REF(M,1)AND M<0,0,M,1.1,0),COLOR00DD00;
STICKLINE(M<=REF(M,1)AND M<0,0,M,0.1,0),COLOR00FF00;
IF(DIFF<0,DIFF,0),COLORRED,LINETHICK2;
IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK2;
IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK2;
IF(DIFF>DEA,DEA,DEA),COLORWHITE,LINETHICK1;
低金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
{金黄色立柱}
STICKLINE(低金叉,-4,-2,2.5,0),COLOR338888;
STICKLINE(低金叉,-4,-2,1.5,0),COLOR33AAAA;
STICKLINE(低金叉,-4,-2,0.9,0),COLOR33CCCC;
STICKLINE(低金叉,-4,-2,0.1,0),COLOR33EEEE;
STICKLINE(低金叉,-0.4,-2,0.3,1),COLOREE00EE;
DRAWTEXT(低金叉,-3,' 低位金叉'),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二金:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
{粉红立柱}
STICKLINE(二金,0,-2.5,2,0),COLORCC00CC;
STICKLINE(二金,0,-2.5,1.5,0),COLOREE00EE;
STICKLINE(二金,0,-2.5,0.1,0)COLORFF00FF;
DRAWICON(二金,DEA*1.2,23) ;
DRAWTEXT(二金,-2,' 二次金叉'),COLORFF00FF;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1)AND CROSS(DIFF,DEA);
{股旁网-股票公式网站 www.gupang.com}
{绿色立柱}
STICKLINE(底背,0,2.5,2.5,0),COLOR009900;
STICKLINE(底背,0,2.5,1.4,0),COLOR00BB00;
STICKLINE(底背,0,2.5,0.5,0),COLOR00DD00;
STICKLINE(底背,0,2.5,0.1,0),COLOR00FF00;
STICKLINE(底背,4.5,2.5,0.3,1),COLOR0000FF;
DRAWLINE(A1=0,DEA,底背,DEA,0),COLORRED,LINETHICK2;
DRAWTEXT(底背,2,' 底背离'),COLOR00FF00;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
{深 青色立柱}
{STICKLINE(顶背,2.5,4,3,0),COLORCC0000; }
STICKLINE(顶背,2.5,4,2.5,0),COLORFF4400;
STICKLINE(顶背,2.5,4,1.5,0),COLORFF8800;
STICKLINE(顶背,2.5,4,0.2,0),COLORFFCC00;
STICKLINE(顶背,0.4,2.5,0,0),COLORFFFFFF;
{白色立柱}
STICKLINE(顶背,5,4,4,0),COLOR999999;
STICKLINE(顶背,5,4,3,0),COLORBBBBBB;
STICKLINE(顶背,5,4,2,0),COLORDDDDDD;
STICKLINE(顶背,5,4,1,0),COLORFFFFFF;
DRAWLINE(A2=0,DEA,顶背,DEA,0),COLORFFFF00,LINETHICK2;
DRAWTEXT(顶背,3.6,' 顶背离'),COLORFFFF00;

通达信MACD资金趋势指标公式

 

相关文章