在线检测未来函数

通达信MACD获利指标公式

来源:Internet,编辑:股旁网,2011-05-15

SHORT:=12;LONG:=26;MID:=9;
HL:=EMA(WINNER(C)*100,10);
JC:=EMA((WINNER(C*POW(1.1,0.75))*100-WINNER(C*POW(1.1,-0.75))*100),10);
DIFF:EMA(HL,SHORT)-EMA(JC,LONG);
DEA:EMA(DIFF,MID);
MACD:5*(DIFF-DEA), COLORSTICK;
AA:=LAST(MACD>=REF(MACD,1),3,1);
BB:=MACD<REF(MACD,1);
CC:=LAST(MACD<=REF(MACD,1),3,1);
DD:=MACD>REF(MACD,1);
STICKLINE(AA AND BB AND MACD>0,MACD,0,0,0),COLORDDDD00;
STICKLINE(CC AND DD AND MACD<0,MACD,0,0,0),COLOR0000DD;
0,VOLSTICK,COLORDDDD00;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
{股旁网-股票公式网站 www.GUpang.com}
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK1;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN;

通达信MACD获利指标公式

 

相关文章