在线检测未来函数

大智慧专测大盘指标公式

来源:Internet,编辑:股旁网,2011-06-15

LC:=REF(CLOSE,1);
动力1:EMA(EMA((SUM(IF(INDEXC>LC,VOL,0),42)/SUM(IF(INDEXC<=LC,VOL,0),42)),5),2)*100,COLORGRAY,linethick2;
动力2:EMA(EMA((SUM(IF(INDEXC>LC,VOL,0),55)/SUM(IF(INDEXC<=LC,VOL,0),55)),5),2)*100,ColorD49D56,linethick2;
STICKLINE(CROSS(250,动力1),350,400,9,0),COLOR00ff00;
STICKLINE(CROSS(400,动力1),300,400,9,0),COLORff00ff;
关注:IF(动力1<70,70,50),LINETHICK2,COLORffcc66;
WVAD10:=MA((INDEXC-INDEXO)/(INDEXH-INDEXL)*VOL,10)/1000+50;
DRAWTEXTABS(5,5,'股旁网 www.gupang.com'),linethick1,COLOR00EEff;
真金:IF(CROSS(WVAD10,50) AND 关注>50 AND 动力1<400 AND ZIG(1,19)>REF(ZIG(1,19),1),200,50),LINETHICK2,COLORBLUE;
白银:IF(CROSS(WVAD10,50) AND 动力1<400 AND ZIG(1,19)>REF(ZIG(1,19),1),150,50),LINETHICK2,COLORYELLOW;
铜钱:IF(CROSS(WVAD10,50),100,50),LINETHICK2,COLORRED;
Var2:=(INDEXC+INDEXH+INDEXL)/3;
Var3:=EMA(Var2,10);
Var4:=REF(Var3,1);
{持股:}STICKLINE(Var3>Var4,258,288,2,0),COLOR0066FF,linethick2;
{持币:}STICKLINE(Var3<Var4,218,248,2,0),COLORgreen,linethick2;
大盘:=COUNT(INDEXC>REF(INDEXC,1),3)=3; {连续N天上涨}
动力:=COUNT(动力1<REF(动力1,1),3)=3; {连续N日下跌}
DRAWTEXT(FILTER(大盘 AND 动力,2),动力1,'小心'),ALIGN1,ColorFFE900;
DRAWICON(FILTER(大盘 AND 动力,2),动力1+30,8),ALIGN1;
50,LINETHICK2,COLORYELLOW;
250,LINETHICK2,COLORff00ff;
stickline(c>0,400,400,5,0),LINETHICK2,COLORGREEN;

大智慧专测大盘指标公式

 

相关文章