在线检测未来函数

通达信改进了的MACD指标公式

来源:Internet,编辑:股旁网,2011-08-26

DIFF:EMA(CLOSE,7) - EMA(CLOSE,19);
DEA:EMA(DIFF,9);
DRAWBAND(DIFF,RGB(200,50,55),DEA,RGB(50,100,10));
MACD:2*(DIFF-DEA),COLORSTICK;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
STICKLINE(B1>0,-0.1,0,1,0),COLORRED;
STICKLINE(B2>0,-0.1,0,1,0),COLORFF00FF;
STICKLINE(B3>0,-0.1,0,1,0),COLORYELLOW;
STICKLINE(D1>0,0.1,0,1,0),COLOR00FF00;
STICKLINE(D2>0,0.1,0,1,0),COLORFFCC66;
STICKLINE(D3>0,0.1,0,1,0),COLORWHITE;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORRED;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORYELLOW;
STICKLINE(MACD<REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORCYAN;
STICKLINE(MACD>=REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORMAGENTA;
STICKLINE(C>0,0,0,50,1),COLORBLUE;
{www.gUPang.com 股旁网_最新股票指标公式}
MACD底背:IF(B1>0,-0.1,0),COLORRED,POINTDOT;
KDJ底背:IF(B2>0,-0.1,0),COLORFF00FF,POINTDOT;
RSI底背:IF(B3>0,-0.1,0),COLORYELLOW,POINTDOT;
MACD顶背:IF(D1>0,0.1,0),COLOR00FF00,POINTDOT;
KDJ顶背:IF(D2>0,0.1,0),COLORFFCC66,POINTDOT;
RSI顶背:IF(D3>0,0.1,0),COLORWHITE,POINTDOT;
强:IF(DIFF>MA(DIFF,2),DIFF,DRAWNULL),COLORRED,LINETHICK2;
弱:IF(DEA>MA(DEA,2),DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
DRAWICON(CROSS(DIFF,DEA),DEA,5);
DRAWICON(CROSS(DEA,DIFF),DEA,27);
A:=REF(DIFF,1)<REF(DIFF,2) AND REF(DIFF,2)<REF(DIFF,3) AND DIFF>REF(DIFF,1);
B:=REF(DIFF,1)>REF(DIFF,2) AND REF(DIFF,2)>REF(DIFF,3) AND DIFF<REF(DIFF,1);
DRAWICON(A,DIFF,1);
DRAWICON(B,DIFF,2);
STICKLINE((MACD > 0),0,MACD,0.1,0),COLOR0000CC;
STICKLINE((MACD > 0),0,MACD*0.9,0.1,0),COLOR0000EE;
STICKLINE((MACD > 0),0,MACD*0.8,0.1,0),COLOR0011FF;
STICKLINE((MACD > 0),0,MACD*0.7,0.1,0),COLOR0033FF;
STICKLINE((MACD > 0),0,MACD*0.6,0.1,0),COLOR0055FF;
STICKLINE((MACD > 0),0,MACD*0.5,0.1,0),COLOR0077FF;
STICKLINE((MACD > 0),0,MACD*0.4,0.1,0),COLOR0099FF;
STICKLINE((MACD > 0),0,MACD*0.3,0.1,0),COLOR00BBFF;
STICKLINE((MACD > 0),0,MACD*0.2,0.1,0),COLOR00DDFF;
STICKLINE((MACD > 0),0,MACD*0.1,0.1,0),COLOR00FFFF;
STICKLINE((MACD < 0),0,MACD,0.1,0),COLORCC0033;
STICKLINE((MACD < 0),0,MACD*0.9,0.1,0),COLOREE0033;
STICKLINE((MACD < 0),0,MACD*0.8,0.1,0),COLORFF1133;
STICKLINE((MACD < 0),0,MACD*0.7,0.1,0),COLORFF3333;
STICKLINE((MACD < 0),0,MACD*0.6,0.1,0),COLORFF5533;
STICKLINE((MACD < 0),0,MACD*0.5,0.1,0),COLORFF7733;
STICKLINE((MACD < 0),0,MACD*0.4,0.1,0),COLORFF9933;
STICKLINE((MACD < 0),0,MACD*0.3,0.1,0),COLORFFBB33;
STICKLINE((MACD < 0),0,MACD*0.2,0.1,0),COLORFFDD33;
STICKLINE((MACD < 0),0,MACD*0.1,0.1,0),COLORFFFF33;

通达信改进了的MACD指标公式

 

相关文章