在线检测未来函数

通达信月周日MACD指标公式

来源:Internet,编辑:股旁网,2011-09-27

月DIF:="MACD.DIF#MONTH"COLOR0080FF;
月DEA:="MACD.DEA#MONTH",COLOR0080FF,LINETHICK2;
周DIF:="MACD.DIF#WEEK"COLORRED;
周DEA:="MACD.DEA#WEEK",COLORRED,LINETHICK2;
日DIF:="MACD.DIF",COLORWHITE;
日DEA:="MACD.DEA",COLORWHITE,LINETHICK2;
DRAWBAND(月DIF,RGB(100,0,100),月DEA,RGB(120,120,120));
DRAWBAND(周DIF,RGB(200,20,10),周DEA,RGB(10,100,200));
DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORMAGENTA;
DEA:EMA(DIF,9);
{MACD:(DIF-DEA)*2,COLORSTICK;}
{www.gUPang.com 股旁网_最新股票指标公式}
红色启动埋伏:=(EMA(IF(LOW<=LLV(LOW,30),(SMA(ABS(LOW-REF(LOW,1)),30,1))/(SMA(MAX(LOW-REF(LOW,1),0),30,1)),0),3))*(10),COLORRED,LINETHICK2;
DIFF:=EMA(CLOSE,11)-EMA(CLOSE,26);
红1柱:CROSS(DIF,DEA) AND CROSS(MACD,0),COLORBLUE;
STICKLINE(MACD>0,MACD,0,-1,1),COLORRED;
STICKLINE(MACD<0,MACD,0,-1,1),COLORCCCC00;
DRAWICON(ISLASTBAR=1 AND MACD>REF(MACD,1),HHV(MACD,60),1);
DRAWICON(ISLASTBAR=1 AND MACD<REF(MACD,1),HHV(MACD,60),2);
VAR1:=HHV(DEA,53);
VAR2:=LLV(DEA,55);
VAR3:=DEA-(DIFF-DEA);
UP:IF(DIFF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1),COLORBB9A00;
DN:IF(DIFF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR3),VAR2),COLORAA00CC;
止跌:=(REF(EVERY(C<O,2),1) AND C>O);
VAR1N:=MA(CLOSE,5),;
VAR2N:=MA(CLOSE,10);
VAR3N:=(VAR1N-CLOSE)/CLOSE>3/100;
VAR4N:=(VAR2N-VAR1N)/VAR1N>0.03;
VAR5N:=LLV(CLOSE,30)=LLV(CLOSE,120);
底部:=VAR3N AND VAR4N AND VAR5N;
包赚小赔:BARSLAST(底部)<=2 AND 止跌,COLORMAGENTA;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1,COLORMAGENTA;
STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;
DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;
埋伏金叉:红色启动埋伏 AND 低位金叉,COLORGREEN;
A:=EMA(CLOSE,2);
B:=EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42);
低位金叉买:CROSS(A,B) AND 低位金叉,COLORCYAN;
日金:IF(CROSS(日DIF,日DEA),0.5,0),COLORWHITE;
周金:IF(CROSS(周DIF,周DEA),1,0),COLORLICYAN;
月金:IF(CROSS(月DIF,月DEA),1.5,0),COLORMAGENTA;
STICKLINE(周金,0,0.08,6,0),COLORLICYAN;
DRAWTEXT(周金,0.16,'周金叉'),COLORLICYAN;
STICKLINE(月金,0,0.08,6,0),COLORMAGENTA;
DRAWTEXT(月金,0.17,'月金叉'),COLORMAGENTA;
日死:IF(CROSS(日DEA,日DIF),-0.5,0),COLORYELLOW;
周死:IF(CROSS(周DEA,周DIF),-1,0),COLORBLUE;
月死:IF(CROSS(月DEA,月DIF),-1.3,0),COLORGREEN;

通达信月周日MACD指标公式

 

相关文章