在线检测未来函数

通达信K线说话主图指标公式

来源:Internet,编辑:股旁网,2011-10-04

早晨之星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏之星:=REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND
CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE!=HIGH;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1) > REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5);
倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5);
锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5);
吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1));
乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1));
十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1));
平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1)-REF(LOW,2))/REF(LOW,1)<=0.001);
大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018;
红三兵:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND
(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND
(CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))
AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND
REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
光脚阴线:=LOW=CLOSE AND HIGH!=LOW;
光头阳线:=HIGH=CLOSE AND HIGH!=LOW;
分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
十字星:=CLOSE=OPEN AND HIGH!=LOW;
大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;
好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)
OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);
倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1);
DRAWTEXT(长下影 OR 长上影 OR 倾盆大雨,H+H*0.02,IF(长上影,'长上影',IF(长下影,'长下影','倾盆大雨'))),COLORBLUE;
DRAWTEXT(黄昏之星 OR 早晨之星,IF(早晨之星,H,L),IF(黄昏之星,IF(十字星,'黄昏十字星','黄昏之星'),IF(十字星,'早晨十字星','早晨之星'))),COLORGREEN;
DRAWTEXT(大阴烛 OR 大阳烛 OR 十字星,IF(大阴烛,L,H),IF(大阴烛,'大阴烛',IF(大阳烛,'大阳烛','十字星'))),COLORCYAN;
DRAWTEXT(下跌三部曲 OR 上升三部曲 OR 长十字,H+H*0.03,IF(下跌三部曲,'下跌三部曲',IF(上升三部曲,'上升三部曲','长十字'))),COLORRED;
DRAWTEXT(光脚阴线 OR 光头阳线 OR 跳空缺口,O,IF(光脚阴线,'光脚阴线',IF(光头阳线,'光头阳线','跳空缺口'))),COLORMAGENTA;
DRAWTEXT(红三兵 OR 三只乌鸦 OR 分离,L+L*0.03,IF(红三兵,'红三兵',IF(三只乌鸦,'三乌鸦','分离'))),COLORBROWN;{三只乌鸦}
DRAWTEXT(红三兵 ,L+L*0.03,'红三兵'),COLORMAGENTA;{红三兵COLORLIRED}
DRAWTEXT(乌云盖顶 OR 曙光初现 OR 好友反攻,IF(乌云盖顶,H,L-L*0.01),IF(乌云盖顶,'乌云盖顶',IF(曙光初现,'曙光初现','好友反攻'))),COLORLIGRAY;
DRAWTEXT(射击之星 OR 吊颈 OR 十字胎,IF(射击之星,H,L),IF(射击之星,'射击之星',IF(吊颈,'吊颈','十字胎'))),COLORLIBLUE;
DRAWTEXT(锤头 OR 倒转锤头 OR 孕育线,IF(锤头,H,L),IF(锤头,'锤头',IF(倒转锤头,'倒转锤头','孕育线'))),COLORLIGREEN;
DRAWTEXT(平顶 OR 平底,IF(平顶,H,L),IF(平底,'平底','平顶')),COLORLICYAN;
DRAWTEXT(穿头破脚 OR 身怀六甲 OR 双飞乌鸦,IF(穿头破脚,L,H+H*0.05),IF(穿头破脚,'穿头破脚',IF(身怀六甲,'身怀六甲','双飞乌鸦'))),COLORLIRED;
DRAWTEXT(多方炮 OR 出水芙蓉,L-L*0.0005,IF(多方炮,'多方炮','出水芙蓉')),COLORYELLOW;
{www.gUPang.com 股旁网_最新股票指标公式}
墓碑十字星:=H/MAX(C,O)>=1.04 AND MIN(C,O)/L<=1.003 AND BETWEEN(MAX(C,O)/MIN(C,O),1.005,1.001);
吊颈线:=H/MAX(C,O)<=1.008 AND L/MIN(C,O)<=0.97 AND BETWEEN(MAX(C,O)/MIN(C,O),1.005,1.001);
STICKLINE(墓碑十字星,O,O+(C-O)/3,4,0),COLOR0000FF;
STICKLINE(吊颈线,O,O+(C-O)/3,4,0),COLOR008800;
DRAWTEXT(墓碑十字星,L,'●墓碑'),COLORWHITE;
DRAWTEXT(吊颈线,H*1.007,'●吊颈'),COLORWHITE;
搓揉线:=(REF(H,1)-MAX(REF(C,1),REF(O,1)))/(REF(H,1)-REF(L,1))>0.6
AND (MIN(O,C)-L)/(H-L)>0.6;
DRAWTEXT(搓揉线,H*1.007,'●搓揉线'),COLORWHITE;

通达信K线说话主图指标公式

 

相关文章