在线检测未来函数

通达信K线形态+缺口提示主图指标公式

来源:Internet,编辑:股旁网,2011-10-08

上市日期:FINANCE(42),NODRAW;
{标缺口}
LL:=REF(L,1);HH:=REF(H,1);
上跳:=L>HH;下跳:=H<LL;
DRAWICON(上跳,L*0.9952,1);
DRAWICON(下跳,H*1.0058,2);
{涨跌停}
涨停:=CLOSE>REF(CLOSE,1)*1.095 AND CLOSE=HIGH;
跌停:=CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW;
STICKLINE(涨停,O,C,1,0),COLOR00FFFF;
STICKLINE(跌停,O,C,1,0),COLORFF0000;
GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L);
明日支撑:=L+(C-GJ);
阻:REF(明日阻力 , 1),NODRAW;
支:REF(明日支撑 , 1),NODRAW,COLORRED;
STICKLINE(ISLASTBAR AND C>=阻,阻,阻,10,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND C<阻,阻,阻,10,1),COLOR00FF00;
STICKLINE(ISLASTBAR AND C>=支,支,支,10,1),COLORFF00FF;
STICKLINE(ISLASTBAR AND C<支,支,支,10,1),COLORFF8800;
DRAWTEXT_FIX(C>1,0,0.02,0,'K线形态:'),COLORFFFFFF;
早晨之星:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
黄昏之星:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2)),1,0));
长十字:=CONST(IF((CLOSE=OPEN AND HIGH/LOW >1.03),1,0));
垂死十字:=CONST(IF((CLOSE=OPEN AND CLOSE=LOW AND CLOSE=HIGH),1,0));
早晨十字星:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
黄昏十字星:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1) > REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2)),1,0));
射击之星:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5)),1,0));
倒转锤头:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5)),1,0));
锤头:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5)),1,0));
吊颈:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5)),1,0));
穿头破脚:=CONST(IF(((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1))),1,0));
乌云盖顶:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1)),1,0));
曙光初现:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1)),1,0));
身怀六甲:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1))),1,0));
十字胎:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1))),1,0));
平顶:=CONST(IF((ABS(HIGH-REF(HIGH,1))/HIGH<0.001),1,0));
平底:=CONST(IF(((ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1)-REF(LOW,2))/REF(LOW,1)<=0.001)),1,0));
大阳烛:=CONST(IF((CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018),1,0));
三个白武士:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1)),1,0));
双飞乌鸦:=CONST(IF((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98),1,0));
孕育线:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100),1,0));
多方炮:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN),1,0));
出水芙蓉:=CONST(IF(((OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60)))) AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049)),1,0));
上升三部曲:=CONST(IF((REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4)),1,0));
下跌三部曲:=CONST(IF(( REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,4)),1,0));
跳空缺口:=CONST(IF(HIGH<REF(LOW,1) OR LOW>REF(HIGH,1),1,0));
三只乌鸦:=CONST(IF((REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1)),1,0));
光脚阴线:=CONST(IF((LOW=CLOSE AND HIGH!=LOW),1,0));
光头阳线:=CONST(IF((HIGH=CLOSE AND HIGH!=LOW),1,0));
{www.gUPaNg.com 股旁网_最新股票指标公式}
分离:=CONST(IF((OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0),1,0));
长下影:=CONST(IF(((MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667),1,0));
长上影:=CONST(IF(((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667),1,0));
十字星:=CONST(IF((CLOSE=OPEN AND HIGH=LOW),1,0));
大阴烛:=CONST(IF((OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018),1,0));
好友反攻:=CONST(IF(((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002) OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)),1,0));
倾盆大雨:=CONST(IF((REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1)),1,0));
VS1:=IF(早晨之星=1,0+0.08,0);
VS2:=IF(黄昏之星=1,VS1+0.08,VS1);
VS3:=IF(长十字=1,VS2+0.08,VS2);
VS4:=IF(垂死十字=1,VS3+0.08,VS3);
VS5:=IF(早晨十字星=1,VS4+0.08,VS4);
VS6:=IF(黄昏十字星=1,VS5+0.08,VS5);
VS7:=IF(射击之星=1,VS6+0.08,VS6);
VS8:=IF(倒转锤头=1,VS7+0.08,VS7);
VS9:=IF(锤头=1,VS8+0.08,VS8);
VS10:=IF(吊颈=1,VS9+0.08,VS9);
VS11:=IF(穿头破脚=1,VS10+0.08,VS10);
VS12:=IF(乌云盖顶=1,VS11+0.08,VS11);
VS13:=IF(曙光初现=1,VS12+0.08,VS12);
VS14:=IF(身怀六甲=1,VS13+0.08,VS13);
VS15:=IF(十字胎=1,VS14+0.08,VS14);
VS16:=IF(平顶=1,VS15+0.06,VS15);
VS17:=IF(平底=1,VS16+0.08,VS16);
VS18:=IF(大阳烛=1,VS17+0.08,VS17);
VS19:=IF(三个白武士=1,VS18+0.08,VS18);
VS20:=IF(双飞乌鸦=1,VS19+0.08,VS19);
VS21:=IF(孕育线=1,VS20+0.08,VS20);
VS22:=IF(多方炮=1,VS21+0.08,VS21);
VS23:=IF(出水芙蓉=1,VS22+0.08,VS22);
VS24:=IF(上升三部曲=1,VS23+0.08,VS23);
VS25:=IF(下跌三部曲=1,VS24+0.08,VS24);
VS26:=IF(跳空缺口=1,VS25+0.08,VS25);
VS27:=IF(三只乌鸦=1,VS26+0.08,VS26);
VS28:=IF(光脚阴线=1,VS27+0.08,VS27);
VS29:=IF(光头阳线=1,VS28+0.08,VS28);
VS30:=IF(分离=1,VS29+0.08,VS29);
VS31:=IF(长下影=1,VS30+0.08,VS30);
VS32:=IF(长上影=1,VS31+0.08,VS31);
VS33:=IF(十字星=1,VS32+0.08,VS32);
VS34:=IF(大阴烛=1,VS33+0.08,VS33);
VS35:=IF(好友反攻=1,VS34+0.08,VS34);
VS36:=IF(倾盆大雨=1,VS35+0.08,VS35);
DRAWTEXT_FIX(早晨之星=1,VS1,0.02,0,'早晨之星'),COLORFF00FF;
DRAWTEXT_FIX(黄昏之星=1,VS2,0.02,0,'黄昏之星'),COLORFFFF00;
DRAWTEXT_FIX(长十字=1,VS3,0.02,0,'长十字'),COLOR00FFFF;
DRAWTEXT_FIX(垂死十字=1,VS4,0.02,0,'垂死十字'),COLORFFFF00;
DRAWTEXT_FIX(早晨十字星=1,VS5,0.02,0,'早晨十字星'),COLORFF00FF;
DRAWTEXT_FIX(黄昏十字星=1,VS6,0.02,0,'黄昏十字星'),COLORFFFF00;
DRAWTEXT_FIX(射击之星=1,VS7,0.02,0,'射击之星'),COLORFFFF00;
DRAWTEXT_FIX(倒转锤头=1,VS8,0.02,0,'倒转锤头'),COLORFF00FF;
DRAWTEXT_FIX(锤头=1,VS9,0.02,0,'锤头'),COLOR0000FF;
DRAWTEXT_FIX(吊颈=1,0.02,VS10,0,'吊颈'),COLORFFFF00;
DRAWTEXT_FIX(穿头破脚=1,VS11,0.02,0,'穿头破脚'),COLORFFFF00;
DRAWTEXT_FIX(乌云盖顶=1,VS12,0.02,0,'乌云盖顶'),COLORFFFF00;
DRAWTEXT_FIX(曙光初现=1,VS13,0.02,0,'曙光初现'),COLORFF00FF;
DRAWTEXT_FIX(身怀六甲=1,VS14,0.02,0,'身怀六甲'),COLOR00FFFF;
DRAWTEXT_FIX(十字胎=1,VS15,0.02,0,'十字胎'),COLOR00FFFF;
DRAWTEXT_FIX(平顶=1,VS16,0.02,0,'平顶'),COLORFFFFFF;
DRAWTEXT_FIX(平底=1,VS17,0.02,0,'平底'),COLORFFFFFF;
DRAWTEXT_FIX(大阳烛=1,VS18,0.02,0,'大阳烛'),COLOR0000FF;
DRAWTEXT_FIX(三个白武士=1,VS19,0.02,0,'红三兵'),COLORFFFFFF;
DRAWTEXT_FIX(双飞乌鸦=1,VS20,0.02,0,'双飞乌鸦'),COLORFF0000;
DRAWTEXT_FIX(孕育线=1,VS21,0.02,0,'孕育线'),COLOR00FFFF;
DRAWTEXT_FIX(多方炮=1,VS22,0.02,0,'多方炮'),COLOR00FFFF;
DRAWTEXT_FIX(出水芙蓉=1,VS23,0.02,0,'出水芙蓉'),COLORFF00FF;
DRAWTEXT_FIX(上升三部曲=1,VS24,0.02,0,'上升三部曲'),COLORFF00FF;
DRAWTEXT_FIX(下跌三部曲=1,VS25,0.02,0,'下跌三部曲'),COLORFFFF00;
DRAWTEXT_FIX(跳空缺口=1,VS26,0.02,0,'跳空缺口'),COLOR00FFFF;
DRAWTEXT_FIX(三只乌鸦=1,VS27,0.02,0,'三只乌鸦'),COLORFFFF00;
DRAWTEXT_FIX(光脚阴线=1,VS28,0.02,0,'光脚阴线'),COLORFFFF00;
DRAWTEXT_FIX(光头阳线=1,VS29,0.02,0,'光头阳线'),COLOR0000FF;
DRAWTEXT_FIX(分离=1,VS30,0.02,0,'分离'),COLOR00FFFF;
DRAWTEXT_FIX(长下影=1,VS31,0.02,0,'长下影'),COLOR00FFFF;
DRAWTEXT_FIX(长上影=1,VS32,0.02,0,'长上影'),COLORFFFF00;
DRAWTEXT_FIX(十字星=1,VS33,0.02,0,'十字星'),COLOR00FFFF;
DRAWTEXT_FIX(大阴烛=1,VS34,0.02,0,'大阴烛'),COLORFF0000;
DRAWTEXT_FIX(好友反攻=1,VS35,0.02,0,'好友反攻'),COLORFF00FF;
DRAWTEXT_FIX(倾盆大雨=1,VS36,0.02,0,'倾盆大雨'),COLORFFFFFF;

通达信K线形态+缺口提示主图指标公式

 

相关文章