在线检测未来函数

通达信机会来临MACD指标公式

来源:Internet,编辑:股旁网,2011-11-07

A:EMA(CLOSE,9)-EMA(CLOSE,18);
B:EMA(A,7),LINETHICK1;
MACD:=2*(A-B);
STICKLINE(MACD>=0,MACD,0,0,0),COLORF00FF0;
STICKLINE(MACD<0,MACD,0,1,0),COLORF00FF0;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0,0 ),COLORFFFF00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFFFF00;
IF(A<0,A,0),COLORRED,LINETHICK1;
IF(A<0,0,A),COLORRED,LINETHICK1;
IF(A<B,A,B),COLOR00FF00,LINETHICK1;
IF(A>B,B,B),COLORWHITE,LINETHICK1;

机会来临:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,0.5,0),1),COLORGREEN;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
E:=CROSS(83,RSI);
STICKLINE( E,E,0.5,1,0),COLOR00FFFF;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWTEXT(E,0.85,' 逃顶'),COLORGREEN;
低位金叉:CROSS(A,B) AND A<-0.1,COLORRED;
STICKLINE(低位金叉,0,0.5,2,0),COLORRED;
JCCOUNT:=COUNT(CROSS(A,B),BARSLAST(B>=0));
二次金叉:CROSS(A,B) AND B<0 AND COUNT(JCCOUNT=2,21)=1,COLORYELLOW;
STICKLINE(二次金叉,0,0.2,2,0),COLORYELLOW;
DRAWICON(二次金叉,B*0.9,25) ;
DRAWICON(LLV(MACD,4)>0 AND MACD<REF(MACD,1) AND REF(MACD,1)>REF(MACD,2) AND REF(MACD,2)>REF(MACD,3),MACD,2);
DRAWICON(HHV(MACD,4)<0 AND MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3),MACD,1);

通达信机会来临MACD指标公式

 

相关文章